3 steps needed at laptop startup instead of 2 steps before

Can’t say I’ve been havi having this issue myself, would you mind deleting everything boot.log then restarting and posting boot.log here

I deleted the contents of /var/log/boot.log
Then I powered the laptop off.
Finally I started the laptop up.
This is the content of the /var/log/boot.log file

WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Volume group “luks” not found
Cannot process volume group luks
WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Volume group “luks” not found
Cannot process volume group luks
/dev/mapper/luks-708e0d88-4db9-4713-a5ac-aea1abe6e832: clean, 479801/29327360 files, 58147508/117306241 blocks
[ 21.282609] libvirt-guests.sh[976]: libvirt-guests is configured not to start any guests on boot

can you run

systemd-analyze blame


systemd-analyze critical-chain

also this is my grub

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_CMDLINE_LINUX_DEFAULT="quiet cryptdevice=UUID=2ad2d1b8-9969-4645-b888-82a3b3fcdbd3:luks-2ad2d1b8-996$

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

systemd-analyze blame

      8.864s apt-daily.service
      7.876s NetworkManager-wait-online.service
      5.597s plymouth-quit-wait.service
      3.570s purism-power-optimisations.service
      2.725s apparmor.service
      1.346s systemd-udev-settle.service
      1.067s fwupd.service
       349ms exim4.service
       316ms dev-mapper-luks\x2d708e0d88\x2d4db9\x2d4713\x2da5ac\x2daea1abe6e832.device
       287ms systemd-logind.service
       245ms udisks2.service
       205ms upower.service
       204ms accounts-daemon.service
       201ms ModemManager.service
       196ms acpi-support.service
       195ms grub-common.service
       187ms networking.service
       158ms systemd-timesyncd.service
       148ms bluetooth.service
       144ms libvirtd.service
       129ms systemd-cryptsetup@luks\x2da340786a\x2df694\x2d48e0\x2da719\x2d8c5755911263.service
       128ms avahi-daemon.service
       121ms NetworkManager.service
       121ms keyboard-setup.service
       117ms packagekit.service
       114ms wpa_supplicant.service
        98ms bolt.service
        86ms systemd-fsck@dev-disk-by\x2duuid-54bc1128\x2da72c\x2d47ab\x2d8343\x2dde56912aeec4.service
        80ms systemd-journald.service
        74ms ntp.service
        69ms user@1000.service
        63ms user@119.service
        61ms systemd-udev-trigger.service
        58ms lvm2-monitor.service
        56ms brltty.service
        50ms systemd-udevd.service
        50ms polkit.service
        47ms plymouth-start.service
        47ms rsyslog.service
        47ms gdm.service
        45ms systemd-rfkill.service
        43ms systemd-cryptsetup@luks\x2d708e0d88\x2d4db9\x2d4713\x2da5ac\x2daea1abe6e832.service
        38ms colord.service
        36ms plymouth-read-write.service
        30ms systemd-modules-load.service
        30ms pppd-dns.service
        26ms switcheroo-control.service
        24ms systemd-sysusers.service
        22ms alsa-restore.service
        22ms libvirt-guests.service
        22ms ebtables.service
        21ms systemd-backlight@backlight:intel_backlight.service
        21ms resolvconf.service
        19ms systemd-tmpfiles-setup-dev.service
        16ms systemd-sysctl.service
        16ms systemd-tmpfiles-setup.service
        15ms systemd-remount-fs.service
        14ms systemd-user-sessions.service
        13ms ufw.service
        13ms boot.mount
        13ms blk-availability.service
        12ms dev-hugepages.mount
        12ms systemd-journal-flush.service
        11ms openvpn.service
        11ms sys-kernel-debug.mount
        10ms dev-mqueue.mount
         9ms systemd-random-seed.service
         9ms dev-mapper-luks\x2da340786a\x2df694\x2d48e0\x2da719\x2d8c5755911263.swap
         9ms kmod-static-nodes.service
         9ms systemd-update-utmp.service
         5ms console-setup.service
         5ms systemd-update-utmp-runlevel.service
         4ms sys-fs-fuse-connections.mount
         4ms rtkit-daemon.service
         2ms tmp.mount

systemd-analyze critical-chain

graphical.target @11.800s
└─multi-user.target @11.800s
└─exim4.service @11.450s +349ms
└─network-online.target @11.450s
└─NetworkManager-wait-online.service @3.573s +7.876s
└─NetworkManager.service @3.443s +121ms
└─dbus.service @3.441s
└─basic.target @3.409s
└─sockets.target @3.409s
└─virtlogd-admin.socket @3.409s

              └─sysinit.target @3.403s
                └─haveged.service @3.402s
                  └─apparmor.service @675ms +2.725s
                    └─local-fs.target @674ms
                      └─run-user-119.mount @5.056s
                        └─swap.target @670ms
                          └─dev-mapper-luks\x2da340786a\x2df694\x2d48e0\x2da719\x2d8c5755911263.swap @661ms +9ms
                            └─dev-mapper-luks\x2da340786a\x2df694\x2d48e0\x2da719\x2d8c5755911263.device @658ms

The line with your GRUB_CMDLINE_LINUX_DEFAULT= looks cut at the end by $
"quiet cryptdevice=UUID=2ad2d1b8-9969-4645-b888-82a3b3fcdbd3:luks-2ad2d1b8-996$

That bit at the end will be different for b9th of us, mostly interested in the lack of the hidden timeout

Just to say that I’ve had the same issue since for about the same time as OP. So at least that makes two of us.

What does your /etc/default/grub look like? Try changing to hidden timeout values.

This is all my uncommented etc/default/grub
I do have hidden timeout values

GRUB_CMDLINE_LINUX_DEFAULT=“quiet cryptdevice=UUID=708e0d88-4db9-4713-a5ac-aea1abe6e832:luks-708e0d88-4db9-4713-a5ac-aea1abe6e832 root=/dev/mapper/luks-708e0d88-4db9-4713-a5ac-aea1abe6e832 resume=/dev/mapper/luks-708e0d88-4db9-4713-a5ac-aea1abe6e832 splash”


it seems the only difference in our grub file is the line

Can other people post the value of their
in etc/default/grub ?

I have one final theory. Can you post the contents of

Sudo lsblk -o name,uuid,mountpoint


Sudo nano /etc/crypttab


Sudo nano /etc/fstab

Basically this

Sudo lsblk -o name,uuid,mountpoint

loop0 /snap/core/4917
loop1 /snap/firefox/118
loop2 /snap/core/5145
loop3 /snap/firefox/107
loop4 /snap/core/5328
loop5 /snap/firefox/124
├─sda1 7b8e7ee7-9474-470a-9479-f6a13913c4db /boot
├─sda2 5217e035-8bac-4ee6-a0cd-b2fe462f7f9a
│ └─luks-5217e035-8bac-4ee6-a0cd-b2fe462f7f9a
│ b1ee5984-0d41-4344-a514-bafb0244e9e9 /
3f8b6f4a-5c87-4ca8-8fa9-aba615c589c0 [SWAP]

Sudo nano /etc/crypttab

luks-5217e035-8bac-4ee6-a0cd-b2fe462f7f9a UUID=5217e035-8bac-4ee6-a0cd-b2fe462f7f9a $
luks-89be739b-ece0-43d5-b370-aded04e6b502 /dev/disk/by-id/ata-BIWIN_SSD_180504390119$

Sudo nano /etc/fstab

UUID=7b8e7ee7-9474-470a-9479-f6a13913c4db /boot ext4 defaults,noatime,di$
/dev/mapper/luks-5217e035-8bac-4ee6-a0cd-b2fe462f7f9a / ext4 default$
/dev/mapper/luks-89be739b-ece0-43d5-b370-aded04e6b502 swap swap default$
tmpfs /tmp tmpfs defaults,noatime,mo$

Just to confirm. Having same problem as OP. Appeared after last software-update several weeks ago. Didn’t use the laptop anymore afterwards except 2 or 3 times as it used to be a pain in the a.

Will delete the whole system and install it the 3rd time since buying it - not exactly what one would call reliable. Next time after without disc-encryption as so far it only created unnecessary problems.

1 Like

sudo lsblk -o name,uuid,mountpoint

NAME                             UUID                                 MOUNTPOINT
├─sda1                           54bc1128-a72c-47ab-8343-de56912aeec4 /boot
├─sda2                           708e0d88-4db9-4713-a5ac-aea1abe6e832 
│ └─luks-708e0d88-4db9-4713-a5ac-aea1abe6e832
│                                6b4d4652-d372-43d1-9cd3-6b199ff12315 /
                                 23285cdf-fb83-4b4a-a8f8-3ea85ca3ffad [SWAP]

sudo nano /etc/crypttab

luks-708e0d88-4db9-4713-a5ac-aea1abe6e832 UUID=708e0d88-4db9-4713-a5ac-aea1abe6e832     none luks
luks-a340786a-f694-48e0-a719-8c5755911263 /dev/disk/by-id/wwn-0x5002538e402670b1-part3  /dev/urandom swap,cipher

sudo nano /etc/fstab

UUID=54bc1128-a72c-47ab-8343-de56912aeec4 /boot          ext4    defaults,noatime,discard 0 2
/dev/mapper/luks-708e0d88-4db9-4713-a5ac-aea1abe6e832 /              ext4    defaults,noatime,discard 0 1
/dev/mapper/luks-a340786a-f694-48e0-a719-8c5755911263 swap           swap    defaults,noatime,discard 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

Ok, I’m pretty sure there’s a problem that the computer thinks one of the drives needs a password when actually it doesn’t. I would advise you email purism directly as getting it wrong could, in theory, leave you (heaven forbid it) with… The GRUB recovery terminal. As such I recommend you contact purism directly with your lsblk, crypttab, fstab and ask them what the correct configuration is. Sorry for not being able to be much help I had hoped it was just a GRUB misconfiguration.

1 Like

@ajlok I hear you. Bought the laptop in may and I seem to have all the bugs people are reporting on this forum at the same time. What’s annoying is the lack of communication. Customers are pretty much left waiting for ‘fixes’ without any communication from Purism about time-frame.

Will contact support, thanks tasty.

1 Like

It sounds like this may be very similar to the problem reported in this other thread. In that case I was asked for a password three times: once by Grub, then once for each of the encrypted partitions (root and swap). I was able to resolve it by taking the steps in the tutorial linked in that thread.

1 Like

Purism will be trying their best to solve these issues. But GNU/Linux requires a level of technical understanding to utilise its full potential, things like full drive encryption (which can be done in windows but not as securely as GNU/Linux), updating all drivers and programs with a single command and no restart (unless its kernel yet), automatic dependency install instead of downloading dodgy .exe files, the ability to edit every config file (so if you want to you can disable the GUI for password entry or change the logo animation), that you use you can directly edit the code have it peer reviewed by world-class coders and finally if it is of good quality for it to be pushed to billions of devices worldwide, that you can run the kernel on everything from a $5 computer to every single top 500 supercomputer. So yes GNU/Linux is not windows but that’s because Windows is s**t. Because Windows is a literal prison that restricts and constrains you BY DESIGN. So yes while I agree that GNU/Linux can be frustrating and hard, this is the price paid for vastly numerous advantages of running GNU/Linux, both technical and ethical. So please be patient with purism and post your issues both hear and on the tracker (if you prefer to tag me and I’ll upload them).

@mak provided the solution to this issue

see it there



sudo update-grub