Activities Menu

So last night I decided to try and install a new menu from gnome extensions website. I received an error message when I tried to install a new menu. Now my Activities menu is gone and with it my side panel of shortcuts. I’m trying to get to that particular settings where my gnome extensions are at but it’s proving difficult. I want to see or delete that ----> Gno-Menu <----- trouble maker. Don’t download Gno-Menu guys.

Any suggestions on how to fix this? Saving reinstall as my last resort.

I do not know if my experience will help you, but I went nuts with menus and Activities when I first received my Librem 13v3 with PureOS. The latter would disappear and I could not get any kind of Applications menu.

From my memory–senior moments possible–it turned out if I enabled the “Applications menu” extension, Activities completely disappeared due to an error.

Here is what I finally did:

  1. Went to Tweaks->Extensions to see if there were any related ‘triangle !’ (sic) error icons. (I could never figure out where those errors were logged.) I disabled those menu-related extensions and rebooted. I wanted “Dash to Panel” but that “Applications menu” extension kept failing with the error icon.

  2. I eventually found that my system did not have a proper list of the applications in order to construct the menu. This was in /etc/xdg/menus. There was a kde(?) one but no gnome one. Reinstalling gnome-menus finally generated the list that was needed.

  3. Went back to Tweaks and reenabled any menu-related extensions.

I think things started working immediately, but I may have rebooted.

I hope this might at least give you an idea of where to look.

1 Like

Totally gave me the solution. Thanks! Reinstall gnome. I need to find those commands and launch it through that ‘other’ terminal option.

Unable to currently do this since I’m at work but can you uninstall gnome? I’m thinking, isn’t a specific command appropriate? Like sudo apt-get uninstall task-gnome-desktop? Is that wrong?

I may be misunderstanding your intent, but I am not sure you would want to uninstall gnome itself. To redo the whole desktop is out of my league and would make me nervous on my own system, much less another’s. When I did this I ‘reinstalled’ only ‘gnome-menus’.

First, the following commands never helped me, but I have seen others suggest them when things were broken:

 sudo apt update --fix-missing
 sudo dpkg --configure -a

Next, I believe both apt and apt-get have --reinstall as parameters. For apt, it would be:

 sudo apt --reinstall install gnome-menus

That should force a reinstall ‘gnome-menus’, even though that package is already on the system. (Of course, this is an example; other packages should work as well.) It may fix anything that is broken.

I appreciate your help. I’ll give that a shot first. I’ll use console since I don’t have access to my Terminal from my Activities --> shortcut panel. :slightly_smiling_face:

Solved! Case closed :slight_smile:

That is always good to hear!

Thanks Wayne :slight_smile:

I just received my new Librem 15V3 and so far everything has gone well. It booted right up and everything seems to work so far. Except for the fact that i have never used Linux and am trying to find my way around the system.

The one issue I do have concerns the Librem Key. it does nothing which i assume is my mistake. When i booted the machine for the first time I just followed the instructions for the system. There were none for the Librem Key. I made up two passwords and they work fine. Then I tried sticking the Librem Key in and nothing.

I’m assuming I should have put the key in from the git-go and used it for the decryption and user passwords??? Does anyone know what to do about this? I’ll contact support if no one knows.

Also, I realize that people say you don’t need a firewall or anti-virus software for Linux but, do I? If so what do you Linux users recommend for those programs.

Last but not least I tried downloading and installing a couple of programs such as the TOR browser and I got a message that the install failed even though I was connected to the internet. Any thoughts on why?

Thanks, in advance.

I have never seen anyone not recommend using a firewall on Linux. I would definitely use one!

I suspect a firewall is there if you are using PureOS out-of-the-box. Look for the firewalld front-end. Personally, I installed the firewall-config package to have a GUI where I could change some of the port rules.

I do not use it, but clamav (anti-virus) is in the repository. Others would need to comment or maybe search through the threads here.

Hey OPS200.

I had the same issues. The Librem Key is not functional. So it doesn’t check the TPM. To use it you can download NitroKey.

To install programs, run in tilix (terminal):

sudo apt update

sudo apt upgrade

I hope this will help

I’m one of those who says you don’t really need that stuff. But that needs some explanation. Even on Windows, you’re probably better off with what Microsoft includes by default instead of a (paid) 3rd party tool. That’s not my opinion, but the one of many security experts, because those tools often can make your system more vulnerable instead of less. (Background: read here, make sure to follow all the included links). The firewalls that are somewhat popular for Windows users are “personal firewalls”. They mostly control what local programs can do. It expresses the mistrust that Windows users have in the programs they use.
On Linux, I think the most popular use for ClamAV and similar is on mail servers - to protect Windows end-users :wink: If you only install from trusted repositories, there’s little risk of infection (I’m not saying zero, of course there could be a breach).
Personally, I also didn’t really play with IPtables. Of course, it can make your system more secure. But by default there are already really few ports open. Also, I only use my laptop in my trusted home network. Admittedly, it’s not completely trusted. Currently, there are still some Android, Windows and proprietary routers, so I’m really waiting for phones, tablets and routers from Purism :wink:
In the end, it’s a personal decision. But treating external files with some healthy skepticism is more important than AV software.

Thanks for the response. I’m not going to worry about it. The firewall on this Librem seems to be working fine as is.