Adding matrix account to chatty, froze up chatty

  1. Have you tried to restore a previous backup?

I just deleted /home/purism/.purple/chatty/db/matrix.db and /home/purism/.purple/prefs.xml that made chatty responsive. Opened preferences disabled and deleted matrix account.

I would like to re-add matrix account so I may try again now that I know how to work with it if it freezes again

[EDIT]: turns out I can sign-out from other (main) device and then chatty will allow opening preferences.
However it’s still not usable with matrix, I’ll wait few updates or try to dump debug messages


[UPDATE]: chatty got updated and now I can add matrix account successfully.
And with that all my messages (signal, telegram and matrix) are giving notifications, this feels so much better.

There is no file handling with chatty though :frowning:


[UPDATE2]: chatty works in general for notifications, however if Usage app is opened it’s always using 100% CPU and in general user experience with chatty is not very good / smooth. Going back to either Fractal dev or Fluffychat (without notifications)

Are you using the Flatpak versions of Fractal/Fluffychat?

for fractal please follow

# Add the gnome-nightly repo
flatpak remote-add --user --if-not-exists gnome-nightly

# Install the nightly build
flatpak install --user gnome-nightly org.gnome.Fractal.Devel

This is dev version for encryption support.

As for fluffy, I see it’s having trouble with OpenGL. It was working well last time I tried. Now I can install it (just from flathub) but can’t open it

Asking a dumb question but I haven’t figured out a way to start a matrix conversation or group chat in Chatty. How do you do this or is it not possible at this time? Should I just use a different client?

Actually that’s a good point and I’ve no clue. I always used element on my desktop to start / join new chats. On phone I was simply using existing chats and at this point I’m not using chatty to test.

Does Fractal work on your device. I installed it and it give me a network error and then a Secret Service Error.

It works for me, although with some minor bugs. Have you installed the dev version?

Thanks for the reply. I installed both versions. The not devel version runs and I can log into my matrix homeserver but the encryption does not work. The devel version gives me the errors. I also can’t log into my matrix server (or any other) with chatty. I can access my server with element installed on Ubuntu or using riot on the internet. I cleaned up all of the flatpak apps and reinstalled but no difference. Did you install with flatpak?

I installed beta version, not developer, using terminal from here

definitely requires beta version for encryption to work

When I open Fractal beta the first screen shows an network error then a security error which claims the key ring is locked. There is no prompt to unlock like there is with Chatty. I have two of these phones and both do the same thing.

Are you using the latest beta version?

oh maybe u r not up to date for PureOS itself?
But keyring issue is because there is no gnome / gtk keyring working. You can get around it by using app called seahorse (it’s GUI app for keyring management).
I had similar issue in past: How to install fractal next

Thanks for the reply. Gnome keyring is installed. I installed seahorse and there is a a default keyring but it is empty. You said you added a key named login. Where did you install it?

Before going through seahorse, do you get password prompt after logging in to phosh (if yes, you definitely have working keyring and shouldn’t need extra app)

As for seahorse:
Sorry I maybe wrong (replying from memory, don’t have seahorse installed anymore).
In seahorse there is + then add new keyring (nothing special, normal keyring), name it exactly login give it whatever password you want.
That’s all.

Thanks for your help. I do get the prompt when logging into phosh. I added the key login with Seahorse and Fractal started working. For some reason it does not see the default keyring.

It requires keyring with name login.