Arch Linux with dm-crypt/LUKS fails to boot

I’ve been trying to install Arch Linux following the Installation guide with an encrypted root partition (dm-crypt and LUKS), however, with PureBoot I can’t get the system to boot.

I have tried using the encrypt hook as well as the sd-encrypt hook.

Without encryption everything works smoothly. Also I tried to setup everything the same way in a libvirt/QEMU VM and it worked as well.

The process stops showing me no more than the following output:

Loading the new kernel:

kexec -l /boot/vmlinuz-linux --initrd=/boot/initramfs-linux.img --append=" root=/dev/mapper/cryptroot rw loglevel=3 verbose intel_iommu=igfx_off  vt.default_red=0xff,0xff,0xff,0xff,0xff,0xff,0xff,0xff,0xff,0xff,0xff,0xff,0xff,0xff"

Starting the new kernel

I have tried as well to specify the root partition’s UUID instead of the, like PureOS seems to do it:

--append="root=UUID=8f953f1e-4391-4242-85e1-867e73327ca5 rw ..."

However, I’ve had no luck so far.

root:~# blkid 

/dev/nvme0n1p1: LABEL="boot" UUID="82292ed9-4285-43b2-8dbc-7d13fc0835ed" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="5c842a41-01"

/dev/nvme0n1p2: UUID="c7bd78bf-06de-4555-9475-c86a4fce48f7" TYPE="crypto_LUKS" PARTUUID="5c842a41-03"

/dev/mapper/cryptroot: LABEL="arch" UUID="8f953f1e-4391-4242-85e1-867e73327ca5" BLOCK_SIZE="4096" TYPE="ext4"


Does anybody have any idea what mistake I’m making?
How could I get some output of what’s going wrong?

Duplicate LUKS password prompt not appearing - Dual boot

I managed to solve it by specifying the i915 module in mkinitcpio.conf:

1 Like