BAT0 missing from /power_supply. Battery indicator shows no battery availble

A few days ago I restarted my Librem 14 and when it booted back up, the battery icon showed a red X in KDE plasma. Hovering over it displayed the message “no batteries available”. Listing the files in /sys/class/power_supply shows only AC when it used to show BAT0 as well. Since then I have tried looking at online solutions, reinstalled PureOS, and switched to a different Debian based distro (for more reasons that just trying to troubleshoot this). Any help is much appreciated.


tomsi@Grimoire:~$ upower -d
Device: /org/freedesktop/UPower/devices/line_power_AC
native-path: AC
power supply: yes
updated: Fri 16 Sep 2022 07:35:29 PM MDT (357 seconds ago)
has history: no
has statistics: no
warning-level: none
online: yes
icon-name: ‘ac-adapter-symbolic’

Device: /org/freedesktop/UPower/devices/DisplayDevice
power supply: no
updated: Fri 16 Sep 2022 07:29:34 PM MDT (712 seconds ago)
has history: no
has statistics: no
warning-level: none
icon-name: ‘battery-missing-symbolic’

daemon-version: 0.99.11
on-battery: no
lid-is-closed: no
lid-is-present: yes
critical-action: HybridSleep

I suggest re-seating the battery.

1 Like

This solution also worked for me. Thanks!