Bluetooth support for Librem 5

Since I can not connect to my car’s BT, I checked my L5 and dmesg | grep redpine says I have

[16782.763078] redpine_91x: FW Version :
[16782.763083] redpine_91x: RSI FW Version : 0000.
[16782.763089] redpine_91x: Driver Version : RS9116.NB0.NL.GNU.LNX.OSD.
[16782.763093] redpine_91x: Operating mode : 5 [Wi-Fi STA + BT EDR]
[16782.763097] redpine_91x: Firmware file : RS9116_NLINK_WLAN_BT_IMAGE.rps

I checked the file /etc/modprobe.d/librem5-devkit.conf
and it says dev_oper_mod=5 in two places:

# blacklist mainline driver (rsi):
blacklist rsi_91x
blacklist rsi_sdio
options rsi_91x load_flash_fw=1 feature_bitmap_9116=1 antenna_sel=3
options rsi_sdio dev_oper_mode=5

# blacklist vendor driver (redpine):
# blacklist redpine_91x
# blacklist redpine_sdio

# wlan_rf_power_mode values: 0x00 default, 0x11 medium, 0x22 low power
options redpine_91x dev_oper_mode=5 rsi_zone_enabled=1 antenna_diversity=1 wlan_rf_power_mode=0x00

# blacklist magnetometer as long as we don't use it
blacklist st_magn
blacklist st_magn_i2c
blacklist st_magn_spi

What is better to do? Change the opmode to 13 or switch to ?

I tried all versions, with dev_oper_mod=5 and dev_opermod=13. The latest version, works but only for bluetooth audio. None of the versions with neither of the oper_mods can connect to my car with the phone profile. Any ideas on how I can proceed?

I tried to flash the 2.51.11 version but flashing fails. So I am stuck with 1.2.20. The messages in dmesg of the failure to flash are:

[ 14.086724] redpine_91x: rsi_probe: ***** 9116 Module *****
[ 14.086841] redpine_91x: redpine_hal_device_init: oper_mode = 13, coex_mode = 2
[ 14.088018] redpine_91x: Received Board Version Number: 10
[ 14.089084] redpine_91x: rsi_load_firmware: Loading file RS9116_NLINK_WLAN_BT_IMAGE.rps
[ 14.090634] redpine_91x: FW Length = 82051 bytes
[ 14.090643] redpine_91x: ================================================
[ 14.090647] redpine_91x: ================ RSI Version Info ==============
[ 14.090650] redpine_91x: ================================================
[ 14.090653] redpine_91x: FW Version :
[ 14.090659] redpine_91x: RSI FW Version : 6f62.6e.65.3b.7261
[ 14.090665] redpine_91x: Driver Version : RS9116.NB0.NL.GNU.LNX.OSD.
[ 14.090668] redpine_91x: Operating mode : 13 [Wi-Fi STA + BT DUAL]
[ 14.090673] redpine_91x: Firmware file : RS9116_NLINK_WLAN_BT_IMAGE.rps
[ 14.090677] redpine_91x: ================================================
[ 14.269639] redpine_91x: device firmware doesn’t match proceed to upgrade …
[ 14.269659] redpine_91x: *** rsi_check_crc failed - will try reflash ***
[ 14.285046] redpine_91x: Burn Command Pass… Upgrading the firmware
[ 14.285054] redpine_91x: auto_fw_upgrade: Flash Start Address is not multiple of 4K
[ 14.285059] redpine_91x: Firmware upgrade failed - attempt RAM load
[ 14.285062] redpine_91x: Ram file magic 0x3a2f size 81987
[ 14.285067] redpine_91x: Bad ram FW magic
[ 14.285070] redpine_91x: ##### Firmware loading failed #####
[ 14.285097] redpine_91x: redpine_hal_device_init: Failed to load TA instructions
[ 14.285102] redpine_91x: rsi_probe: Failed in device init
[ 20.451005] redpine_91x: redpine_set_clr_tx_intention,357: Wait event failed
[ 20.451035] redpine_91x: rsi_tx_scheduler_thread,628: Failed to get tx_access
[ 26.590535] redpine_91x: redpine_set_clr_tx_intention,357: Wait event failed
[ 26.590571] redpine_91x: rsi_coex_scheduler_thread,112: Failed to get tx_access
[ 26.590632] redpine_91x: rsi_probe: Failed in probe…Exiting

Why is sharing an incomplete resumen? in the way is hard give a good answer.


Try: L5 Bluetooth stutter

Any ideas on how to get bluetooth working with the phone profile? Currently, the L5 doesn’t connect to my car’s bluetooth for handsfree calls.

Bluetooth support for Librem 5

Well, that sucks :frowning: I hope it will be supported in the near future.

I don’t know about the near future, but at the moment any bluetooth connection I initiate stutters like mad. I’d say it is unusable.

Okay. There appears to be one exception to the bluetooth-stuttering problem: I recently bought a pair of Roseland (an unknown brand to me) stereo speakers (at the Action store) that appear to work without a hitch or glitch.

1 Like

I’ve got BlueAnt speakers and they worked fine out-of-the-box with the Librem 5. Admittedly I am running the older PureOS version (still on amber).

I tried connecting to the bluetooth radio in our car without any luck. This probably the oldest bt incarnation we have at hand. It wouldn’t even connect.
The speakers I tried are a couple of years old. They all stutter when connectedbto the L5.
I also tried connecting to a small bt receiver I have hooked up to my stereo. It’s a bit more recent. It stutters every ten seconds or so.
No other device in our home (i.e. phones and tablets) have these problems.
The Roseland speakers I mentioned in my earlier post, I bought a couplenof weeks ago. I think they have bt 5.2 on board. They seem to work fine.
Could this be bt version related?

Hopefully it will be solved in coming versions of PureOS.

Okay, some news just in: I again connected to the bt-receiver that’s hooked up to my stereo, and now the stutter is gone…
I am using the same internet radio app, and the same station. Like before, I am not running any other apps that might interfere.

Does anybody have an explanation for this?

I have a Bose bluetooth speaker that works flawlessly along with my Raycon earbuds, but the bluetooth adapter I use in my car is stutter city. No clue what the issue might be.


May be on Inactive mode or Active mode.
Inactive mode: when monitor is OFF(ultralow cpu)
Active mode: when monitor is ON (full cpu)

I can say that I have tried this with gPodder, I’ve tried with other apps running with nothing else running, screen on screen off, doesn’t seem to be any correlation. I also tried turning off WiFi but that made no difference either. I’m thinking we need to wait for a new firmware?

With newer Bluetooth firmware available some stuter are gone, not sure what version bt your device it has?

There are a lot thing that could cause Stutering like DATA, CPU, BT version, Distance TX, BUS, BUG.

1 Like

I sometimes have a spontaneous issue with the bt-transmitter that’s hooked up to my audio-video receiver, so that sound gets chopped up in my receiving headphones. (I haven’t used the transmitter with the L5, though.) I correct the issue by turning the transmitter off, on again, and then reconnecting.


1 Like