Building coreboot from source (official script)


#266

Same here: 15 v3 updated to 4.8.1. All good. Thank you, @kakaroto and Purism.


#267

Hey kakaroto and all,

The link provided works however after clicking download, I get a ‘termporary error, retrying’ message.

https://mega.nz/#!TZUGyKBI!5rITrOXUUBXaThpWfwxc_Hks-UI64eKi7O_336Vn4og

Not sure if I’m clicking wrong… once downloaded everything should run smoothly as no other errors in the script. Thanks for the work here, kakaroto.

EDIT: My fault; I was running a few addons in purebrowser that were really screwing with purebrowser performance. there is no issue with the mega link. lol fake news :confused:


#268

Looks like I’m having trouble with get_and_patch_me_11 () at line 226 on a 13v2. (“Couldn’t automatically determine the direct link URL to download ME from.”) It suggests downloading the files from the mega.nz repository manually. Having done that, the path is:

~/building-coreboot/coreboot/me_11_repository.rar/Intel CSME 11.0 Firmware Repository Pack r51/11.0.18.1002_CON_LP_C0_NPDM_PRD_RGN.bin

Yet the line 226 error still triggers. Any ideas as to what I’m missing?

As background, I’m using the script at: https://source.puri.sm/coreboot/coreboot-files/raw/master/build_coreboot.sh, although I’ve also tried https://source.puri.sm/coreboot/coreboot-files.git as well as downloading direct from a link mladen sent via email. Same error regardless of the source.


#269

@worker: You’re saying “the path is” and you give me a path to an me bin file, maybe that’s the misundestanding, the script expects the rar file to be me_11_repository.rar not for the rar file to be extracted in a directory named me_11_repository.rar


#270

the file needs to be renamed to ‘me_11_repository.rar’ and left in the ‘coreboot’ folder.

I mistakenly threw the downloaded rar file into coreboot without renaming it and I ended up with an error at 226 as well.


#271

This link appears to be dead. Mega reports that “the link is invalid, the file has been deleted, or removed for violation”.


Fan full blast after sleep, coreboot and Intel ME
#273

@okennedy Believe that the ME 11.0 repository pack is now on release 52 (as of 8/8). It’s available at:

https://mega.nz/#!DNdDVQ7I!hronBMVN8m82JciiT6UQwtwh-LVlHXIo-NzTB0324rk

The forum that @kakaroto was using for the ME repository packs should be here, which should allow you to verify the release number.

That said, I’m not sure whether the build script needs an update to support r52.


#274

This was definitely the problem. Thanks @kakaroto and @vficarrotta.


#275

@worker: thanks! I’ve updated the ME URL in the script now.