Can not install Pure OS on a HP Laptop


i would like to install und run Pure OS on my HP Laptop 17-ca1216ng. Here you can look at the data sheet of the Laptop:

When I want to boot the ISO from the USB Flash Drive, it will not / it doesn’t boot the stick/the system, because of the error: “no suitable video mode found”.

I suppose the firmware for the graphics card or the firmware for the cpu is missing and I do not know how to solve that problem/issue. I downloaded the firmware from here, and I want to ask if this is the correct firmware whats neccesary and how can I use this firmware to be able to boot my Stick/Flash Drive to install PureOS?

the file “”. it contains a file named “firmware-amd-graphics_20210818-1_all.deb”. is t the right one? when correct, how can I use it? I extracted the deb.-paket and there are many files in it. I suppose some file of the vega.* Files would be the right one?

which firmware do I need and how can I use the firmware to boot the ISO-Stick?

thanx for your help and sorry for my bad English :slight_smile:

If you’re going to use non-free firmware on a non-Librem computer, why not just use vanilla Debian (with non-free firmware)?

1 Like

Hello johnk :slight_smile:

please dont ask. I would like to run PureOS, not Debian or another distro.

I have my reasons :slight_smile:

Please can you help me to solve the issue?


I guess you can try running Debian first, and if it works, copy the required firmware files to PureOS. (I’m not an expert, can’t provide more details, sorry).

1 Like

thats exactly my question.

The ISO / the Stick doesn’t start, it doesn’t boot, I can not boot the disk to install Pure OS.

So how can I integrate the firmware into the stick to boot the stick?

I tried to copy the firmware-files on a second flash drive und plugged it in during booting. But didn’t work.

It seems that copying the firmware simply on the flash drive is not sufficient … thats the point what I don’t understand… how to do it right

EDIT: Please note that I corrected my post. I used a wrong vocable/word. sorry

You can do (or try to do) whatever you want, but it is my understanding that PureOS is VERY similar to vanilla Debian with only free software, so it doesn’t make sense to me to put non-free software back into PureOS. I know that Debian is immediately upstream of PureOS, and there seems to be very little different from Debian to PureOS (I have both on different computers).

Sounds like what you want is to take the iso apart and put the firmware in it. I don’t know how to do this, and I don’t know that its even feasible.

You can try adding “nomodeset” to the boot parameters, but I’ve never used pureos so I don’t know what bootloader it uses (I don’t think its grub?) and thus can’t instruct you how to do so. But I think its worth looking into.

If it does work, you’ll have to install it first, then boot with nomodeset again, and then add the firmware (whichever it is) to its proper place.

First things first, though, see if nomodeset works at all.

unfortunately nomodeset doesn’t work …

sorry I forgot to add, to mention, that there is a second boot feature which offers the iso itself, labeled “nomodeset”.

but the same error occured … “no suitable video mode found”… after that error it seemes that the Stick searches all drives … I suppose for some firmware-files. On my second stick which i always plug in during booting, there are many firmware files for vega graphics, but I don’t know what file is the right one.

perhaps you can help me solving this problem.

You can try this suggestion:

But read the whole thread.

Over the past 10 years I’ve had a number of laptops that would not boot an install ISO on a USB stick (that other laptops would boot just fine). I was always able to burn the ISO to a CD and boot that on a USB CD drive.

It is also possible that it’s an AMD graphics driver issue. If it’s a firmware issue (and I have no idea) then the driver still has to want to use the firmware (i.e. load the firmware into whatever needs it).

If the driver wants to use the firmware, most likely it will automatically pick up the correct firmware file to use (so you just install all the AMD graphics firmware files). As has been suggested, it is possible that by using another distro that works with this hardware, you can find out which firmware file is required e.g. examine system logs for messages about loading firmware.

Here’s the bottom line: PureOS has always steered clear of AMD. Perhaps noone is using that combination. Perhaps you will be the one who first gets it working.

If you are desperate … when it fails to boot, if you have the laptop connected via ethernet, does the laptop appear on the network?

If you are desperate … install and boot PureOS on a portable drive (e.g. a USB flash drive) attached to a computer that works. Then use dpkg -i xxx.deb to install firmware for AMD graphics (pointless on that computer). Then boot the portable drive on the problematic laptop. If it works then image the portable drive to the internal drive. Then gparted to fix up the file system size, assuming that the portable drive is (much) smaller than the internal drive. (Keep the portable drive because you would be creating a situation that is inherently difficult to support and manage.)

To do the disk imaging would require a second bootable portable drive. If you absolutely refuse to pollute your laptop, even temporarily, by temporarily booting with Debian or Ubuntu then you would need to prepare a second portable drive with a bootable PureOS on it.

Does all of this work? Who knows?

One thing you haven’t told us is what operating system is currently installed on the laptop and whether you want to keep that. If the above procedure works and you follow it then you will be wiping out whatever is currently installed - and that might not be what you want.

Another complication is whether that laptop uses BIOS or UEFI and, if the latter, whether you can configure it so that PureOS will work.

Is it an option then to use different hardware? Or do you insist on PureOS on that specific problematic laptop?

1 Like

Be careful with that:

Hm? In how far? It is like it is, PureOS will not bring any microcode updates. That’s the curse of the FSF OS endorsement.


Hello guys :slight_smile:

At first I want to thank you all for your kind help!

I must appologize for not writing a few days, other things needed my attention.

I am happy, I made it! I really could install PureOS on my laptop. thanks to a tutorial which was also postet on this forum earlier. It contains the tip to use supergrubdisk.

By supergrub2disk I could boot and install PureOS. After installing I could install the drivers for network and also for the graphics card. I downloaded both from the Debian Webpage.

Everything is fine, but two issues are remaining, which I can’t solve.

a) When I install / activate the firewall ufw, it works, but when I start the pc the next time, its disabled. It doesn’t matter by what way I enable the firewall on the running system, the next time I start the pc the firewall is disabled.

b) I couldn’t install lsb for my printer driver. Unfortunately temporarily the lsb package/programme is not downloadable at “”. It says “the service is unavailable”. And i read on the web that lsb is no longer in the repos of debian, so it seems that I will not be able to get my printer working on PureOS.

Perhaps someone has a solution for both problems. :slight_smile:

Again: Many thanks for all your help! :slight_smile:

I am always happy nowadays to see, that computerforums can impart/convey Information and help to people who need help or can’t solve a problem. Thats just wonderful! :slight_smile:

Bye Kai

Edit: I already tried “sudo systemctl enable ufw” and enabled it, but It doesn’t solve the issue.

1 Like