Cannot boot up Linux Mint Live USB on Librem 14

(Sorry for the double post, I accidentally hit “Create Topic” before I was finished and deleted the first one.)

Hey all. I am attempting to install Linux Mint on my Librem 14 but am having a lot of trouble. I created a live USB using Etcher from a Mint iso. I know the USB works because I was able to boot into it on my desktop. However when I plug the USB into my L14 and press ESC to access the boot menu, I don’t see an option to boot from the USB. The options I have are:

1. (My hard drive)
2. Payload [coreinfo]

t. TPM Configuration

I attempted to change the boot order while running PureOS using the coreboot util found here: When I try to change the boot order, though, I get this error in the terminal: Error reading current firmware; see flashrom log for more info. OK, so I check the log, and see all this:

WARNING: No chipset found. Flash detection will most likely fail.
Super I/O ID 0x8528 is not on the list of flash-capable controllers.
No board enable found matching coreboot IDs vendor="Purism", model="Librem 14".
You seem to be running flashrom on an unknown laptop. Some
internal buses have been disabled for safety reasons.

Laptops, notebooks and netbooks are difficult to support and we
recommend to use the vendor flashing utility. The embedded controller
(EC) in these machines often interacts badly with flashing.
See the manpage and for details.

If flash is shared with the EC, erase is guaranteed to brick your laptop
and write may brick your laptop.
Read and probe may irritate your EC and cause fan failure, backlight
failure and sudden poweroff.
You have been warned.
Unhandled programmer parameters: ich_spi_mode=hwseq
Error: Programmer initialization failed.

I tried building the firmware update from source, thinking it might be out of date, but even after going through the process successfully and rebooting I get the same error.

I’ve had to restart my laptop a bunch of times throughout this process to access the boot menu, and I noticed that a message flashes on screen for a second right before I’m prompted for the password to decrypt my hard drive. The message reads:

i915 0000:00:02.0: firmware: failed to load i915/kbl_dmc_ver1_04.bin (-2)

I’m not sure if this has anything to do with the problems I’m having, but as it’s firmware related I thought I’d include it just in case.

Any advice on how to fix what’s going on would be greatly appreciated, as I’m stuck!

Might be a stupid question but did you try to create a live USB using dd instead of etcher?

If so, same results?

Which version of Mint are you using? An older version might not work with the L14’s hardware.

then the USB stick itself isn’t being detected. Nothing to do with what’s on the stick (mint) or how you wrote it, it’s a simple hardware detection issue. You can try a soft reset (CTRL+ALT+DEL), try another USB port, or just try another USB stick.

this has nothing to do with changing the boot order, so don’t waste your time here.

it’s not and it’s not. It’s a power saving blob needed by the i915 driver, which isn’t included in PureOS (which is blob-free). It’s a spurious error.

Use another USB stick


I was able to fix the problem! I continued searching around and stumbled across this forum topic about coreboot: Librem coreboot Utility Script: usage, discussion, and help. I noticed that someone else in the thread was getting the exact same error message from sudo bash ./ that I was:

Unhandled programmer parameters: ich_spi_mode=hwseq

In the thread @MrChromebox mentions that the build utility should be updated to address that error; I followed his link to the build utility on gitlab ( and saw this message:

Project 'coreboot/utility' was moved to 'firmware/utility'. Please update any links and bookmarks that may still have the old path.

I noticed in the bash commands to download the script the old path is still written out, so instead I changed it to

wget -O

which downloaded fine. After running the new build script and updating my firmware, pureboot was able to read the USB without problems.

I’m not sure if any of the steps I went through above actually fixed the problem, or if it’s all a coincidence. but I figured I’d write out what I did in case anybody else is having a similar problem.