Cannot order sim card without IMEI, how to access with no SIM card

Without a sim card, the settings -> modem app does not allow me to view the IMEI. I’ve tried running mmcli -m any - but I don’t see an IMEI code. WHERE is this code and why is it hidden if no sim card is present?? I can’t order the sim card BEFORE I can order a sim card. Please provide a command line terminal command with sample text that shows WHERE the IMEI is in the output. Just saying “go to this app” is of no use at all… phone is fully updated. There exists no “settings” if you don’t have a sim card.

Hello. Does this thread give anything useful?

No, I’ve gone through this page before. Someone posted: “You should be able to get the IMEI via mmcli -m any.” … but I don’t see any code the correct size in the output - or any example what the output should look like. I don’t have a sim card, so the rest of the suggestions don’t solve it because the app is dead if no sim is inserted. Settings shows nothing. I’m desperately trying not to open the phone and dig around to find something printed somewhere (no pictures given in any docs). I’ll take a grep/sed/awk monstrosity at this point, but just something I can run in software to show the IMEI to see if this brick will work on a local phone provider. How is it so difficult to read this code? is this a security issue - it’s not a secret on any other phone…? and *#06# doesn’t work either… just spins forever.

Do you by any chance have an old, inoperative SIM card lying around? If so, you could insert it just so the Modem Settings will appear. (Personally, I think it would be better if these settings were never hidden, even if they’re blank, but…)

The output you’re looking for from that mmcli -m any command (if it worked) would look like what I posted in this thread .

I have no extra sim card… it’s built in to the other phone.

If you’re in the U.S., whatever the IMEI is, it will only pass T-mobile’s checker currently, by the way (as well as MVNOs using T-mobile’s network). The BM818-A1 is disallowed by AT&T and Verizon (and related MVNOs).

I know when attempting to order a SIM directly from the carrier, you have to run the IMEI by them, but there is also the option of ordering a SIM card from, say, Amazon or eBay.

Otherwise, you might just be able to walk into the carrier store/kiosk and tell the rep you need a SIM. If you explain that the IMEI is hidden without a SIM inserted, they’ll probably just attempt to activate one for you anyway.

Or pop off the back plate, unscrew the modem cover, and look at the modem’s label. :slight_smile:


I think this is just a bug.

Have you tried the BM818 tools package? (Don’t know whether it works without a SIM but worth a shot.) sudo apt install bm818-tools if it’s not already installed.

Have you tried executing the ATI command on the modem?

Mint Mobile is a T-Mobile MVNO. So Mint Mobile should work on your Librem 5 to get voice, data, and texting. You can order various different kinds of SIM cards for Mint Mobile on Amazon. You can buy a $1 SIM card that let’s you activate the phone on a plan of your choice, and pay when you activate the phone. You can also get a 3 month SIM card for T-Mobile and pay nothing when activating. Amazon will sell you these SIM cards without asking for an IMEI number.

mmcli -m any | grep "equipment id"

for whatever reason " equipment id: " is just 000000000000000… gave up and opened the phone, lost a screw, but found the code. didn’t want to open it, damaged the screws as they are exceedingly tiny. wish something in software worked.

It did work. For some reason your modem module appears to be missing an IMEI. Please contact support.

That app doesn’t show the IMEI, unfortunately, with or without a SIM inserted.

1 Like

OK, thanks for the confirmation. Don’t suppose you want to try the ATI (modem) command? (in particular without SIM)

error: couldn't find modem

1 Like

So, the problem is worse than I thought. There IS NO IMEI in the phone… it’s just all blank 00000’s and will not connect to my mobile carrier because it has no value. How do I set the IMEI number to what is printed on the modem??

As suggested above, for that, “please contact Support” (