Can't set up VPN

I have installed openvpn, network-manager-openvpn, and netork-manager-openvpn-gnome.

I try to configure a VPN in Settings. I enter the gateway, the CA certificate, the user certificate, the user private key, and the user key password. When I click “Add” the Settings window disappears. When I open Settings again, the VPN that I configured is not there.

I had this working with several VPNs for moths until I had to change the password on one of them. I changed the password in Settings, but when I tried to connect, I got the window asking me for the password. I entered the password, but it didn’t work and I got the password request window again.

I am 100% certain that the password and user name are correct because it is working on another system.

I have removed and reinstalled network-manager, openvpn, network-manager-openvpn, and network-manager-openvpn-gnome several times, to no avail. I deleted /etc/NetworkManager and reinstalled all of the pacakges. Nothing makes any difference.

How do I restore VPN functionality?


Here’s what dmesg says when the VPN configuration fails:

kernel: [ 2580.705940] traps: gnome-control-c[3714] trap int3 ip:7f1338ce49f5 sp:7ffe67522740 error:0 in[7f1338cac000+7d000]

Have you tried using your VPN setup through the Gnome Shell? Read this thread to understand how to manage your extensions under the section ‘Tweaking Gnome’
I installed an extension called auto open vpn. Make sure you follow the extension installation link to get it to work properly. You may also want to read my comment to understand its limitations.

1 Like