Cell modem failing?

To clarify, is the fix for https://source.puri.sm/Librem5/linux/-/issues/303 contained in phosh 0.25.2-1pureos2, or is it in some other package?


No fix for that has made it to the repos yet. So far only the recent change that apparently made the issue worse on some devices has been reverted, so for now it’s just back where it was a few weeks ago.

The actual improvements will be coming soon in kernel and librem5-base packages. Phosh is completely unrelated to that.


Hopefully the fix will be coming soon. Every now and then I check my phone and even though it says I have reception and working modem I don’t have any internet, calls, or SMS go through. I have to stay vigilant and use the HKS to reset it.

It’s been already there for some time now.

@Dos I have your latest update and while there were some noticeable differences (thanks), I am also still encountering this issue, among others.
In addition to everything looking fine in the status bar, but not having internet:

  • not finding a 4G signal when set to 2G, 3G, 4G (preferred), and within range of a strong 4G signal
  • not connecting to any “G” when there is a signal with bars, or also when selecting 4G (preferred)
  • not being able to switch the preference of “G” network
  • not able to manually search for other carriers/bands
  • not finding any signal (no bars) when still very much in full bar range
  • exclamation point still occurs in situations it clearly shouldn’t
  • incoming call sometimes does not allow answering or declining, keeps ringing until voicemail after buttons are clicked (e.g. click answer, button shade increases, string says answering call, but it doesn’t connect, and keeps ringing)
  • APNs not appearing immediately, then ending up with duplicates that can’t be deleted via GUI
  • Inability to send MMS without manually switching to carrier’s MMS APN (loss of internet while doing so), likely due to the fact that internet & MMS are two seperate APNs, but phone assumes everything is routed through one
  • Inability to receive MMS under any circumstance (even small sized images and while on MMS APN)
  • CBS settings (sometimes VoLTE settings) resetting
  • Missing missed call notifications
  • No voice/SMS/MMS over Wi-Fi
  • No icon to indicate a pending voicemail
  • taking up to 10 minutes, sometimes more to connect to the internet, sometimes requiring toggles of swks, hwks, or reboot to solve

I have non-technical people I’d like to recommend the phone to, but only once it’s more reliable than a dumb/flip phone for phone things, and it’s not quite there yet.

1 Like

My phone hasn’t really worked right since this problem started. I actually had to stop using it as my daily driver. The modem still seems like it goes to sleep after a few minutes. When streaming music over mobile data, with wifi turned off, the stream stops between 2 and 5 minutes. Doesn’t come back until I cycle the HKS. When this happens, I check my weather app, just to make sure it isn’t Shortwave that has a problem. The weather app doesn’t populate either, until I cycle the HKS. The last straw was last week, I had an important call coming in from my lawyer, his name came up on the caller id, but when I tried to answer, the screen was unresponsive. After he hung up, I tried calling back, the contacts screen wouldn’t respond when I tried to call his number from that screen. It wouldn’t respond from the recent call screen either. Also, sometimes after being on a call for a couple of minutes, I’ll hang up and try to call someone else, and nothing related to making a call will respond. Nothing call related works until I cycle the HKS. I have people telling me they tried calling and didn’t get an answer, when I know I had the phone with me and had very good cell strength. I have too much going on right now to not be able to use the L5 as a basic phone. I sent in a support ticket on the April 30th, they asked for a log file from when the problem occurs. I sent the log file, the same day, haven’t heard anything from them since.

Did you have suspend turned off in all those scenarios?

Never had turned it on.

It’s possible there are two separate issues. I remember before when the modem failed it would fail completely and the modem would not even be recognized again until after a reboot. That has since been patched which is very helpful.

Currently the issue that I have come across is that it looks like the modem is functioning but in reality there is no service. At the very least it is more easily resolved by toggling the HKS to reset the modem. However, it is equally problematic as it still results in missed calls, SMS, and any other info requiring a mobile data connection; all the while I assume everything is fine because the indicator saying a signal is still present.

That’s the issue I’ve had all along. It always looks like I have a good 4G signal.

similar issue for me with wifi it shows connected but no connectivity or data goes through connection. so can only use 4G on mine.

Same. I wonder if it is somehow connected issue where the OS suddenly loses awareness of the state of the modem and WiFi cards.