Cellular connection anomalies

Quite often when I leave my home wifi, the phone suggests that it is connected to 4G with good signal quality, but it has no mobile network connection. A related problem that occurs quite often in this scenario is that not even calls and sms work. A cure that sometimes works, is to toggle the mobile kill switch off/on and wait for the connection to reestablish. (and yes, mobile data and roaming are enabled in settings)

Anyone else experiencing this? Which logs should I collect to troubleshoot the issue?

1 Like

To clarify, calls and SMS do indeed work when you’re connected to WiFi?

Mostly yes, but difficult to know if someone tried to call or text me and it doesn’t go through. I don’t get many sms and calls, but as I recall it calls mostly go through when I am in the house with wifi on. Seems unlikely though, that wifi should make a difference in this case. It would be easier to understand the issue if only mobile data failed, but calls and sms makes this more of a mystery. It seems, somehow, that the transition from wlan to mobile causes things to fail.

Just as a test, I turned the wifi killl switch off, and had my partner call me and it worked. Also mobile data. But she can confirm that I have been unreachable out on the town at several times.

Just to add to the issue, I just turned the wifi kill switch back on, and the phone doesn’t recognize that there is a wlan adapter. At the same time, the data connection icon showing two arrows and an ‘x’ occured, showing there is no mobile connection either. Toggling the switch off/on a second time brought it back, though.

Overall, I just experience that modems don’t work reliably at all times.

Been out again. This time cellular connection worked when I checked, but coming back home about 3 hours later, cellular modem software has crashed and won’t wake up by toggling kill switch.

Cellular back after a reboot. This happened frequently on my Pinephone, but could usually be fixed by restarting eg25-manager, but this service doesn’t exist on the L5. Any other trick availble?

Presumably “eg25-manager” is specific to the Quectel EG25-G cellular modem chip that is in the PinePhone - so not surprising that the process / service does not exist on the Librem 5.

I’m not sure that roaming works yet. If you don’t need roaming then I would disable it. (I’m talking here about roaming between carriers within one country, not global roaming.)

As to the basic problem you are discussing, amber or byzantium?

BlockquoteI just turned the wifi kill switch back on, and the phone doesn’t recognize that there is a wlan adapter

Ive noticed that it just takes time for the Wifi adapter to kick in when my phone is in that similar state.

Also I have noticed that when you have both cellular data on and wifi on at the same time, that the cellular data seems to take priority for the internet connection vs the wifi connection. I have concluded that by the temp service SIM card that I have with Mint Mobile. The other day i got a text message from mint stating that I was out of my prepaid data plan. I still have text and phone capability with Mint. Anyhow, when I run from the terminal sudo apt update…nothing happends for communication with the repos…but once i turn off the mobile data connection and wifi kicks in…my sudo apt update runs just fine. This leads me to believe that when both are on at the same time…the cellular data is taking a connection priority over the wifi connection.

Thoughts or has anyone else noticed this as well?

1 Like

I don’t buy it. All of the time that I am at home I have both connections ‘up’ and, in that circumstance, doing the equivalent of ‘what is my ip’ has always given the public IP address of my home internet connection, not some CG NAT IP address of my mobile provider i.e. it’s using WiFi.

[Adding: By virtue of network security, it wouldn’t even be possible for me to connect in to work from home via the mobile connection. So if the Librem 5 chose the mobile connection, instead of the WiFi, then it would fail to connect - and I would notice. For example, I would be getting errors, not email, on the Librem 5.]

Furthermore, output of route -n shows both connections providing a default gateway but the metric of the WiFi is ‘600’ while the metric of the mobile connection is ‘1050’ (where lower is better). (For fun, if I plug a USB to GbE adapter in to the Librem 5 then the metric on the ethernet is ‘100’ - so that would take priority over both.)

Of course, if your metrics have the opposite ordering then what you suggest may well be true. So you need to check your metrics.

1 Like

I do buy it. I’m having the same behavior with Mint Mobile, but on the Mobian Pinephone. For a while I would use speedtest-cli to quickly check my carrier and speed when I got home and WiFi connected. Even when confirmed on WiFi, my mobile data will deplete to exhaustion. Now I just shut off cell data when I get home. I don’t think it’s Mint, since the same thing was happening when I had a Tracfone SIM.

No big deal Purism will lick this problem and the fix will make it to Mobian before my L5 arrives. My Pinephone would not be what it is (daily driver) without Purism!


It is Byzantium.

Command does not exist on my phone. Did an apt search for it, but didn’t find an exact match. Which package do I need to install?

It’s probably
ip route

You should already have it.

Yes, that command works.

purism@pureos:~$ ip route
default via dev wlan0 proto dhcp metric 600 
default via dev wwan0 proto static metric 1050

My bad. I’ve installed net-tools or at least I think that’s the package that gives the route command.

If you are dual stack (as I am) then you would also need to rule out that an application is using IPv6 instead and picking up different routing. So route -6 -n

Then you would want to install the traceroute package for the traceroute command and see, for a given domain name, which gateway is used. In the case of @Whe3zy he says that it’s downloading updates from the Purism repo that goes awry, so that tells him which domain name to try.

Or use traceroute6 if it is using IPv6. However, as it happens, I don’t think Purism supports IPv6 for its repository. Which is probably just as well because I’m only dual stack on the LAN and internet thereto. My mobile provider is IPv4 only.