External battery charger for Librem5

Try different usb port with sudo and different usb cables. This issue happened to me one time, i not remember well how, why, this issue it happen to flash L5. Also you can use a different computer too.

I’ve tried sudo and non-sudo (after adding udev rules) that didn’t help.
Let me try different USB ports (this didn’t help either).

One more thing I’ve noticed:

If I keep flash script running (before plugging in phone), I don’t see solid red LED on battery insertion. (LED goes blinking red -> solid green)

If script is not running then I see behavior mentioned under steps at https://developer.puri.sm/Librem5/Development_Environment/Phone/Troubleshooting/Reflashing_the_Phone.html (blinking red -> solid red) and then I start script.

This procedure I like better, yet it will not work if this prerequisite (connection) isn’t achieved:

Using different computer didn’t work however I got more details:
Trying to debug jumpdrive boot process:
Output of uuu -lsusb
uuu (Universal Update Utility) for nxp imx chips – libuuu_1.4.193-0-ge56424c

Connected Known USB Devices
	Path	 Chip	 Pro	 Vid	 Pid	 BcdVersion
	1:5	 MX8MQ	 SDP:	 0x1FC9	0x012B	 0x0001

boot-purism-librem5.sh has uuu purism-librem5.lst and purism-librem5.lst has all uuu commands listed.
so I started uuu shell with uuu -s and executed commands from lst.

Please input command: 
U>CFG: FB:  -vid 0x316d -pid 0x4c05
>Start Cmd:CFG: FB:  -vid 0x316d -pid 0x4c05
U>CFG: SDP: -chip MX8MQ -compatible MX8MQ -vid 0x316d -pid 0x4c05
>Start Cmd:CFG: SDP: -chip MX8MQ -compatible MX8MQ -vid 0x316d -pid 0x4c05
U>SDP: boot -f u-boot-librem5.bin
>Start Cmd:SDP: boot -f u-boot-librem5.bin
New USB Device Attached at 1:5
100%1:5>Okay (3.057s)
U>SDPU: delay 1000
1:5>Start Cmd:SDPU: delay 1000
Wait for Known USB \
Wait for Known USB /

Wait for Known USB -
Wait for Known USB \
Wait for Known USB | /

I’m sorry, Are you suggesting script needs to be started before connecting phone? (I’ll try this with other computer as well)

Looks all right to me so after confirming (again) needed/related connection with those two:
uuu -lsusb
lsusb | grep 8M

current proposal of mine might sound weird (at the moment) but please share with us following procedure (that might/should work with your current Librem 5 setup): please do not use Jumpdrive executing command at all, just jump to this one as your very next command:

Negative. I’m suggesting to start script afterwards.

Please share with us back specification numbers of your new external charger, because if you are having numbers similar to the ones shown here: https://forums.puri.sm/uploads/default/original/2X/6/6de968b085ca3c0c97e628fa1d0fceb24f23d190.jpeg be aware that those numbers are very bad ones to be used with Librem 5 battery, IMHO (hopefully not relevant, but they are not ideal if/when inserted into Librem 5 with its fully charged output of 4.35V, as referred elsewhere already).

Doesn’t work either (adding terminal info below).
Should phone be in flash mode all the way until script finishes? Phone definitely comes out of flash mode after SDP: boot
It shows green LED which changes to amber LED and it doesn’t show up under lsusb or uuu-lsusb

○ uuu -lsusb
uuu (Universal Update Utility) for nxp imx chips – libuuu_1.4.193-0-ge56424c

Connected Known USB Devices
Path Chip Pro Vid Pid BcdVersion

1:1 MX8MQ SDP: 0x1FC9 0x012B 0x0001

○ lsusb | grep 8M
Bus 001 Device 004: ID 1fc9:012b NXP Semiconductors i.MX 8M Dual/8M QuadLite/8M Quad Serial Downloader

± ./scripts/librem5r4-flash-image --variant luks
2022-03-17 18:06:33 INFO Looking for librem5r4 luks byzantium image
2022-03-17 18:06:37 INFO Found disk image Build 10637 ‘luks librem5r4 byzantium image’ from Wed Mar 16 20:33:06 2022
2022-03-17 18:06:38 INFO Found uboot Build 82 from Fri Sep 10 11:19:03 2021
2022-03-17 18:06:38 INFO Downloading to ./tmp_librem5r4-flash-image_xzlwyb5f
2022-03-17 18:06:39 INFO Downloading image from https://arm01.puri.sm/job/Images/job/Image%20Build/10637/artifact/librem5r4.img.xz
2022-03-17 18:41:54 INFO Calculating sha256sum of ./tmp_librem5r4-flash-image_xzlwyb5f/librem5r4.img
2022-03-17 18:42:05 INFO Downloading uboot from https://arm01.puri.sm/job/u-boot_builds/job/uboot_librem5_build/82/artifact/output/uboot-librem5/u-boot-librem5.imx
uuu (Universal Update Utility) for nxp imx chips – libuuu_1.4.193-0-ge56424c

Success 0 Failure 0

1:1 1/ 1 [=================100%=================] SDP: boot -f u-boot-librem5.imx

oh so 4.2V is not good, is that correct?

1 Like

Either lib1.4.77 or lib1.4.193 packages are the OK ones but you are connected with something called libuuu_1.4.193-0-ge56424c, probably all right but still output that I’m unfamiliar with. Please take a look at this package more closely, please install and use compatible one (lib1.4.77 or lib1.4.193 but not libuuu) within your Linux distribution.

Another still, related to this post of mine, as of this brand new day (please just bear with me as solution itself, actual flashing one, is not in my hands anyway) is based on that you are currently having on your Librem 5 (that doesn’t boot/react, for some unknown reason, any more) installed Kernel: 5.16.0-1-librem5 (and uuu package for arm64 in version: 1.4.77-1).

Now (reproducing steps made by myself), after getting steady red LED light (showing that Librem 5 is physically connected) output of: uuu -lsusb is already present (as shown in @librem5 posts above) yet sudo fdisk -l doesn’t see eMMC drive from my/your Librem 5.

My current step two: successful execution of ./boot-purism-librem5.sh from JumpDrive folder auto-mounts both L5 eMMC partitions but lsusb | grep 8M and uuu -lsusb commands doesn’t show any output any more (both outputs are empty). sudo umount /dev/sdb1 and sudo umount /dev/sdb2 changes nothing (as expected) either.

Please provide adequate help to @librem5 on how to establish uuu connection again, get both: visible Librem eMMC and uuu working (both connections established at the same time, as perhaps needed for flashing, I think while not moved, as not intend to execute: ./scripts/librem5r4-flash-image, not now)?

And if relevant, central (and helpful for real) workaround here is probably based around this fact:

That I might briefly (and unofficially) translate into (for the purpose of this thread solution only): current Librem 5 Jumpdrive package is disabling uuu when 5.16.0-1-librem5 image “on board”. Discussion is open now :grinning:, all kindly invited (myself already out, I guess, as cannot help any further).


Please ignore my above advice (as probably not helping anyway) here and tell us which Linux distribution you are using? Also, why not to simply extract (unpack) JumpDrive 0.8 archive (as already recommended elsewhere): https://github.com/dreemurrs-embedded/Jumpdrive/releases/download/0.8/purism-librem5.tar.xz and run ./boot-purism-librem5.sh from there (related extract folder)?

In contrary, DC 4.2V number is just about the very right/best (for the described purpose here) one.

1 Like

I’ve 3 versions of uuu installed (2 on my PC and 1 on Laptop).
On PC I’ve

  1. from sudo apt install
    :slight_smile: /usr/bin/uuu main :heavy_check_mark:
    uuu (Universal Update Utility) for nxp imx chips – lib1.4.77

  2. built from source
    uuu main :heavy_check_mark:
    uuu (Universal Update Utility) for nxp imx chips – libpureos/1.2.91+0git6b465-0pureos+librem5.2-1-g5e5fee8

On my Laptop I’ve uuu installed through Manjaro git package and that one is

uuu (Universal Update Utility) for nxp imx chips – libuuu_1.4.193-0-ge56424c

Yes I’m extracting jumpdrive and running ./boot-purism-librem5.sh, however this gets stuck so finally tried running commands from that script one at a time.

1 Like

It is the newer package and the one that you need. Can you purge the other one away? Please start required procedure from your PC (by recognizing lib1.4.77 package). Should read as:
apt list uuu
Listing… Done
uuu/stable,now 1.4.77-1 amd64 [installed]

1 Like

I’ve tried with lib1.4.77 but I’ll try again after making sure that’s only package.
I’ll update this thread after a while.

Also should I look at 1.4.193? or continue using 1.4.77 ?

1 Like

I think that 1.4.77 is just fine one, current one within PureOS and Debian. You might want to execute:
sudo apt reinstall uuu

If you prefer, I’ve just installed 1.4.193 without any problems (additional dependencies):
sudo dpkg -i uuu_1.4.193-1_amd64.deb
(Reading database … 169584 files and directories currently installed.)
Preparing to unpack uuu_1.4.193-1_amd64.deb …
Unpacking uuu (1.4.193-1) over (1.4.77-1) …
Setting up uuu (1.4.193-1) …
Processing triggers for man-db (2.9.4-2) …

apt list uuu -a
Listing… Done
uuu/now 1.4.193-1 amd64 [installed,local]
uuu/stable 1.4.77-1 amd64


I going to flash my second L5 because still it is on Amber to Byzantium, i wish to Octarine :wink: , so i hope to reproduce the bug that you having.

1 Like

I don’t wish for u to get stuck but at same time I would like some solution (or at least debug info).

uuu ** L5 ** -v -V

I see

uuu (Universal Update Utility) for nxp imx chips -- lib1.4.77

Success 0    Failure 1                                                                                                                                                                      
1:12     1/ 2 [Cannot find valid IVT header          ] SDP: boot -f "COPYING"

Are you using Virtual Box? What operating system are u using?

1 Like