Firmware failed to load

During normal use, all of a sudden, the Librem 15 v3 crashed and upon reboot and decryption of the SSD, following message showed:
[ 1.156598] i915 0000:00:02.0: firmware: failed to load i915/sk1_dmcver1_27 bin (-2)
[ 1.156604] firmware_class: see for information about missing firmware
When trying to boot in recovery mode, following error shows:
[ 404.469708] SQUASHFS error: Unable to read fragment cache entry [230f6ce9]
[ 404.469708] SQUASHFS error: Unable to read page, block 230f6ce9, size 4dd8
Because no important data is currently on the laptop, I decided to build a bootable USB with the ISO downloaded from and burn it with
dd if=pureos-8.0-gnome-live_20180904-amd64.hybrid.iso | pv | sudo dd of=/dev/sdb bs=1M.
However, when booting on this thumb drive, and going through the installation process, it sometimes finishes the installation and shows that error, more often it crashes during installation and the same error appears
[ 404.469708] SQUASHFS error: Unable to read fragment cache entry [230f6ce9]
[ 404.469708] SQUASHFS error: Unable to read page, block 230f6ce9, size 4dd8
Additionally, now the encryption of the SSD takes about 45 seconds, which seems rather long, which might be a sign that the SSD is fried…

I put the Qubes ISO on the USB drive and booted that, but it froze at ~ 20% installation.

Anyone know a fix for this?

1 Like

I’m not intimately familiar with how SSDs work, but is it possible their is a corruption on the SSD itself? Have you tried completely formatting the drive (not the quick but long full format)?

I’m not at all certain that the SSD is actually the problem, just a wild guess…
Yes, I have formatted the drive several times, doesn’t solve the issue.

I can enter grub, but when trying to boot, it shows:
error: you need to load the kernel first

Ok, I’ve tried a couple more things, spoiler alert, the Librem 15 is still a brick…

  • booting pure OS from a usb drive, when in the initial test area, tried to update the firmware with sudo apt-get install firmware-misc-nonfree, error package has no installation candidate
  • tried to finish the pure OS install, crashed at 23% with error unsquash filesystem
  • Ubuntu on the USB stick: when selecting “try Ubuntu”, Squashfs error: squashfs_read_data failed to read block 0x346622b5;
    when selecting “install Ubuntu” ubi-console-setup failed with exit code 2. Further information may be found in /var/log/syslog. Do you want to try running this step again before continuing? If you do not, your installation may fail entirely or may be broken.
  • Tried booting with another USB stick in another port, The Installer encountered an error copying files to the hard disk: [Errno 5] Input/output error This is often due to a faulty CD/DVD disk or drive, or a faulty hard disk. It may help to clean the CD/DVD , to burn the CD/DVD at a lower speed, to clean the CD/DVD drive lens (cleaning kits are often availble from electronics suppliers), to check whether the hard disk is old and in need of replacement, or to move the system to a cooler environment.
  • Put ISO on one USB stick, and installed it on another USB, no success either, crashed upon setting the partition, but same error.

I’m pretty much out of ideas and options by now…

I’ve contacted the Purism support several times per mail, on Twitter and of course here on the forum. So far, nobody has gotten back to me…

That fourth bullet certainly seems to indicate a bad SSD. Do you have any other hard drive/computer to try with? That I think would really help determine if the problem is specific to the hardware.

Regarding your emails - make sure you follow the advice here (if you haven’t already):

If you have, then I guess you can only wait and/or try again. They are a fairly small team.

1 Like

@Rothbard Like I have already explained, I do not see any emails from you in my inbox.

Now to your problem: looks to me like the PureOS iso image was not downloaded properly. I suggest that you re-download it, burn it to an USB known to work. Then try to re-install the system on your system (make sure to format the entire drive first).

If you have the same issues with PureOS like before, it could be indicative of some more serious problem.

Btw, ignore the firmware warnings, they are not related and do not affect your device’s functionality in this way.

Thanks for the feedback!

@mladen I have downloaded and burned the PureOS iso several times already. Further, because the same error shows with the Qubes, Ubuntu and Antergos installations, I don’t think it’s an issue with the iso file… I’ve tried two different brand new USB Sticks, they appear to work just fine otherwise. I did format the SSD several times during the installation process, but I haven’t yet formated it before starting the installation, might this be useful/how does it work?

@taylor-williamc I believe it is an issue with the SSD, but I’ve tried booting from the iso on one USB, and installing on another USB, but this showed the usual error. Is there any concrete way I can test if it’s an issue with the SSD?

1 Like

Can I ask what you did to install to the other USB? I’ve never actually tried that, but something just seems to me like that might not work as expected, so I am hesitant to trust results from that. Maybe I’m wrong.

Otherwise, maybe you can boot from the USB, and then while still in the live session, open GNOME Disks and check the SSD? But if you don’t have another computer to work with or another HDD/SSD to swap into your laptop as a test, I’m not really sure what to do.

@Rothbard Start PureOS live and check if the GNOME Disk SMART status check reports anything:

Tried the smart data and self test, here are the results.

Issue solved!

I’ve bought a new SSD, put that in the Librem 15, tried to install PureOS, which for some reason froze in the setup process. Then, I installed Ubuntu, which works fine.
So, at least the SSD is working now, and I can finally use the laptop, but still some unknown issue with PureOS…

1 Like

Well, perhaps just a temporary glitch, you could simply try again…

Booted from a new USB, and now it works like a charm!

Quick off topic question, can I fix the favorite bar to the left side of the screen, so that it shows at all time?
All I can find is a ‘Windows List’ in the ‘Extensions’ tap of ‘Tweaks’.

Thanks for your help!

Everything worked fine on Ubuntu, then I installed PureOS, and during regular use it crashed - again.
On reboot same error as before:

[ 1.339149] i915 0000:00.02.0: firmware: failed to load i915/sk1_dmc_ver1_27.bin (-2)
[ 1.339155] firmware_class: See for information about missing firmware
BusyBox v1.27.2 (Debian 1:1.27.2-3) built-in shell (ash)
Enter ‘help’ for a list of built-in commands.


Now, when I want to boot Ubuntu from a live usb, it’s stuck at

Booting from Had Disk …

It seems that - again - the SSD is broken.
Can this really be the case?
Or is something completely broken with the rest of the hardware?

Can you boot to live PureOS and use GNOME Disks to format the entire disk?

Also, please try completely different distro, like Manjaro Linux.

No, it’s stuck at “Booting from Hard Disk…” as soon as I select to boot from the USB.
I’ve tried Pure OS, Qubes and Antergos - same error.
Manjaro did not work, black screen without any message after booting from the USB.
Then, I installed Ubuntu, and this time, it works.
I have no clue why, but, I guess it is working now, will stick with Ubuntu for now, and hope that it will not break again.

I was having this nearly identical issue with out of the box brand new Librem 15.3 - somehow couldn’t get back in after setting passwords so opted for reinstall.


• Used GParted to “loop” (see below post), then format ext4, SSD.
• Re-ran USB image of OEM PureOS.
• When screen hung on the screen showing issue listed above in original post, i hit “enter” once, waited, second time, waited patiently… and hey presto! - system booted into Gnome, where it was possible to finish the installation with the Gnome install/format/setup tool.

Now EVERYTHING works sweet as a nut.
Nice kit!