Firmware update with Error adding serial number

I am trying to update the firmware of a Librem 13, Version 4 Laptop from Purism, because the OS-reset failed with an error message about missing firmware. should do the job. To prepare the update I execute it on my desktop computer. The last lines are:

Set the device serial number:

1 - Extracted from your local system (Default string)
2 - Enter serial number manually
3 - Do not set a serial number

Enter your choice (default: 2): 3

Injecting serial number into firmware image

Error adding serial number to  file ./firmware/pureboot-librem13v4-beta-13.1.rom

Before I tried to enter the serial number: but with no success.

Does anyone has an idea what’s going on?

hello and welcome ! i’ve encountered this ‘serial-thing’ the first time i’ve flashed coreboot on my Librem-Mini-v1 a few months ago and it isn’t a big deal if you ignore it or set it to whatever.

@MrChromebox might be able to assist you further …

that has nothing to do with the device firmware/coreboot

this was fixed a while ago, I’ll check and see what happened

I’m not able to reproduce here, either with manually setting a serial number (option 2), or setting none (option 3)

Thanks for the testing. I retried it now (after a fresh download of the core_util): and now it works :slight_smile:

Because You @MrChromebox said, that my initial problem, which leads me to think about a firmware update, might not be solved by a firmware update, I will open a new thread about it: PureOS stops booting with firmware error

Anyway I think this issue is solved :slight_smile: