Gnome software : The name :1.101 was not provided

This is more a debian thing but I figured i would ask here anyway.
This shows up when i try to refresh the list of software on a miniv2 running pureos 10.

gnome software center or snap ui or whatever its called says that there is a problem and it says it cant load the list of updates

this the line in /var/log/messages:

gnome-software[1996]: not GsPlugin error FwupdError:10: The name :1.101 was not provided by any .service files

I have read elsewhere that this is an issue with snap and that I can un-install and re-install gnome-software.
Any thoughts?

I have not been around here for a while and I just cheked the main website.
They are offering qubes pre-friggin installed on the mini or the 14
Damn that is tempting.

Anyway - does anyone else deal with the above when trying to check for updates?

thanks, -non

For what its worth:

After a reboot the message no longer appeared.
Not yet anyway.
non@ ribution

I am getting this occasionally as well. Reboots seem to do the trick, but I am curious as to the cause of the error.

1 Like

it will reaperar , it seems to be related with fwupd, that sometimes fail to calculate checksums for downloaded firmware repository.

1 Like

At least I know what to do next time. Just ignore it until after the next reboot.

Hi I found something that made this error go away and allows me to use gnome software UI thing on my mini.

I ran the suggestions from this post:

I ran

fwupdmgr refresh
apt full-upgrade 

then I think I ran
fwupdmgr refresh again.
Now I can update via the gnome-software thing again.

I was afraid to run apt full-upgrade, because , well it sounds scary - but it worked. Thanks to @mladen and @Quarnero from the other post for the solution.
I waited a bit to see if the glitch returned but so far no problems.

1 Like