Gnomeshell crashes after update from 25/26th of april - byzantium


#21

Oh I did something stupid. One of the packages I downloaded was arm64 instead of amd64 :woman_facepalming:

After installing the following three it seems to go much better:
https://repo.pureos.net/pureos/pool/main/g/gobject-introspection/libgirepository-1.0-1_1.64.1-1_amd64.deb
https://repo.pureos.net/pureos/pool/main/g/gjs/libgjs0g_1.64.1-3_amd64.deb
https://repo.pureos.net/pureos/pool/main/g/gjs/gjs_1.64.1-3_amd64.deb

Edit: yess! that fixed it, GNOME works again, thank you!!!


#22

You might be okay using Debian Testing alongside PureOS, but it’s a Frankendebian that can possibly break things in the same way that waiting for updates from unstable can. Okay, your software breaks earlier, but it will still break. This is what we saw with Debian Testing and this GNOME transition.


#23

I don’t know if this is the same under Byzantium but I’ll test.


#24

Yesterday, I started selectively picking package updates in aptitude, and today there are still conflicts if I select all available updates, and gjs update that solved the broken state of Gnome for @peterpan and @vmedea is not officially available yet in Byzantium. I chose not to update the following packages (I’m not sure why Aptitude pretends they are automatically held back, as I picked most package updates manually):

I write this not for a complaint, but for Byzantium users who want to and can take the path of selectively picking packages to update, until the transition of Gnome from 3.34 to 3.36 gets smoother. :sweat_smile:


Is ugrade to pureOS10 working again?
#25

This will take a little I suppose.
I have a fully upgraded system now, but had to install libhandy from amber-updates manually to get seahorse and gnome contacts back (because several gnome apps do have this dependency now)

And I can’t get gnome-control-center running because this seems to be a package which was changed by Purism - so it has to be updated first from them i. e. integrating their changes to the new 3.36 release