Group texts still don't work

I got the new Chatty 0.5.0 beta update today. It has a “New Group Message…” command, but it’s grayed out. Issue #572 says it should be fully working. I filled in the information from and rebooted, but it had no effect. What’s the status on getting this working?

I already checked that thread. There’s nothing new there since the merge request was closed. It doesn’t explain why it’s still not working or what we can do to make it work.

The reason is that the package mmsd-tng, that chatty needs to be able to handle MMS needs to be updated to version 1.5.

There is a merge request for that in the debian repositories:


So what does this mean for the prospects of actually getting the group text feature? This looks like a whole new approval pipeline that I didn’t know we were going to have to wait on.

It likely means that when the package in salsa is updated to 1.5 we will likely backport it to PureOS.


As far as I can tell, Salsa is a hosting service. Which version of Debian needs to accept the updated package? Unstable?

Any. We can push packages that aren’t yet in Debian into PureOS as well, but having it in Debian archive first (regardless of the suite) makes it easier, so we tend to do it this way when possible.

However, AFAIK mmsd was stuck in Debian’s NEW for a while now, so we may end up pushing it straight into PureOS anyway.


mmsd-tng 1.6-1 which is required for MMS to work with chatty was uploaded today to landing.

So if there is no issue, in about one week or so it should be in Byzantium.

mmsd-tng 1.6-1 entered Debian unstable suite today.


Not coming to Amber, I take it?

1 Like

That would be nice.

What’s the package packporting process from Byzantium -> Amber?

Yesterday, I got the update with mmsd-tng. I sent some group texts to my friends asking them to respond, but they haven’t responded yet. I’m using the MMS settings that I found here. I have read receipts turned on, so when I send an SMS, I see either a gray checkmark or a red X, depending on whether my message went through. I don’t see those on my group texts.

What else do I need to do to get this working?

1 Like

No response? This is a really serious problem. All indications say it should work now, yet it doesn’t.


I have a Librem 5 USA that arrived a few months ago. I have not been able to send MMS messages to single numbers or create/recieve group texts (create group message grayed out). Is this still an unsolved issue? I’m with @luther: all indications seem to be that this is a solved issue by now.

What phone provider are you using?

I have Purism’s AweSIM (t-mobile backend if I’m not mistaken). I set up the APN according to how the SIM setup email from Purism indicated (APN: 4G data works wonderfully.

1 Like

Try the settings listed here AweSIM User MMS & mobile data settings reviews

Thanks. Unfortunately, it did not fix my problem. I tried looking up what the MMSC field should be for the apn and found: Unfortunately, it still doesn’t work (even after update + reboot). I’ll try purism support and report back here if I learn anything

Is this what you are talking about?
Because it is always greyed out. You just use the new mms option which takes you here.
You are changing the MMS settings in Chatty, right?

Hi all, thanks for the helpful replies. The problem ended up being much less interesting (and much more my fault). I did change the MMS settings in Chatty, but I had them wrong in my system settings > Mobile > APN, where I put “” instead of “”. (b -> d)