How to change Gnome-Keyring Password?

I initially set up a gnome keyring password that’s kind of long and cumbersome to type. (I don’t know why!) I would like to change it to something else, but I’m not really finding a solution.
I did try installing seahorse keyring manager, but the action I need requires a right-click, which is not possible on the L5.
I don’t see a way in the native Password Safe app, unless I’m missing it.
I’ve investigated various Terminal options, but haven’t figured it out.

Any ideas?


Install seahorse (it uses libhandy already) and change the secret on login collection
Edit: The one in debian might not use libhandy yet though, should at least be libhandy0 hopefully.

1 Like

I don’t see it. It’s not under Default keyring, either, which is what I would need to right-click on on a regular computer in order to change the password.
Edit: To clarify, clicking on Default keyring does display the services that have saved passwords for me, but to get the gnome keyring, I would have to right-click…not possible.


Yes, it is default keyring, and yes, you need to connect mouse, just tried all possible gestures (now can barely see through smudged screen) but damn menu is not popping up without mouse ;(

1 Like

On touchpads, a double-finger tap is usually (for me, anyway) configured as right click. Does the L5 have some sort of input settings like the desktop distros have for mice and touchpads?

That doesn’t work in this case.

Shot in the dark, but maybe this?

Maybe it’s wayland or shell, but that doesn’t work for me unfortunately (under sway)

I actually did go looking for Accessibility settings in the store, but it didn’t seem to install, so I gave up.

Which version of seahorse do you have installed? Just tried it with seahorse 3.36.1 (byzantium repo) and I succeeded with doing a “double click” on an entry with phosh (you know what phone I’m using :wink: ). I had to try several times till I succeeded, though.

It’s much better with seahorse version 3.38.0 (tried it on my laptop and it’s design seems to be much more mobile friendly).

Edit: Typo in version number
How did you do the “right-click”?

Well, right click doesn’t work, but double click opens a new window with the corresponding entry on 3.36.1.
On 3.38.0 it’s the same with double click, but this time it’s adaptive:

Doesn’t work for me on posh (byzantium) either with double tap or accessibility secondary click (long tap)
I mean right click doesn’t work, double tap just opens the entry

Interesting - just tried it again to verify. Double tap on a key opens a new properties window for the entry with seahorse 3.36.1 (Pinephone Mobian repos with PureOS Byzantium as base repos in my case).

On a key yes, because it’s primary action (to open properties). Secondary action (open menu) doesn’t work though

Yeah, that’s true: No secondary action / right click.

Just looked into mousetweaks code - it’s clearly X11 based, tried virtual-pointer from wlroots-examples - just crashes the posh. May need to write own script to change it using secrets-service api

If it is useful to anyone, I manage to do the “right-click” changing the keyboard layout to “terminal” by clicking on the globe and then pressing “>_” and then “Menu”. I was able to easily change the password in seahorse like that.


That’s very useful! I’ve been wanting to change my original keyring password for months. Thanks!