How to reduce annoying fan noise

What if the system when executing wrmsr returns

wrmsr: pwrite: Operation not permitted

This is a lenovo Thinkpad X1 Yoga

Whoever is running the command needs root privelege.

Are you using a script?

If so how are you running it?

sudo wrmsr -a 0x1A0 0x4000850089
on KUbuntu

It would help a lot if you would answer questions.

If you are using a script running automatically sudo does not work.

Sorry I did not answer. It was sleep time here :slight_smile:
But I wrote
sudo wrmsr -a 0x1A0 0x4000850089
not a script. So it seems it should have worked, yes? OK I will try again, maybe I did something wrong with sudo (password maybe…). I will retry and report back.

Nope. It does not work. To make sure I switch to root:
$ sudo /bin/bash
# wrmsr -a 0x1A0 0x4000850089
wrmsr: pwrite: Operation not permitted
#
However, this works fine on Librem13. It fails on a lenovo Thinkpad X1 Yoga. Could it be some Bios setting preventng this? On the other side cpupower-gui works and reduces the max frequency. So I am OK with this. I just though I would report that issue with wrmsr…maybe we learn something more from this problem.

Now, I wish someone could share the same script but for Qubes OS…

1 Like

It is something to do with the Thinkpad X1, which may have a different CPU. MSR is machine specific register.

What are the results of
grep -i ghz /proc/cpuinfo | head -1
and
sudo rdmsr -p0 0x1A0

grep -i ghz /proc/cpuinfo | head -1
Intel® Core™ i7-8565U CPU @ 1.80GHz

sudo rdmsr -p0 0x1A0
850089

It might be something to do with the Thinkpad or maybe something about KUbuntu or some difference between the i7-7500U and the i7-8565U.

If the last, the reason might be buried somewhere in the 5000+ pages of the “Intel® 64 and IA-32 Architectures Software Developer Manuals” at:

OK, Thanks. I will try another distro using a USB stick to rule it out as a KUbuntu problem.

something different but relative: When I run the above on LIbrem13v4 it says
model name : Intel® Core™ i7-7500U CPU @ 2.70GHz
When in Turbo mode it goes up to 3.60 and I use msr to bring it down to 2.7

On Yoga it replies
Intel® Core™ i7-8565U CPU @ 1.80GHz
But when in turbo mode it goes up to 4.60 (this is what cpupower-gui reports).

What is the explanation. How on the one system it is rated 2.7 and goes up to 3.6 and the other is rated 1.80 (lower than 2.7) but it goes up to 4.60 ???

Even in the same model line in the same year intel makes CPUs with different base frequencies and different peak frequencies and the base and peak frequencies are not directly related. Besides that, there is a minimum frequency that is different still.

Intel is not using some fixed architecture that they keep over time, only shrinking to improve speed and power consumption.

For Qubes, you should be able to do it in a dom0 terminal, right? You wouldn’t have to do it in any guest process because it would be virtualized in that case, as power consumption has no virtual meaning. But I don’t run Qubes so perhaps I’m missing something.

What you say is true. However, Qubes is based on Fedora, not Debian, so the commands probably differ.

Which commands differ? If you mean wrmsr, it’s a separate installable module with its own syntax independent of the OS.

I believe your problem is that you have Secure Boot enabled (which certainly isn’t secure on a Stinkpad so you might as well disable it). For best results, replace it with a Librem :wink:

3 Likes

dnf search wrmsr
No matches found.

Yes! you got it! Thanks. I disabled secure boot and it worked immediately. I did not think about secure boot…

You’re welcome, but I didn’t think of it, either. Searching for error messages can go a long way toward making one look like an expert.

1 Like