How to remove mms?

I once tried to send a picture through the Chats application. L5 showed me that the picture was sent. The recipient never received the picture but this is another issue. My question here is how to remove this picture from the Chats timelilne with this user. I delete the whole chat and it seems to be deleted.

But when I reboot and I open Chats the chat with the user is there with all text messages deleted but containing only that picture.

So the picture does not really get deleted.

  1. This looks like a Chats bug.
  2. how to delete it using the filesystem?

Alternatively, could be database or could database + filesystem.

[EDIT: There is a config file in there as well… altering instructions, see my post further below. Removing rm ~/.mms/modemmanager/* (don’t do this command)]

A similar question came up in the Matrix L-5 room a couple weeks ago.

Try this:

systemctl --user stop mmsd-tng
rm ~/.mms/modemmanager/{IMAGE_THAT_NEEDS_DELETED}
systemctl --user start mmsd-tng

1 Like

Thank you. It worked!

Check here if the bug has been reported:

If nobody reported it yet, do a good deed and report it yourself! :slight_smile:

But this would also remove the configuration file ~/.mms/modemmanager/mms

Hmm… I just pinged the person who had the trouble a few weeks ago (he’s not on this forum, just in Matrix). The advice he received was what I pasted in, but he said that he only deleted the stuck image.

He just provided his AT&T mms file to me (in case you need it @antonis). And I have the one for AweSIM (which is T-Mobile). So if you have any trouble, just ping in here, one of us forum members can provide the file.

Thank you @leetaur I do not remove without checking what I remove first. So ls showed me the existence of mms file which I did not remove.

But on the other hand I would like to see a working mms file to check if I have something wrong in my file, since it does not work.

For my working mms file search the forum with my username and “mms” (I‘m off my desk at the moment).

Here is the link to my post some days ago: APN settings values and storage