How to Use Librem 5 with T-Mobile?

Basically, you brought up my fears again for the use on Verizon :slight_smile:
Just when I was happy to see all the lacking bands on Gemalto (13,66) you drop all these facts. Damn it!

We need to press Purism to be more specific about these modems. We need to know more details.

I’m sorry to say, but it would generally be wise to switch to a GSM-based carrier (AT&T or T-Mobile for example), since they use technology that is in world-wide use.
Verizon, as a CDMA-based carrier is very US-centric and generally only properly supported by Qualcomm devices.
Nobody but Qualcomm can realistically deliver a CDMA-One chipset.
That’s why every phone manufacturer uses a Qualcomm-chipset for the US, even Samsung and Huawei, which roll their own modems (but not for the US and Canada).

That is not a coincidence; the US specifically favored CDMA-One as a Qualcomm-technology to guarantee that the (at the time European) GSM-manufacturers could be excluded from the market.
That’s also why Kanada and South-Korea used mainly CDMA, on heavy pressure from the US.

1 Like

I ran back to VZW from ATT and not looking back :slight_smile: terrible coverage

In case you don’t know , Verizon is done w CDMA
Shutting it down for good by the end of the year

Indeed, good riddance.
However, this means voice calls will require VoLTE support and for Broadmobi, the jury is still out on that.

Yep. That’s what I was concerned most about from the day one.

I posted this in a few places but no feedback on it . says it has a built in tcp/ip stack a shit ton of bands including 12 and 41 is m.2 all major GSM us carrier certified

“At this point in time it is probably not too likely that MC74xx/EM74xx will support voice calls in the future.”

That doesn’t make sense to me. They have (i think) 3 variants that don’t target China. Yes, nobody ever put them in a phone, but certainly each of them is already in use in the target regions - either with carriers that don’t need whitelising or they actually are whitelisted/approved.

1 Like

given the fact the baseband is one of the only proprietary blob components. Why were we only limited to these 2 choices ? Is it a linux driver issue or ?

1 Like

I’m talking specifically about VoLTE whitelisting, which is a very common practice.
Whitelisting IMEIs for general usage is not, and shouldn’t be of any concern.

Broadmobi might well offer non-china variants, but that doesn’t mean they’re used in any significant number.
I certainly can’t find any reference of any Broadmobi device used anywhere (except China) by anyone.

Again, this isn’t a big deal for use as a data modem and even circuit switched calls, since it’s just another Qualcomm modem, packaged by Broadmobi; it is however a dealbreaker for VoLTE if Broadmobi uses their own IMEIs (which is common).

Can the non-usa version of librem 5 work on US T-Mobile? I can’t seem to get it to work.

I called T-Mobile and gave them the IMEI, but it’s showing Network: Not registered. Their techs had no idea how to register it. I did see a signal strength of 55%, and LTE 4G. This makes me think the radio is capable, but what must be done further for them to make this phone work?

They just wanted to try a new SIM Card, but I know that’s not the issue since I can swap it into a OnePlus 6T or Pixel 4 with no issues. I know the librem is reading the Sim just fine as well because it’s showing the phone number on the Librem 5 (Non-US version).

Any Idea what my issue may be?

Yes. The “USA” in “Librem 5 USA” only refers to where it’s manufactured, not where it can be used.

In fact, T-mobile (along with MVNOs that use T-mobile’s infrastructure) is probably the only U.S. carrier where you can currently get service for the L5.

Lots of us U.S. forum members here are using T-mobile or an MVNO on T-mobile.

Sometimes it helps to go into Settings > Mobile, then click on Network (which should be showing “T-mobile” - if it’s not, then that’s your problem - and also make sure “2G, 3G, 4G (Preferred)” is enabled), then click “Set,” even if it’s already showing “T-mobile” as selected.

Under “Access Point Names,” make sure T-mobile is selected, click on the gear wheel, and make sure the APN is set correctly, then save it.

You will also need to have this relatively new app installed, with VoLTE enabled: List of Apps that fit and function well [Post them here.]

This is not necessarily true. T-mobile is my current provider, and has been for quite a few years. Before that, I had an account with Ben, a company that subsequently was bought by T-mobile. The weird thing is that, after all these years, Ben is still named as my provider in the mobile settings page. (And I am pretty sure somewhere along the line I switched sims.)
My L5 works very well with T-mobile, and since one of the latest updates I even have VoLTE.
Only thing I don’t have, is a ringing phone on the other side when I call someone. But I don’t think T-mobile is to blame for that.

Edit: I have to correct that. My network ís named as T-mobile, my access points are still named ‘Ben internet’.

But are you and @amarok talking about different countries? He in the US and you in the Netherlands?

While it may all ultimately be under the same holding company, the rules and details may differ from one country to the next. This may be amplified by the acquisition history.

Yes, I am i. the Netherlands. I am not under the impression T-mobile has a special policy when it comes to the L5. I am not even sure they gave it much thought. Don’t know hownit is in the States.

Actually, I meant if the field is empty instead of showing the carrier name (T-mobile in this case), then that’s the problem. (Wasn’t implying it could show a different carrier’s name.)

Ah, like so. I had it wrong anyway.

Thanks Amarok, I downloaded the app you requested and tried to follow the guide but I don’t get FDD LTE on the bm818-tools app. I get None. Sometimes the app cannot read the firmware but if I reboot and run the app again it will find the FW version. It’s the exact FW version in the screenshot. I did the socat command as well with the AT+BMRAT command and also get None instead of FDD LTE. My APN is with no username / password set. Network is set to Automatic, I can select t-mobile for network and hit “set” but when I come back to it it’s back to automatic, doesn’t seem to save. mobile settings shows:
Modem Status
Carrier: (blank)
Network Type: unknown but sometimes switches to LTE and shows.
Network Status: Not registered.

The only difference I see is that FDD LTE never shows up. Any idea why?

I would email and ask them. They might have you download and install the most recent modem firmware. The one that I and apparently you have is an older version that works for some, but not for others, I believe.

My experience getting 4G calling on T-Mobile to work is documented here:

I had to update the firmware in my modem and emailing Purism support was what got me the answers I needed.