Is GPS supposed to work?

I’m also realizing it would have been good to ask if there was a way to check if the librem5 already had the content the script downloads. Thus far it appears to have had no impact and the librem5 is still quite confidently wrong by around 500 ft.

If you’re not getting anything from socat, geoclue likely doesn’t get anything either, which means you’re not using GNSS at all.



Yes, all 3 are up/on/whatever

Reboot and do socat as the first thing you do without touching any other location related stuff.

Well, that sounds less than ideal.

Rebooted because that seemed like a good next step and now getting a bunch of text from that socat command and the GPS does seem to be much more accurate.

I wonder how many others have had the GPS stop working and not known it since there was nothing to indicate to me that the GPS wasn’t being used…

I don’t know for sure if this was this specific issue, but there’s a reliability fix for gnss-share coming in the next update that may prevent this from happening. That said, it’s more likely that it was an effect of you running the script which now uploaded almanac/ephemerides to the module, so when you got things back to normal after a reboot it was able to get a fix quickly (the module stores this data on its internal flash so it persists).


The point is that if GNSS is not working, or the user suspects that it’s not working, this behaviour can mask the problem and confound attempts to diagnose.

Location via WiFi is a privacy problem in my opinion and should be “off” by default in the Librem 5.

One factor that you have to eliminate is caching of the location i.e. you get a fix as you enter the building and even if no fix can be obtained inside the building, it can report the last known fix. Unless your house is particularly large, such a fix won’t be too far off correct.


I second that remark on the lack of privacy when the wifi location is enabled.
And switching it off did also result in my L5 not obstinately placing me in a location I had never visited in my life. Based on my IP-address it kept ‘thinking’ I was located at some office or hub associated with my internet providers provider.
Besides, why would I need wifi navigation anyway?! I only use the navigation in places where there is no wifi. Wifi navigation is about as useful as a mobile with an extension cord.

There is a legitimate reason - because location services is not exclusively used for navigation. When I take a picture, the JPEG metadata is typically tagged with the location. If I am inside when I take the picture and unable to get a fix via GNSS but I can get a location to a precision of “one house” using WiFi then the picture will be adequately tagged for most purposes.

To an extent, WiFi navigation would work e.g. in an area where WiFi leaks out of people’s houses for many houses and that area was densely mapped by Snoople (and under the assumption that for some reason GNSS is unavailable); in other words in more urban areas.

Note that using the IP address for an estimate of the location is worse than using WiFi in most cases, from the perspective of accuracy. On a mobile device on a mobile network using the IP address is very dubious.

I assume it also helps getting the fix faster.

Okay. Point taken. I always carry a real camera, so I hadn’t encountered the tagging situation.

1 Like

On a good day the L5 gets a fix really fast (in seconds), without the wifi.
Indoors, when wifi could or should make a difference, I never noticed any benefits.

But, having said that, there have been a few updates to the positioning software in the L5 since I disabled the wifi part. So, maybe things have improvedin thus respect. I will give it a try.

Okay, tried it.
It put me right back in the same spot it put me in months ago. Apparantly nothing has changed.
Disabled it again.

1 Like

I tried disabling WiFi in my geoclue.conf too. For the first time in I don’t know how long, my L5 did not guess my location at my old house from which I moved over two years ago. I have also done the steps suggested by @dos in the post above, and it seemed to have improved the GNSS accuracy and speed somewhat.

I still have to evaluate the speed it actually takes to get a GPS fix. Yesterday, once it got its initial fix, the L5 seemed to track my whereabouts pretty accurately when I was out and about (i.e. no WiFi).

Sounds promising. :slight_smile:

I have had location turned on constantly since Wednesday this week, but my L5 seems to fail to get a GPS fix just running Maps or Puremaps. During the 10 min walk to my gym this morning, my L5 was unable to determine my position while turned on and in open air for the entire walk. For me, I usually get a GPS fix in open air within 5 minutes by using the python script gnss-test (referenced in some earlier forum thread). Sadly, getting a GPS fix just by using Maps or Puremaps on my phone takes much longer, if I can get a fix at all.

1 Like

Somehow, it gets better with time - the L5 is a lot like cheese in that respect.

1 Like

Or a good port? :wink:

GPS works only when cell or wifi service is present. There is considerable lag if attempting to use it for navigation. I spent the week in and out of an area with no cell service, left the phone open to the sky. No location, no timely location update. No increase in accuracy or utility except when sitting in a wifi zone. So, basically unusable for directions.

That’s not true. It works offline. Having up-to-date almanac and ephemeris helps tremendously with getting the fix, but downloading that doesn’t happen automatically anyway so you have to do it manually regardless of whether you’re online or not (and this data remains valid for some time, so you don’t strictly have to be online to use it either).

1 Like