Is there still no cure for the No WWan adapter problem?

I’m getting more and more the error No WWAN adapter found and need to reset the L5 to resolve the problem.

I’m connected to my provider using network mode 2G, 3G 4G (preferred).
Everything is working as it should. I have full signal strength and 4G is being used.
But then out of the blue the data connection error arrows appears as third symbol, right beside the signal strength symbol and the 4G indicator (all these symbols are located in the upper black toolbar on the top left side of the screen).

The next moment, all three indicators disappear for a sec or so and after this short moment both the signal strength indicator and the 4G indicator reappear (so without the connection error arrows).

This behavior repeats several times in a completely random pattern. Sometimes within 10 minutes, sometimes after a few hours.
I’m getting this problem more and more.

Out of experience I know that my connection (or better my WWAN adaptor) will be gone after several of these connection errors
Only way to get all back is to reboot.

When the connection is lost my SD card is no longer available too.
When I use network mode 2G only, there are no problems (tested this for more then 5 days).
As soon as I switch back to network mode 2G, 3G 4G (preferred) the symptom described as above is back again.

Any help is appreciated.

1 Like

Please read the scripts to understand what they are doing. There might be side effects.

The issue is not solved, yet. Last information has been on matrix that @angus.ainslie will not include a workaround as an official package anywhere, but will ask internally what non-programmers could do to help solve the issue.


Many thanks for your reply ChriChri.
I’ve been reading the details about the issue and how to reproduce it at this link.

I’m very reluctant for applying your solution, maybe it’s is going to make things worse.
Also, I’m not a Linux specialist, so if things go wrong I’m not able to fix them easily.

On the other hand, It (your workaround) might improve things. So I’m asking my self: What should I do?
To apply or not, that’s the question. :thinking:

Maybe I should wait a little more and use for the moment 2G as a work around.
As I have been writing, with 2G there is no connection interruption or disappearing of the WWAN adapter.
Have you discovered this too?

I’ll test that and report back. Sounds interesting.

If the workaround wouldn’t work for you, you’d just remove the package to get rid of it - part of the reason I made a package.

Do I need to have the latest Modem firmware for this?

Never mind, I just installed it. Will report back later.

No, the workaround doesn’t use any feature of the modem. As far as I remember a firmware update could only help in some cases when Voice over LTE (VoLTE) doesn’t work as expected. Support would tell you in such case how to update.

OK, still testing. So far no loss of the WWan adapter (despite some connection resets).

I’m sorry to report, but the problem remains, even with your workaround.

I wonder if “bm818-watchmodem.service” is working. see below…

purism@myl5:~$ sudo systemctl status bm818-watchmodem.service*

● bm818-watchmodem.service - Watch Modem of Librem5*

  • Loaded: loaded (/lib/systemd/system/bm818-watchmodem.service; enabled; vendor preset: enabled)*
  • Active: activating (auto-restart) (Result: exit-code) since Wed 2023-01-04 22:35:13 CET; 34ms ago*
  • Process: 11360 ExecStart=/usr/bin/bm818-watchmodem (code=exited, status=1/FAILURE)*
  • Main PID: 11360 (code=exited, status=1/FAILURE)*
  •    CPU: 7ms*

No, that doesn’t look like the service is running.

What does ˋsudo journalctl -u bm818-watchmodem.serviceˋ show you? Maybe there’s a missing dependency. I know at least of one (see the issues in my repo).

Indeed libnotify-bin was not installed. Did so,rebooted, but the script keeps complaining about missing libnotify-bin

Could you look at the journal and post the error if one is logged there?

I have used two commands to check.
One says it’s running, the other reports a failure.

Command 1: sudo systemctl status bm818-watchmodem.service*

● bm818-watchmodem.service - Watch Modem of Librem5

  • Loaded: loaded (/lib/systemd/system/bm818-watchmodem.service; enabled; ven>*
  • Active: active (running) since Thu 2023-01-05 16:40:44 CET; 4h 17min ago*
  • Main PID: 506 (bm818-watchmode)*
  •  Tasks: 3 (limit: 3175)*
  • Memory: 35.1M*
  •    CPU: 25.320s*
  • CGroup: /system.slice/bm818-watchmodem.service*
  •         ├─506 /bin/bash /usr/bin/bm818-watchmodem*
  •         ├─513 journalctl -f SYSLOG_IDENTIFIER=ModemManager*
  •         └─520 /bin/bash /usr/bin/bm818-watchmodem*

Jan 05 16:40:44 myl5 systemd[1]: Started Watch Modem of Librem5.
Jan 05 17:42:46 myl5 /usr/bin/bm818-watchmodem[2092]: seems like modem recovere>

Command 2:
sudo journalctl -u bm818-watchmodem.service

Endless number of lines with this text:
Jan 04 07:38:14 myl5 systemd[1]: bm818-watchmodem.service: Main process exited, code=exited, status=1/FAILURE
Jan 04 07:38:14 myl5 systemd[1]: bm818-watchmodem.service: Failed with result ‘exit-code’.
Jan 04 07:38:20 myl5 systemd[1]: bm818-watchmodem.service: Scheduled restart job, restart counter is at 14.
Jan 04 07:38:20 myl5 systemd[1]: Stopped Watch Modem of Librem5.
Jan 04 07:38:20 myl5 systemd[1]: Started Watch Modem of Librem5.
Jan 04 07:38:20 myl5 bm818-watchmodem[1554]: Please install libnotify-bin.

This looks like it is running. The logfile messages are off Jan 04 of the time when libnotify-bin hadn’t been installed. You’d need to go down to the bottom of the journalctl output to see the actual messages or use ˋsudo journalctl -u bm818-watchmodem.service | tailˋ to get the end of the logfiles.

A general hint about posting logs and outputs: if the program you want to quote the output of does put its output into the PAGER (most times the program ˋlessˋ) it’s hard to copy the full lines of the output. You can always pipe the output to some other command like ˋcatˋ (doing nothing except print to console) or ˋtacˋ to reverse the order of lines or ˋtailˋ (end of output) or ˋheadˋ (beginning of output).

From the console it’s easier to copy the whole lines of output. The form always follows ˋ | ˋ. The ˋ|ˋ symbol is called pipe in this context because what you put into it on one end will leave it on the other end :wink: .

The quotes you can format in the forum by marking the text and using the </> button. You can look at the help to find more formatting options.

If the workaround is active for you, you should once in a while get a message that there has been a problem, but the modem came back by itself. And if it doesn’t come back by itself there should be an alarm and an automatic try to recover.

1 Like

Thank you for helping me learning a bit more finding my way inside terminal.
It looks all a bit like DOS, but it’s more complicated.
Eventually I’'l get there :slightly_smiling_face:

Your script is working like a charm.
It makes sound and it notifies each time there was a problem with the modem/connection or SD card.
Once I had to reenter my SIM credentials. I assume that this happened after the modem was completely reset.
It’s worrying how often this resetting is occurring.
I do hope that they soon will find the cause of the culprit.

Meanwhile: Did you try to test with 2G only mode and if so, what is your experience?

1 Like

Yes, I tried briefly and didn’t find a difference, yet. But the reason might be as well that I’m roaming at the moment and that roaming itself at this place I’m in is not working very well. Gotta repeat the test at home…