L5 - someone stole my wifi card!

Any relevant messages in system log or journal?

1 Like

Do you see anything in sudo dmesg ?
What do you see when you use sudo iwlist scanning ?

1 Like

And ist the system still set to the correct date and time? If not then do so.

I flashed my Livrem 5 USA to OS 10 hoping this would cure the Bluetooth. It did not. I performed the suggested Blue Tooth firmware update and it killed my WIFI still no bluetooth. I reflashed the phone and have WIFI again but still no Bluetooth. I think its a hardware problem where some of WIFI BT boards were faulty to begin with. Should have been QC before they were shipped.


The wifi/BT card that came with my L5 USA was bad out of the box and support sent me a new one. The wifi and BT work fine since replacing the board.

1 Like

Thanks now i know its not just me. I put a lot of time into trying to get it to work. Hopefully the company will send me a new board to fix the problem. All the time wasn’t treally wasted as I am learning a lot. I now have a flash drive to run or load Pure OS 10. Im going to try it on an old Imac.

Did you try “sudo lspci” or “sudo lspci | grep -i redpine” (or, perhaps, try lsusb instead of lspci?) ? If you don’t see it there, then it is a HW issue rather than SW issue.

If it’s a HW issue:

  1. Make sure the appropriate HW security switch is toggled on.

  2. Open up the back and re-seat the wifi card.

I think the WiFi card is connected via SD. I wouldn’t expect it to show up with lspci or lsusb.

(lsusb will show the uSD card reader. lspci will show nothing.)

Log messages are what is needed.

I think this is all of the dmesg output. Hope it helps.

Neither iwlist or lspci commands are recognized.

The Wifi is mysteriously working again.
Yes, I’ve been toggling the HW switches on and off and rebooting. No idea why it’s suddenly back.

Yes but that’s an example of its working, right?

You can see the WiFi come up, and authenticate with the WAP, and associate with the WAP.

At the time of requesting the log, I did not see the WiFi connected. The text may state otherwise. lol.
I was trying to transfer the file to my laptop via USB but it wasn’t showing up then I realized the L5 was online o_O;

Left my phone sitting on the desk over night, powered off. Now it doesn’t seem to see any wifi again.
I’ll try to copy the dmesg log off later but from a quick skim it looks like the same error messages.

Take a look at my post : Bluetooth support for Librem 5
Good luck. It can also be a hardware problem. Check then the support.

I believe that the wifi card on the Librem 5 is on the USB2 bus.

There are claims to the contrary: What are the specs of the Librem 5 SD card reader?

Hmm. Interesting. I haven’t used “mmc” commands before, but I think that is what is used to probe the SDIO bus. But since I don’t know “mmc” and the format of the output, if guess that if I had a “missing” wifi card on the Librem 5 I would turn off-then-on the HW privacy switch and check dmesg. It looks like the OP already did that and it is now working.

mmc1: error -110 whilst initialising SDIO card


I’m contacting official support

Sharing the loss and reappearance of my wifi/bluetooth card:

I believe it happened on March 19. Wifi was the first thing working and had been working the whole time since I received my phone. So I tried to figure out what I had done that would have caused it to die. As a tinkerer it wouldn’t have been the first time I had inadvertently killed something. All of the sudden wifi and bluetooth couldn’t be turned on. Just greyed out icons, no matter which position the cutoff switch was in.

So what had I done over the weekend that could have failed it? I added the group “users” to the purism profile so I could play with more directories. I changed my ringtones (I had added “users” to make that easier). And I updated the main software through the PureOS store.

A few days into it not working, I had read enough, so I tried a few fixes described by others. Time/date was fine. So I put the firmware update into the special autoloading folder. Well, that didn’t work. So I changed the mode to 13. That made it angrier and it showed an error in the log. So I changed it back to 5. Still didn’t work. Didn’t really figure out much else throughout the week, but kept doing updates, and trying to reboot both with the switch on and off. Still nothing.

So I started reading this thread. Looked through the dmesg output. Removed the firmware from that autoloading directory (for some reason it never deleted itself). And I began writing a little paragraph here to see if anyone could help out.

I didn’t finish my paragraph Sunday night, so I just updated the phone software again and went to sleep. When I woke up (March 28), the wifi and bluetooth software switches were active again. I was fairly stunned, but it hasn’t stopped working yet. I think it even worked once while the hard switch was off, which I don’t understand.

So, in the end, I don’t think I did anything that fixed it, so maybe the software update fixed something on it? I’m just providing this anecdote as a data point in case this occurrence repeats for others. So for anyone’s who hasn’t been working I encourage you to update software all the way (if it’s not) and try it out again.

1 Like

Update: they sent me a new wifi card along with a video for me to DIY. It was super easy to replace. That somewhat fixed my issues but i feel like this is a combination with bad hw and very unpolished sw for the hw that currently requires too much messing with. :frowning: Hopefully it’s more of the former.
I sent another e-mail. Let’s see what the next step is.

1 Like