Librem 13 crashing repeatedly

Ok sorry for the ignorance here but I am totally new to linux and this is “chinese” to me. How do I check those things?

Are you currently logged into your PureOS installation?

yes, I am logged in to PureOS

Do you know how to open a terminal (i.e., the command line)?

Yes, I can open a terminal. Does it matter which one I open? I see an Xterm and a UXTerm…

Go to the “Utilities” section of your apps, and click on “Tilix”.

ok done…

Once open, type the following:
cat /etc/apt/sources.list
Then, paste the output here.

deb https://repo.puri.sm/pureos/ green main

So that appears to be correct based on your earlier message. I also just did the sudo apt update and the sudo apt full-upgrade. It is still working on the upgrade. I think I know how to chose the GNOME on Xorg at the log in so I will see if this solves my problems. Thanks for your help!

Actually, yours says, https://repo.puri.sm, instead of https://repo.pureos.net . To change this, simply type sudo nano /etc/apt/sources.list in the Tilix terminal, enter your user password, and it will open the file for you to edit, inside the terminal. Delete what’s there, and and type exactly what I stated above instead, and then do sudo apt update && sudo apt upgrade .

2 Likes

I have the same issue since yesterday. Attempting information listed here … will keep you posted. Pretty upset and worried.

So I tried this and was surprised because I suddenly saw improvement in the computer - it stayed up for about 15-20 minutes. The symptoms later resumed and it crashed (suddenly powered off) about 4 times in two minutes. I have had a variety of errors at different stages trying to reinstall or fix this. The computer is completely unstable and will not stay up at all. At this point, I am contacting puri.sm and getting ready to leverage the warranty unless I hear from someone soon. You can reach me quicker at oemb1905@gmail directly. This is serious and began yesterday afternoon. In order:

  1. At 4-5 pm, keyboard starts typing in wrong characters
  2. I attempt to fix with external keyboard, everything is slower by 8 times normal
  3. Reboot, and network manager is at a total halt and won’t restart with systemd
  4. Reboot again, nothing, i attempt to edit character and keyboard settings in /etc and cannot access
  5. I attempt a fresh install, assuming the pipe character setting from another forum post caused the problem
  6. From last night at 8pm until today at 10am, I have tried various installs and seen various failures from CPU temp during boot, to character set failures on apt upgrades on the 2/3 installs that succeeded … most of the time, during the attempted fresh install the installer would crash just like the system was …
  7. The crashes (random shut offs) increase in frequency and it begins to seem software is tied to issue … i try to reinstall OS with live CD and no mirror to ensure it succeeds
  8. same issues of random shutting off occur, no chance to refiz keyboard character issue or set new system up because it crashes during any apt install …
  9. i see this forum post … i try to use x org and do the stated steps and it succeeds logging in without crashing … it succeeds running for almost a half hour
  10. crashes after i install gnome and reboot … i also installed pureos-* … machine is now crashing repeatedly again, doubtful from packages …

Hope the detail helps … help!

update: after 24 hours of repeated crashing … i gave up and installed debian stretch and did it with no mirror, gnome, but otherwise non-free 100% … it works, i post this now … MYSTERY … much love to #freedom … would love to return to pureOS … was it Kyle Rankin’s IME removing / coreboot / tpm script? Is Intel barfing at that? did debian return me to some propietary hidden micro code that my computer now boots and stays running with again? …

I heard back from customer support after a rep named Goran escalated this … here is what they emailed me!

"We have discovered a regression in the latest coreboot BIOS that was installed on your laptop. This regression causes the CPU to heat up faster and higher than it should and under high load it can cause the system to spontaneously power off. To fix this issue will require that you flash your BIOS with our latest version of coreboot. All of these steps will require that you run commands in a terminal.

Here’s what you need to do:

First, temporarily disable the TurboBoost feature in your CPU. This will
prevent the laptop from shutting down while it is building the coreboot
BIOS:

sudo bash -c “echo -n 1 > /sys/devices/system/cpu/intel_pstate/no_turbo”

Next, update coreboot:

  1. Download the build script
    mkdir building-coreboot && cd building-coreboot && wget https://code.puri.sm/kakaroto/coreboot-files/raw/master/build_coreboot.sh

  2. Install the required dependencies:
    sudo apt-get install git build-essential bison flex m4 zlib1g-dev gnat libpci-dev libusb-dev libusb-1.0-0-dev dmidecode bsdiff python2.7

  3. Run the script on your Librem machine:
    chmod +x build_coreboot.sh && ./build_coreboot.sh

  4. Follow the instructions on the screen, and BE SURE to select your
    correct Librem laptop revision (Librem 13v2 or Librem 15v3, select Librem
    13v2 if you have a Librem 13v3), and give it time to build the image.
    Beyond selecting your specific laptop revision you can select the default
    choices for the rest of the script.

  5. Once done, if everything went according to plan, it will ask you if you
    want to flash the newly built image.

  6. Make sure you are not running on low battery and select Yes.

  7. Reboot your machine once the flashing process is done.

Once your machine is rebooted, you should no longer have any spontaneous
power off issues."

4 Likes

It works! Thanks to the support - first try and no problems. Much obliged. This team upholds the terms of the warranty! Thanks! #freesoftware

I followed both @ezs777 and @oemb1905’s suggestions, and I can confirm that my Librem 13v3 has stopped crashing when doing more intensive tasks!

Thanks everyone!

1 Like

Sorry to resurrect this dead thread, but I have been experiencing a lot of crashes lately. Is what you wrote here (way back when) still valid?
My crashes are slightly different from what is described here. My screen freezes and if there is any audio playing when the crash happens the audio loops at two second intervals until I kill the computer with the power button.
My out put from doing cat /etc/apt/sources.list is:
deb https://repo.puri.sm/pureos amber main
deb https://repo.pureos.net/pureos/ amber-security main
deb https://repo.pureos.net/pureos/ amber-updates main
Does that look wrong?

No.

Some is. Some isn’t.

All the stuff about green is obsolete. It should at least be amber if not byzantium.

All the stuff about always running the latest software (apt update and apt upgrade) is pretty good timeless advice.

You should specify what hardware you have (make/model/version).

VERY important … on ANY machine if you want to update BIOS/UEFI, make sure that you are using some form of battery back-up … if you get a black-out during the update you have a high chance of bricking your machine …

laptops/smartphones already have a battery but with desktop/workstation/servers/IOT that is not always the case …

Librem15 version 3