Librem 13 Screen Flicker / crash linked to wifi / kill switch

In the meantime I’m sure that at least in my case it depends primary on the wifi network I’m connected to. Most of the time I only use my own phone (it’s a GT-I9300) as hotspot and I occasionally see any flickering. But when I connect to the hotspot of my wife’s phone (it’s a Fairphone 2) the flickering is extremely severe and crashes the system (just as you described it in your original post) – almost every time.

The thing is: I don’t move. I sit at the same table and the phones are on the same spot. I get the same signal strength and both networks use the same frequency 2.437 GHz (channel 6). It’s really strange…

I try to make a video of the screen flickering in the next days.

I’ve got the impression, that during the last weeks suddenly my 13v3 startet with Screen flickering. Since yesterday/today - after another software-update - the situation got even worse. Flickering for a minute and eventually the screen slowly died away (from left to right). After directly sending the laptop to sleep and restarting everything’s fine.

1 Like

OK, it took me longer than I thought to make the videos but here they are.

The first and second video show “normal” screen flickering, the third one shows the effect of searching for wifi networks (screen flickering increases).

Video 4 and video 5 show the worst case when after severe screen flickering the screen freezes and goes dark. I just looks like the screen dies. When I watch this process for some time, send the notebook into hibernation and wake it up again, it takes some time for the screen to recover. For several minutes the edges of the screen are brighter than the rest (see this picture).

@veggies Is this the flickering you are seeing or are we talking about different issues?

@mladen Could you please have a look at this. Is this a known problem?


Thanks for the videos, @stefann.

Regarding the flicker, it is very similar to that shown in your videos. Mine tends to vary somewhat randomly in how ‘erratic’ it is (how rapdily and how large the flickers occur), but it looks very much like in the first few videos. Also, when it gets severe and kills the screen, it looks quite similar to video 4 and 5, though most of the time on my end that lock-up / “fade out” happens a bit more rapidly, and seems to totally resolve upon sleep-wake cycle (until the whole flicker cycle starts up again after a minute or two). I havn’t noticed the brightness around the edges after sleep-wake (unless I just havn’t payed attention to them, but in the screenshot they do not seem subtle).

One other change I’ve noticed is similar to @ajlok experience. I noticed that for a few months the flickering seemed to have become much less frequent when in my office. Then, seemly out of nowhere, it flared up about a month or so ago and has become even worse than originally. Now, it will be guaranteed to start flicking after a minute or so, and continue until it freezes, almost 100% of the time in that location. As far as I know the network didn’t change, unless the organization made some sort of internal adjustment. Thus, perhaps there was an update-realted change that effected it? Also I can note I do not have any problems (nor have I ever had freezing) at my home network, during any update cycle. Conversely, I have always had problems in certain locations around my workplace (other than office), regardless of update cycle. The point is just to reiterate that it is location and/or network dependent, and there has never been a time when it always flickered or never flickered; just some variance in severity/frequence in some locations

No, they’re not subtle at all… It depends on how long I wait until I send my notebook into sleep mode. The longer I wait the brighter the edges get when I wake it up again and the longer it takes for them to disappear.

One more thing: Not that it seems very likely but i can count out the wireless module as cause for this issue because I can reproduce it with two different modules (for the reason why I replaced the original see my comments here: bug report T23).

I can observe similar flickering and display dropouts with my non-purism computer, Ubuntu 14.04 and 18.04 and an external 4K display.

There is a big open issue at regarding this and maybe this does affect more computers and GPU chipsets than reported (AMD).

The most probable reason is a new power management feature:

Just a guess (I am waiting for months now to get a decent fix for that)…

This can be caused by bad drivers indeed, there were some reports that proprietary firmware actually helped. Could you guys test some distro that is not using libre kernel, like Mint, Arch?

1 Like

I have the flickering problem on my Librem 13v2 and have posted to the forum at least twice, once about a year ago, and once recently. I, too, have tried the suggested workarounds, without success. It is very annoying and makes some web content unreadable for me. I see the flickering mostly on certain web pages that are high contrast and have a dark background. Turning WiFi off isn’t really an option for me, as I need it for email access, web access, etc. The Librem 13 is a great laptop except for this problem.

OK, I’ll test the proprietary firmware for our graphics hardware by installing firmware-misc-nonfree on Debian testing and adding the kernel parameter i915.enable_guc=2 to enable GuC and HuC (as described in the Arch Linux wiki).

@mladen Please tell me if you are talking about some other proprietary firmware.

@stefann Any changes?

@all: you might wanna try this:

Here’s an Arch Linux package to automatize this, just unpack it to / and tweak the /etc/intelpwm.conf :

Please report if it helps.

I’ve got confirmations that the above solution works. Please test and report your findings.

Sorry it took me so long. I’m in my second place of residence and I wasn’t able to reproduce the issue so easily… Here, I can connect to the hotspot of my wife’s phone without any problems… So the original reporter was right: the problem seems to be correlated with physical location and/or wifi signals.

However, I had extremely severe screen flickering today – after I enabled GuC and HuC (see above). So from now on I’m going to test the solution posted by @mladen.

On Debian (testing) it seems like I’m affected by this bug: intel-gpu-tools: Unable to read its own config files due to use-after-free. All register access tools (for example intel_reg read and intel_reg write) fail… Is there an easy workaround?

Sorry, I didn’t find a way to test this… I built intel-gpu-tools as described on the projects website but I’m still affected by the issue mentioned above (intel-gpu-tools is unable to read its own config files). Am I the only one?

After reading a bit about the screen flickering issue caused by low PWM modulation frequencies I get the feeling that this is a completely different issue… @mladen Have you watched the videos I posted?

Btw, please delete or edit the obsolete Troubleshooting entry for Screen Flickering. enable_rc6 is no valid parameter for i915 anymore.

You can list all available module parameters with sudo modinfo i915. Parameter enable_rc6 is not listed there and if you add i915.enable_rc6=0 as kernel boot parameter all you get is this kernel message at boot time:

i915: unknown parameter ‘enable_rc6’ ignored

And then one more thing. To everyone who is trying out different module options (like me) to get rid of screen flickering: At least on a Librem13 v3 it makes no difference if you add the kernel parameter i915.enable_psr=0 because it is set to 0 by default (see this posting for an easy way to find out). modinfo i915 tells me that there’s a “per-chip default” in use, so for our chip the default seems to be 0.

Hi all,

It’s probably unrelated, and I didn’t try any fix mentioned above to see if that changed anything.

Today I have seen my L13v3 screen flicker when I was holding my phone over the laptop, in front of the screen.
I was in conversation using the speaker mode.
That was surprising.

Could that be some kind of EMI sensitivity ?


1 Like

OK, I managed to fix that trivial bug in intel-gpu-tools and tested this. First thing I should mention: The bug is not only trivial but also irrelevant… When I tried sudo intel_reg read 0xC8254 in the beginning I got this:

Error: /usr/share/intel-gpu-tools/registers/gen8_interrupt.txt:1: (‘GEN8_MASTER_IRQ’, ‘0x00044200’, ‘’)
Error: /usr/share/intel-gpu-tools/registers/skylake:1: gen8_interrupt.txt
Warning: reading ‘/usr/share/intel-gpu-tools/registers/skylake’ failed. Using builtin register spec.
BLC_PWM_PCH_CTL2 (0x000c8254): 0x03a903a9 (freq 937, cycle 937)

After fixing the bug I get this:

(0x000c8254): 0x03a903a9 (freq 937, cycle 937)

Writing works as well, so “Using builtin register spec” seems to be good enough. I tried a lot of different PWM frequencies, it never made any difference – the flickering was just the same. @mladen Please remove the “Solution”-mark, I guess we’re back to square one.

While this perhaps won’t solve the screen flicker problem for the original poster, it does in fact solves screen flicker problems, for the cases where this is not hardware related problem. We’ve somehow hijacked this topic from OP (@veggies ), so let’s hear from him/her if this solves their problem.

Yes, sure. I just didn’t know that low PWM frequencies can cause such severe screen flickering and even crash the system.

So would you say that in my case it’s probably a hardware related problem and I should contact technical support ( In that case I’d stop spamming this thread :wink:

Yes, sorry for that! Since both our screen flickering issues (the OP’s and mine) seem to be at least correlated with physical location and/or wifi signals I didn’t want to open another thread (when you search for reports about screen flickering issues you won’t find that very often).

I applied the register changes suggest. The changes dimmed the screen brightness. They may have reduced the flicker/blinking, (I don’t have any objective measure of that) but unfortunately it did not remove the problem.