Librem 13 v3 / Font size too small or too large

I bought a Librem 13 v3 which has a 13" display with a resolution of 1920x1080, which is considered “hidpi”. I configured PureOS and noticed that the font size is much too small to read.

The Gnome 3 settings actually allow scaling the interface to 200%, but this is much too large.

Unfortunately, the Gnome 3 version used in PureOS does not support fractional scaling. There is a way to enable an experimental setting, but when using that at 125% it looks really bad.

  • What options do I have to get readable fonts and icons that look good?
  • If Gnome 3 is not the right desktop, which one supports proper fractional scaling?
1 Like

i altered the font size via ‘Gnome Tweaks’.
hit the purism button type Tweak in the search box, you might need to install it.
open Tweaks, appearance will come up and fourth item to the left is fonts.
i got this information from a previous post about setting up your new purism, i will re-post it and acknowledge who posted the original information.
Hope this helps

thnx to @vrata

1 Like

I installed a pure Debian 9 in the meantime, because installing KDE on PureOS did not work (broken dependencies).

On Debian 9 I tested out different desktop environments, and even KDE did not look as nice as I would have expected with its fractional scaling (which was blurry, just as in Gnome).

Then I found that X11 thought that my screen had 96 dpi (via xdpyinfo |grep -B2 resol).
I created a file /etc/X11/xorg.conf.d/90-librem-display.conf with the following content:

Section "Monitor"
    Identifier   "eDP-1	"
    DisplaySize  294 166 # In millimeters

After rebooting, xpdyinfo reported the correct 166 dpi and the login screen had proper font size.

In KDE, the fonts were much too large.
In Mate and XFCE, the fonts were large enough automatically, but the icons too small.

In Cinnamon, the font sizes and icon sizes are very fine automatically. I’m using that now and am fine.

Qt applications used a font size that was much too large (Qt automatically scales the fonts according to the display’s dpi. I solved this by forcing Qt to assume a lower dpi value:

1 Like