Librem 13v3 bricked?

I’m home now, after lugging the brick all over the world. When I get home from work I’ll just plug it into a monitor and see what happens.

I do have a decrypt password, but it’s long and messy enough I’d not be sure I had typed it in properly.

Might not work. Does the early boot phase recognise and use the external monitor? sometimes? never? always? Worth a try though.

i think vga mode for the hdmi should most likely work with kinda much any hw, but im not sure.

@SteveC try hitting the reset button (next to headphone jack) with a paperclip or sim tool?

Good thought, thanks!

No joy, however; it didn’t have any effect other than to shut it off. Powering it back on put me in the same bricklike state.

I did try the monitor; and I made sure to cycle through the Fn key states for external monitor setup.

Nothing, other than the monitor going to power saving mode in about three seconds, as it is wont to do. (Kind of annoying, actually, since it’s hard to debug issues like this when the monitor won’t stay on.)

so it have no signal, thats sad. if u still wanna fix it urself, then the best is still to mess around with the internal connections, i think if it was already good, then its just an erroneous connection somewhere.

on irc, currently someone have a similar issue with a brand new machine, maybe u could join to it if anything valuable comes up there in the meantime. (freenode -> #purism) btw the symptoms that the other person have is this: " disturbingly, the wifi LED comes up even if the kill switch says its off"

that would be me.

It’s brand new device, no boot at all. i think this is a DOA in my case, because the device never booted at all. here’s what I sent support@.

  1. fiddled with the screen keys to toggle the external/internal screen settings (Fn+F7/F8), no change

  2. depressed the “Reset” button next to the headphones jack: turns off the LED, but otherwise has no effect

  3. leave the power plugged in in the hope this is a battery problem (orange led turns on, no other change)

  4. connect to an external, known working, HDMI display in the hope this is a screen problem (no display there either)

  5. fiddle with the backlight settings (Fn+F10): they change the backlight, but otherwise do not affect the boot sequence, naturally.

  6. shutdown, unplug, and press the reset button for more than 7 seconds

  7. open the back cover of your device and re-seat the RAM module

  8. unplug the AC, the main battery and the CMOS battery, press and hold the power for 10 seconds

  9. (bonus) try another, known working, memory module

  10. boot without a memory module (no change)

(I wish those troubleshooting steps were documented somewhere, but I’m not sure where to do that between the three wikis… )

I don’t buy the “display problem” theory: in that case the external HDMI would work and stuff like “caps lock” or control-alt-delete would do something as well.

and my case is different, as mentioned on IRC: for me the device never worked, although it could be argued it did work at some point because surely it was tested before being shipped…

1 Like

Yes, that matches my situation precisely–except that I know mine worked, because I had it for several months before this happened.

Did you send yours back? If so, they may have figured out what happened, and that information could be useful for my situation.

if im right, this is a fresh case as well (sorry if not, its not always a fine stuff to try answer stuffs in others’ name :smiley: )

Not yet: support replied with more debugging steps (which I’ll add to my above post), none of which work so I guess that’s the next step. Hopefully they’ll figure something out as well. I’ve pointed support to this thread as well, and I suggest you reach out to them as well…

with the constant crashes people are having, now some laptops are randomly bricking? Not good.

6 did nothing for me, but 7 actually did the trick.

@anarcat, I suggest trying 7 again. If it still doesn’t work, I’d strongly suspect your ram module is bad.

(At least, I think it was the ram module–it was pretty much the only thing that wasn’t screwed in place, and had two thingamabobs, one on each side, that when pried away gently, allowed it to hinge upward; the module itself had four chips on it.)

@anyone else: The mechanism (thingamamobs) that holds the ram module IN is not proof against having a padded case tip over from a height of something like 75 cm. Now that I think about it, I had my carrying case tied to the top of a tip-over-prone wheeled carry on bag, and it fell over in the airport at my destination. That was apparently enough to jostle the ram module loose. I could very readily imagine it working loose during shipping if boxes are tossed around casually by the shipping companies.


As I just told anarcat, it appears that my ram module came loose. It has a mechanism that’s supposed to hold it in place, but it doesn’t strike me as being terribly robust.

…and lesson learned; travel with a screwdriver that fits the case screws, in case it happens again.

I did that multiple times. I also swapped in a known-working RAM module and that didn’t work either. So either the RAM controller itself is bad, or something else blew up, but it’s not the RAM socket or module, because it works.

My totally unscientific, uneducated guess is that it’s your RAM controller, then…since that would probably cause the same symptoms as (essentially) missing RAM, and we do seem to have had the same symptoms.

Anyhow…you were very helpful to me; thanks!!! I only wish my suggestion had panned out for you.

1 Like

I have seen, on an older Dell, that if the main battery is exhausted, beyond shutdown. Then the computer would not run off the mains, or charge the battery. Replacing the battery fixed the problem. I could hypothesize that unplugging the battery might allow it to run off the mains.

Is it possible that when you stopped working last, you just closed the screen, instead of doing a full shutdown from the OS?

One could also hypothesize that some hangs are from some websites who have software that insists on monitoring connections, and will not advance without that ability. But one would think that would clear on a reboot, and clearing some histories. But that is a different issue.

Is there an option with a Librem where it could be booted from a USB version of another Linux. I am guessing you did try to look at BIOS/EFI?

Making sure that it is in your checked-in luggage, not your carry-on luggage.


(See this is what is crazy with airline travel security. You can’t travel with tools to fix stuff (ie. a screwdriver) but you can definitely buy something that you can easily kill someone with (a vodka bottle).)

That said… I got the RMA on Thursday, but the process has been stuck on getting a shipping label for some mysterious reason. And it’s not clear they’ll want to do cross-shipping which means I might have to wait another month to get this stupid machine. It’s getting really annoying.