Librem 14 - First Impressions

Librem 14 - First Impressions

I received my Librem 14 less than 24 hours ago and so far I have been impressed and disappointed numerous times with the whole experience. If you don’t want to read through the rest of my documentation on this then I will sum it up by saying that this system is a very capable little machine that is really lightweight i.e. they nailed the “RoadWarrior” market with the machine.

A little history is probably needed for my story here. I am not the most tech savvy person even though I have worked as a Systems Administrator/Database Administrator for most of my life (yeah I am old too). That being said I have worked with Linux for years and had followed Mr. Rankin via his contributions to the Linux Journal (R.I.P.). I heard about Purism years ago, probably from something I read in the Linux Journal but passed it off and went with System76.

I was happy with System76 even though they were just re-branded Celvo’s they had stable and supported drivers. Yeah, they were proprietary and yeah there is all sort of holes for those with knowledge and resources (put you favorite 3-letter acronym here please) to circumvent the system. But I wasn’t really worried about that. I paid my taxes and don’t do anything wrong, at least intentionally, so why should I care?

Well, in the past few years I seen attempts get more complicate and originate from a more diverse set of actors that it really has me concerned about our reliance on this technology, its place in the future, and how to protect it and keep it from being enemy.

Okay, so I had looked at the Librem stuff before and in comparison to it’s biggest competitor they both lacked capability or were much more pricey for the capability. Usually Librem was well over a year behind on processor version and the same can be said for this one, but they get a COVID pass as the target launch was first portion of Q4 2020 which would have made it a pretty quick release.

The Package

The delivery was typical FedEx, boy I hope they got deal on using.

It was scheduled to be here on a Friday and I was to sign for it. No problem, I can do that. So I signed up for alerts with FedEx to go to my phone number that way I would know when they were out with the package.

Friday came and I didn’t get any messages. Okay, so I check the website just in case (it is FedEx and don’t trust ‘em any further than I can throw one of their trucks’). Well, they had a problem and moved the delivery to Monday. Great, why did they not SMS me like I signed up for? Oh well… it is FedEx so I will sign up again and wait for it on Monday.

Saturday comes and thank goodness the wife was outside working checking the garden as they ended up leaving the package with her but they were going to just leave it, didn’t have her sign for it and we have been getting a lot of rain the past few days (about 7.5 inches in the last 48 hours) so my new laptop may have been a soggy mess if she would not have been there. Thankfully I have my new Linux laptop.

The box is rather small and unimpressive compared to what I had been used to with my previous purchases from the Denver folks. But that is okay, I have a metal shell on this laptop. Anyway, the packing materials were just fine. I did not opt for the interdiction service as I am just not that paranoid about my devices being compromised during shipping… yet.

The machine

First I open the clam shell and realize that the screen is uber thin and really bendy. I don’t know how much flex the screen can withstand but am mildly concerned that I could easily injure it if I am not careful (I am a big guy, think defensive tackle) so it may not take much to break.

I plug it in and power it up, go through the setup process and am up and running. So far so good, less than 10 minutes in and I am surfing web pages… wahoo! I start checking this little guy out, weight, ports, trackpad, keyboard, etc. I then noticed all of my finger prints all over the system. Hmph, it looked good at first and now it looks like had been working on it while eating Pizza Hut Deep Pan Pizza, might be difficult to keep this little guy presentable when doing on prem work with the customers present. It is what it is… lets carry on. then notice that the two-finger gesture work in Web web browser, very nice! I also realize that the Librem 14 is very responsive, quiet, the screen is bright, and the speakers get loud, not good for music but handy for voice applications like zoom or Youtube screencast tutorial. So far, I am really starting to dig this.

Since I am stating to like this machine I decided to install some software that put on all my work machines start off with VIM. Well that was a bust, I go to run sudo apt install vim and I get a series of errors trying to get to the main repository and there are no mirrors listed in the sources.list file. There I sit with Web and Terminal staring at me waiting for some kind of input. I decide to look for alternate mirrors and after a few minutes find one, although I don’t know if I can trust it. I am impatient and add it to the list, run apt and whew, I have VIM again!

The reason I share this is that it would have been a real pain for the typical user and would have triggered a support call, they would be frustrated and upset. This is something that Purism needs to eliminate if they want to scale beyond the niche they currently have.

Okay, the next thing I notice is that my battery indicator is charging but is stuck on 79% and hasn’t moved since I first plugged it in. I thought this was a bit weird but recalled something Nicole wrote about in an article a couple of months ago and thought it might have something to do with the settings. When I ran cat /sys/class/power_supply/BAT0/status it displayed Charging so I figured that it might be a problem with the GUI giving the right values and maybe I would need upgrade and reboot for it to get straightened out so I didn’t pursue manual settings any further.

It appears that may have been on the right track, at least partially as I did eventually get the Power Statistics program and the gauge to actually show an increase in the battery energy and not just show that it is charging without increasing percentage or stored energy in Wh by draining the battery in increments and then plugging it back in. It apparently is set between 52% and 65% (27.4 and 34.2Wh respectfully). I haven’t found where that is and at this point I can just live with it, but the behavior is not expected by the end user and is likely another point of frustration for them.

I decided to slap some RAM (64GB worth) and see just how capable the machine can be. To do that I needed to pop the case and while I am in there I can check out the hotfix and see how “bad” it really is.

The hotfix is there on my board and it was hidden by tape that holds the wifi antenna cables down but mine looks a lot better than the first images posted. There is no sign of heat stress on nearby components and aside from a little residual flux I would likely not known any better that it was a hotfix so its use does not worry me in the least.

The RAM they shipped with was Crucial (one of my favorites) and the RAM I put in was Crucial and took it without one hiccup.

I was also pleasantly surprised that Purism sourced a Samsung 970 EVO Plus for the 500GB NVMe option, another bonus!

So far I have VMware Workstation, VS Code, and a lot of my other tools installed that I usually use for my work so now I will see what it truly is capable of.

Overall I am please thus far and hope that my feedback helps other consumers as well as the Purism folks.


For those speakers check out Better EQ for Librem 14 speakers


Thanks, that does help quite a bit.

1 Like

You might be effected by this problem:

1 Like

It now makes sense what Nicole was suggesting in this blog article. I first needed the driver for the EC to see the charge settings in /sys/class/power_supply/BAT0/ shown below.


Instead of pulling the project and going through the gcc/make process I went back to a mirror repository to see if I could install librem-ec-acpi-dkms from there, and I did.

sudo apt-get install librem-ec-acpi-dkms

Thank you.

1 Like

Hi. I just got my Librem 14 yesterday. I was very happy to get it after 11 months of waiting. The packaging was fine, but when I inspected the outer covering, there were 3 small screws missing in the bottom cover. Also, the right side, at the area where the ports are, was loose and I had to tuck-in to fasten. The rest was OK so far. I originally had requested only one privacy scree, I emailed them that in the order there were two, nothing was done, and I got charge for the two screens. Am just glad this is over for me.