Librem 14 + Qubes OS - Multiple Problems

Hi everyone,
months ago I received my Librem 14 and, overall, my experience as a client was pretty bad.
The hardware I received was pretty cheap, some letters in the keyboard are “stuck”, one of the screw was ruined and thus impossible to remove (and for this reason I had to literally cut the notebook to apply hardware upgrades), and it does not satisfy what the team said in the past months.

I know this is a startup and they had external issues that they could not control. But I think that they should not send devices like mine, because it should not pass quality control…

Anyway, this thread is regarding another topic: Librem 14 + Qubes OS.
I have several issues:

  1. WiFi is not working. My notebook does not show WiFi networks around me. Just ethernet connection is available. The WiFi part is not existent at all. How can I fix it?
    (With PureOS WiFi was working)
  2. Battery percentage is broken. I already applied latest PureBoot firmware and EC upgrade. Anyway the battery problem is still here (on PureOS and on QubesOS).
    The battery is always at 49%.

Thanks in advance for the help

If your wifi was disabled via the kill switch when you installed and configured Qubes, it is possible that your sys-net VM was not assigned the wi-fi PCI device, causing this issue.
If that is the problem, you can fix this by:

  • reboot your L14 with the kill switch on (wifi enabled)
  • shut down sys-net
  • go into the VM settings for sys-net, in the devices tab, and manually add the wifi device (should be 01:00.0 Network controller)

Edit: after doing so, sys-net may fail to start if you turn your L14 on with the kill switch off. For a fix, check my solution here Qubes fails to start sys-net if wifi kill switch is off


Did you reach out to purism support?

1 Like

I installed Qubes with the WiFi switch on.
I tried to reboot the L14 with the switch on and it’s not working anyway.

I will try to shutdown sys net and edit settings. Will update asap.

This fixed my problem. Thanks.

What about the battery percentage issue?

That might be an issue specific to your laptop. One thing you could try is to drain the battery to 0% and then charge it.

Have you got issues with fan noise? What is the CPU temperature at start?

Thanks for your feedback @Purist

No fan noise issue, will check temperature asap

1 Like

Tried to do it. Does not help. Now battery is stuck at 35%

Have you seen the thread Librem 14 Failed to charge SOLVED in reference to the battery charging issue?

Do you know if the wifi disabled with the kill switch when you installed Qubes?

Have you tried to follow the bellow instructions?

1 Like

I tried folllowing the tutorial you shared:

But nothing changes… Battery is still stuck and keeps saying “Charging”, while it’s always at the same level.

Now I will try to fully discharg it and see what happens…

is your EC firmware up to date?

Yes it was updated. Anyway, after a full discharge, it looks like now the battery is correctly charging and my OS is showing the right %

1 Like