Librem 15 won't turn on

Yeah, it has been suggested previously, I think.

1 Like

I would love to know why this works and where you got those instructions. Any ideas?

1 Like

The best (seemingly) relevant bit of detail I’ve found is here:

I did just have a strange issue where several neighbouring keys (i, j and comma) suddenly stopped working, and I saw someone recommend the same solution as above for a different laptop - to see if that worked, I tried that first before (e.g.) compressed air, and it fixed all three keys immediately. I had walked with the laptop in (a case in) my satchel after noticing that, so it had been turned over several times already, and had made some effort to see if there was something lodged under them with no joy - that approach worked first time. Also, no recollection of any spillage, and no evidence of moisture. Maybe it’s just me, but +1 for hardware toggle :smiley:

Sorry about th late replay i have not logged in recently.
This is actually an old trick. Essentially what your are doing is to fully dran any power that is still in the capacitors. you ccan do the same thing on a desktop that is giving you issues by removing the power cord and switching from the voltage for you country to the opposite setting. we jokingly called this a power supply reboot but what you are hoping is that switching grounds/earths the caps and drains them.


I seem to have similar symptoms with my two months old Librem 13 v2. Yesterday, as I opened the lid after it had slept during the day, it immediately went out. I pressed the power button, an LED lit up as if powering up, then it went dead after some 15 seconds. I think it still lit its power-LED, which was to expect as it’s power adapter was plugged in. I tried again, and the same thing happened, but after that, there was no indication that the power adapter was plugged in. This is still the state: No indication that the power adapter is plugged in, and no response whatsoever from pressing the power button.

I tried the suggestion from @jbloodwo, thus disconnecting the battery, unplugging the power adapter, holding the power button for 1 min., replugging the power adapter, and pressing the power button. I tried this several times with no result. I even left it unpowered with battery unplugged overnight, and still no response when trying to boot.

Do you guys have any further suggestions about what might be wrong, and how to detect and solve it before I must contact support? Thanks in advance!

if you have access to a multimeter, check the power supply to verify that it is outputting power.

Sorry, I forgot to mention, that was the first thing I suspected, and I measured ~19.5 V.

what about trying to boot without the bat in place.

Yes, I tried your suggestion about booting with unplugged battery.

then the only thing i could think of would be check with Purism and see if they might have an idea. if your are in north San Diego county in the San Marcos area i would be happy to see if there is anything i might be able to see to fix this without needing to dispatch this to service.

Thanks for your suggestions, I really appreciate your concern and effort! However, I am in Norway, so I have written to Purism Support asking for advice. Thanks again.

1 Like

Hi @libremuser1,
I ended up sending my laptop in for repairs. I think it was a fault in the internal power system. It came back fixed, and I have not had that problem since. I am sorry that there may not be a quick fix or workaround, if your case is like mine. At least the Purism staff is helpfull and conscientious, though it does take some time.

I bought a new Librem 15v4 on eBay in December 2019. A few months later I installed Ubuntu-MATE 20.4, with very good results.

I used it very seldom until January of this year, when I began using it 3-5 hours per day.
I didn’t have any odd behavior from it until March 30.
The laptop was plugged into AC power, and when I came back to
it from a break, the screen was black and no power lights were lit.

I tried restarting it, then unplugged AC, retried, then re-plugged AC a few times, with no luck.

The next day I followed a tip in the Purism forum from jbloodwo in this thread:
Took off back cover and disconnected battery, then pressed power button for around 30 seconds, then tried AC power. No change.
Then re-connected battery and put cover back on and tried again, with no change.

Since then I wrote Purism support, got a suggestion that didn’t work, and since April 7 the status has been “still checking if we have the parts”.

Based on the future laptop direction of Purism (Librem 14 only), I’m not very hopeful of getting any real help from Purism now.

I was thinking of stripping the good parts (screen, CPU, etc.) from the Librem 15 and putting them into another laptop base, but I was told by a local computer shop that only the memory and SSD drive would be transferable.

Any ideas on how to proceed?

Keep hassling them - and if the final result is that they don’t have and can’t get the parts then ask them at least what parts they are talking about.

I assume that it is not a new laptop and that you bought from a private seller, rather than a company. If it is a company, what warranty did they give?

Thanks for the reply.

I think the part in question is the motherboard, which costs $250 (plus labor, I assume.)

Purism’s warranty is 1 year, so I am somewhat over that now. (Since I got it new, I would assume that they would have honored it.)

This is happening on their phone too. I have a pretty new phone (September 2021 is when it shipped). Performing this stupid power cycle without a battery for 30 seconds appears to allow it to turn back on.

What’s wrong with holding power button few (2-3) seconds more? Without taking battery out, until green LED light comes on.

Also, didn’t you try this advice ending with: “There should be no need to remove the battery to perform this sequence of steps.” Might easily serve the purpose of recovering the battery max. capacity (but not sure, I’m no expert)?

“What’s wrong with holding [the] power button?” Probably nothing, if that worked. This is not my first rodeo. None of the other steps worked (particularly the ones with the battery left in).

There’s a problem with the phone (and apparently the laptops) that goes beyond the users involved.

1 Like

Yes, I’m not accustomed to the [the] usage when needed to be there (not even with sudo), thanks for this justified correction! My posts are more about substance, less about grammatical issues that I bring with my writing here, sorry for that (although important to be learned well, wasn’t focused either).

Back to your issue (let my think loudly :sneezing_face:), there is hardware (Librem 5) and there is BPP-L503, both products under warranty, yet I’d start with the brand new software (by erasing your whole/current eMMC setup … as only professional maintainers of particular Linux distribution doesn’t need this procedure, I guess), start with the brand new installation of PureOS Byzantium (Phone version, to include execution of: ./scripts/librem5r4-flash-image --variant A or B) that brings within it brand new open source firmware: git clone (here is link to my earlier post) for your device.

Just command: sudo systemctl restart upower might be good starting (very first step) point (rather partial, please observe device’s battery percentage when executing it) to move on/forward from where you are locked now (presuming your Librem 5 is just “normal”, healthy device).

Please order another/replacement battery (if/perhaps already delivered one problematic). Even charging once or occasionally your battery outside of Librem 5 might help (beside other Forum tips) too, but not something to rely upon. Librem 5 isn’t polished product (yet) and won’t be (as personal usage device, up to every specific and/or “my own taste”), near to 100% of your or my liking (probably), but every individual that have interest into is able to get there (close to 100% of his/her personal satisfaction) even practically (if/when related to end-user controlled perspective). Translation: your post “request” is minimal/justified/expected indeed, IMO.

Besides, as I’m trying to make it short here: are you able to establish stable, data related, connection over Jumpdrive package (by using USB-A to USB-C cable, link to the Jumpdrive 0.8 image is here) with your Librem 5? This procedure involves some other kind of turning on, powering into your Linux phone, asking therefore (even way before of doing any actual kind of brand new installation).

P.S. This post doesn’t provide any kind of not-known solution, not even close to it, anyhow not without your progressive involvement (rather than extending your expectations toward Purism side, as I do think that they already produced, for sure :roll_eyes:, or at least worked hard toward even better solution), if so at all, yet it isn’t the one (this post), either, that explains on why you might be about to sell (potentially, within some other thread) this particular Linux phone of yours. I’d like to help (if/when enough time available), that’s all (please rethink your next move, how to upgrade this current state, as “no-other-possible-way” turning on procedure, still bothered with this particular problem/issue, since September last year), maybe your “factory” installed image caused/causing this related problem (who knows?).

Please test on/off (either right away or after few hours, actually both) with: sudo shutdown hF now. Also please execute the same command (after conecting device to its power supply) and charge your Librem 5 until red LED light off (if so?), disconnect, please, plugged-in power cable and (try to) turn it on to “note” if 100% there.