Librem 15V3 not recognizing my 960 EVO NVMe


#1

I have a Librem 15 v3 and I installed my samsung SSD 850 Pro 2.5" Sata III. I also installed a samsung 960 EVO NVMe M2 500GB. The problem I am running into is that my laptop is not recognizing my 960 EVO NVMe. I see that my laptop supports it, but am not sure what I need to do to make my laptop recognize it. Samsung has no information to answer my question. My other hard drive, 850 pro, is recognized. I checked boot options and it only shows my one hard drive not the NVMe. What do I need to do to have the laptop recognize the NVMe hard drive?

I have read the forum posts to try and figure out what the problem is, but have not found a solution that fixes the problem.
My OS and kernel version: PureOS & Linux 4.12.0-1-amd64(x86_64)
Coreboot version: 4.6-a86d1b-Purism-4


#2

FWIW my 1GB version of the same using latest PureOS works just fine on 15v3. Sorry I can’t be of more help, but it is a data point.


#3

bpnew, have you updated your system?


#4

What do you mean “does not recognize it” ? Is it not appearing at all in /dev/nvme* ? That wouldn’t make sense. We’ve tested that specific model of NVMe as well, as it’s one of the options offered, and you have the latest coreboot image (well, not exactly, but all nvme issues were fixed in the Purism-2 version)


#5

I have run both apt-get update & upgrade.


#6

I have run the command lsblk and it only shows my one drive, not bothlsblk


#7

I also ran the command sudo apt-get install purism-librem-coreboot-updater. Still no change


#8

Can you do an lspci, and after you apt-get install ‘coreboot-utils’ do a cbmem -c and paste the output in a paste sharing website (like ghostbin.com or pastebin.com)
Also, I would suggest you open the machine and make sure the NVMe is securely inserted into place and the screw is holding it, and if you have a way to test, make sure the drive itself isn’t defective.


#9

I did all the above commands and pasted the output into ghostbin.com at the following link.
https://ghostbin.com/paste/s5kak

I have removed and reinstalled the drive and screwed it in correctly. I have no way of testing the drive itself due to not being able to find a external case for a NVMe SSD.


#10

Thanks for the log, it’s helpful. What I can see in it is that coreboot does not detect that there is a PCI device on your M.2 slot, either the NVMe is damaged and doesn’t respond to anything, or the motherboard/connector itself is damaged and doesn’t connect the nvme correctly to the CPU… or it’s a software issue but since you’re the only one having this problem, and I’ve just re-tested NVMe support on the Librem 15 (with the latest coreboot image, and I tested it with the same 500GB Samsung 960 EVO NVMe), i don’t see how it could be.
The best thing you can try right now is to try the latest coreboot image, and update your machine just to see if it makes any difference. I just announced a build script to let people rebuild coreboot and you can read about it here : Building coreboot from source (official script)

If you have a way of testing another M.2 drive (whether NVMe or not, preferably both) and/or to test that NVMe drive on another machine, it might be helpful.
Good luck.


#11

Problem fixed. I ended up purchasing another 960 EVO NVMe and it worked. Thanks for all the help.


#12

Ok, thanks for letting us know. Sorry to hear about your defective drive but I’m glad to know that the problem isn’t coming from the laptop or from coreboot.
Enjoy your librem! :slight_smile: