Librem 15v3 won't boot


#1

Hi, I just received my new Librem 15v3. But it won’t boot. It goes straight to memory test. After testing for more than an hour, everything is fine with memory. I press escape to exit but it still doesn’t boot and goes back to the memory test. Can you please help.


#2

My librem v2 does the same. I’m currently getting round it by hitting the escape key on boot and changing to the correct boot disk.

I’m also trying to figure out how to edit the bios or coreboot to change the boot order


#3

Yes, this probably has something to do with boot order in coreboot. @ram: please try hitting ESC key upon Purism logo and select your boot disc.

@ram and @tregeagle, you can (most likely) solve this by installing newest coreboot version: Building coreboot from source (official script)

@kakaroto, any thoughts?


#4

@mladen @tregeagle Thanks for your comments.

I looked at the boot order. For my computer it is

  1. AHCI/2: 250 GB SSD HD
  2. ACHI/0: 1 TB SSD HD
  3. Payload [memtest]
  4. Payload [coreinfo]
    I selected 1 (250 GB SSD HD) since that’s where boot should be but even then it goes straight to memtest.

Can you help?


#5

Try option 2 and see how it goes. Since option 2 says “AHCI/0”, I believe the installer used this to install the system. I’m gonna speak to our dev about this to see how does installer choose which disk to install on.


#6

@mladen

I tried option 2 which says “AHCI/0”. It goes to the HD. I guess it cannot find the OS, so it gives bunch of errors, scans the drive for an ISO installer image. I guess it cannot find any, so it takes me to the installer menu (os installation menu?). I didn’t want to install anything on 1TB drive until the issue is resolved, so exited the system.

What should I do? Please help.


#7

This is perfectly normal, it’s a first-time setup, look here: https://tracker.pureos.net/w/installation_guide/oem_installation/

Edit: Make sure to read important and warning notes at the end of the article. :slight_smile:


#8

@mladen
OK. This worked. Thanks a lot.
So I presume OS is installed on 1TB HD and 250GB is spare one for data. Is that correct?
I could go to application and see what’s available. Is there a tutorial to get started?

Thanks again.


#9

Yes. Our OEM installation chosen the first disk it found, which is sata form-factor disk. This is with old coreboot version, I believe, newer version assign first position to m.2 form-factor disks. :slight_smile:

Sorry, I didn’t understand, tutorial on what?


#10

For simple things like setting up a printer, internet access etc. I can play around and figure out such things but tutorial is much faster. For example, I still don’t see my other HD yet. I am sure it is somewhere but I can’t find it. Do I have to mount it?

Thanks again.


#11

Another example is that whenever I start the laptop, it asks me for my encryption passphrase. Is it normal that I have to put in both the encryption passphrase and user password every time I log on? If yes, is there a way to change my encryption passphrase?

These may be simple/stupid questions but I have just started using Librem.

Thank you so much for your help.


#12

You are right. This is planned, but simply it is too much work to accomplish all at once. Have a look at our wiki for the existing information: https://tracker.pureos.net/w/

Yes. You can partition it using GNOME Disks (installed by default) or gparted (you’ll need to install it first) and then mount it by simply opening it (in file manager).

Yes. You don’t have to have your disk encrypted, but you’ll need to reinstall PureOS: https://tracker.pureos.net/w/installation_guide/live_system_installation/

It seems that GNOME disks support this (https://askubuntu.com/questions/95137/how-to-change-luks-passphrase) but please don’t try it until I can confirm this.


#13

Thank you. This is helpful.


#14

However, if you click on the menu in the upper right (represented by the volume and battery icons, and wireless if it is on) and click on your name and then Account Settings, then Unlock and enter your user password, you can switch Automatic Login to ON, which will mean only the disk encryption password has to be entered at startup!


#15

Hi Ram

I started a thread with information as to how I setup a Librem with various customisation & tweaks to the desktop to make my daily work more productive. You might find it helpful in your quest to understand your librem laptop.


#16

That works. Thanks:grinning:


#17

This is good. Thanks for sharing.:grinning:


#18

This worked. Thank you.:grinning:


#19

Just received my Librem 15v3 (11/7/17) and on boot up it hangs because first HD doesn’t have the OS installed on it. It was installed on the 2nd HD and now I have to select ESC/2 to properly boot. So ask your installer why they are installing to the 2nd choice???


#20

This shouldn’t be happening, the installer should be on the first drive by default, unless I’m mistaken. @zlatan-todoric can you confirm what’s going on with this ?
@dcorwith: I would suggest you either :

  • Reinstall the OS on the first HD
  • Run this script I wrote to change the boot order in SeaBIOS.