Librem 5: can no longer receive SMS messages or calls

I can no longer receive SMS messages. I could a few days ago. Now nothing comes in. I have tried many times. I tried uninstalling chatty and reinstalling. I also cannot answer calls. I receive the call but when I push the answer button it seems to immediately terminate the call (it goes back to the main screen). I have tried switching off and on the switch for the modem. I have rebooted the phone and also stopped and restarted it. I see nothing indicated about this when I use “sudo dmesg”. Is there another log I can look at? I can still make calls and I can send texts out.

Also, when I use commands listed at to try to for example send a message from the command line, it seems to create the message (gives me a path) but when I try to store or send the message it gives the same path mentioned in the send but says it is not found. ModemManager is running:

root 580 1 0 16:51 ? 00:00:00 /usr/sbin/ModemManager

Is it supposed to running with some options or something? I did try stopping and running with debug option at one point before these issues happened.

Note also that with updates applied to day I moved to the 5.11 kernel but I was having the problem before that update too.

I had this same problem when I was playing with sending SMS from the command line. It turned out that the problem had to do with the chatty process that was running at the same time, chatty appeared to think that it should take care of all messages, it was chatty that removed them. So, just kill chatty and the problem goes away. You might need to kill chatty a few times because there is some mechanism restarting chatty automatically, but at least for me it worked to kill chatty a couple of times, then the automatic thing gave up, and after that I could send SMS from the command line. You can check if chatty is running using for example this command: ps -A | grep chatty


Thanks, I should have thought of that. By killing chatty, I was able to send a message successfully to another phone. Still was not able to receive one. I tried again and I was able to receive a call. So the problem currently is receiving SMS texts.

The error also occurs with me. I apparently did not receive some SMS messages and I could not make any calls to them. The behavior is new.

I don’t know whether it helps at all but I am sending a quasi-daily datestamp text message from another phone to my Librem 5 - and I have experienced no loss of text messages (apart from when the tower went out for X days during the flood LOL). The reason I am doing this is that I don’t receive enough text messages in real life but I still want to monitor for possible regressions or breakages, such as is being discussed here.

The sending phone is an iPhone, on a different carrier - so should be very vanilla. The sending iPhone has been ‘trained’ that the receiving phone is no longer an iPhone (otherwise the damn stupid thing will try to send via iMessage i.e. via Apple, and there will be problems).

Receipt is essentially instantaneous, typically. The text message makes a net journey of 1 metre but via a very circuitous route.

This is awkward to keep track of. Lots of updates are coming through. Today’s test was after I applied the latest updates (which updates must have been released overnight). Text messages worked yesterday too.

I am using amber. Keeping it simple.


So now it is getting weird. Last night I noticed the phone sitting there with the blue light on. It was frozen, so I powered off and on. Then I heard some notification tones and some of the messages that had been sent to the phone the previous day appeared. That’s interesting I thought. So rebooted again and another message came in. I rebooted again and another. I did this a couple more times and finally got no more messages. So then I tried sending a message to it and my wife did. I didn’t get those messages, despite rebooting several times. This morning, again after rebooting multiple times, I have yet to receive those two messages.

Needless to say, I did not have these issues using the exact same SIM card on my Android phone.

There have been so many packages put on in the last few days I don’t know which if any might be the cause of this issue. I did look at dpkg.log but nothing jumped out at me.

An update, I did email support on this and they had be produce and send logs from ModemManager. Here is a quote from one of the developers:

One thing I see in the logs are “Transfer Route MT” messages. When I get one of those from my carrier I don’t see any more SMSes until that message gets ACKed.

According to Purism these occur with MMS and VoiceMails. They suggested that I put my SIM card into an Android phone to free up the messages. By the time I got that suggestion, I had already done that and all my delayed messages came into the Android phone. When I put my SIM in the Android phone I also got my APN settings updated so I wrote those down. The only one I could put in the Libream phone was the name and apn value which I added since they weren’t there already. With my SIM card back in the Librem 5 I could again get messages.

FYI, the ModemManager issue that discusses issues with ModemManager properly handling MMS messages is issue 257


Thanks for the info @francepat, I saw this same behavior.

I sent myself an MMS image message and for 4 days I received 0 SMS messages. Just today I received all the SMS messages queued up from my carrier.

From the sounds of it, the sooner we get MMS support the better. Otherwise my friends are certain to DoS me by sending an image. :slight_smile:

1 Like

I had a related issue very recently. This was the only discussion I could find on the topic, so I’ll post my experience and solution here for posterity. It’s looking like mms support is around the corner, though, so hopefully this won’t be needed soon.

A friend had shared with me a list from their text app (some samsung note taking app), and his phone sent it as an mms - at least that’s what it appeared to be initially. I didn’t receive it, so he sent it again. I suggested breaking it up, and those didn’t work either. After a simple text to test, I found out I stopped receiving texts entirely. Sending texts was not an issue, and flashing to byzantium did not fix the problem.
Found this discussion after looking it up, and I freed up most of the backed up texts after loading my sim into my backup android - except those two that had been sent initially. After working with purism support, they had me run sudo mmcli -m any --messaging-list-sms

[sudo] password for purism:
/org/freedesktop/ModemManager1/SMS/14 (receiving) /org/freedesktop/ModemManager1/SMS/13 (receiving) /org/freedesktop/ModemManager1/SMS/12 (received)
/org/freedesktop/ModemManager1/SMS/1 (received) /org/freedesktop/ModemManager1/SMS/0 (received)

After removing entries 14 and 13 with sudo mmcli -m any --messaging-delete-sms=[index], the problem was resolved. I can receive texts once again!


MMS support is coming. I’m pretty sure not released yet i.e. not even in byzantium.

I’ll add that last bit to the Tips and Tricks wiki.

1 Like