Librem 5 not detecting wifi networks

I’ve had issues recently with my Librem 5 (Redpine Wifi/BT card) not detecting certain networks. I recently reflashed the phone to troubleshoot an unrelated issue, and the wifi issue has persisted and now I’m not able to detect my home network. Things I’ve tried:

  • Made sure my time and date are set correctly
  • Reset my router
  • Toggled the wifi HKS a few times
  • Made sure my router was broadcasting on 2.4 GHz and 5 GHz
  • Changed the channel my 2.4 GHz network was using, three times
  • Set up a guest network with a different SSID

The third time I changed the channel I switched the setting back to “Automatic,” which is supposed to choose the least-congested channel and broadcast on that. My network briefly reappeared on the Librem 5, and the phone began to connect, but then the network disappeared again and hasn’t come back. No other device seems to have a problem connecting to the network, so this is something specific to the Librem 5. But since this problem was happening before the reflash with different networks, I don’t think it’s specific to the reflash.

Any other troubleshooting suggestions?

Tried updating the driver with the process described in Internet access is very bad. The driver update doesn’t seem to have worked (none of the messages from sudo dmesg | grep -i redpine report anything being at version but my phone has connected to my home network at some point since the upgrade. Not sure if this is still an issue, will update the thread if it reoccurs.

RYFRedpine just watch abgn network, so make sure ur router it working on that protocols. Driver it is not yet available but Firmware.
Also upgrade the Redpine firmware to last.

To make things as clean and simple as possible, I would

  • disable the 5 GHz band on the router
  • lock the router to channel 1
  • ensure that there are no remnant .nmconnection files in /etc/NetworkManager/system-connections (at least none of type wifi)

then do a scan from the command line for visible SSIDs e.g.
iw dev wlan0 scan | grep -E '^BSS|freq:|signal:|SSID'