Librem 5 received and inital reaction

You are talking about regular L5 I guess. L5 USA wasn’t yet offered 3 years ago, was it?

1 Like

With a global chip shortage resulting from a perfect storm of things in the silicon industry:

I feel lucky to receive any electronics that I order at this point of time :wink:
It must be 2x as hard to build a USA supply chained sourced anything these last 2 years.

Thanks. Surprisingly difficult to find…

Thanks @amarok. I’m waiting for approval for my registration. Just mentioning that in case you are in the community there. Either way, helpful info indeed.

1 Like

Also -my 2 cents, I think the Librem is snappier then the Pinephone but I am having some issues out of the box that I am dealing with that are out of my wheelhouse. Mainly the bluetooth. My wifi takes some time to connect but other than those two things(the bluetooth is really a buzzkill) yea its at the very least snappier. And of the kill switches are obviously easier to get to hehe.


great to know! I’d love to replace my daily driver with a fast/reliable linux phone. Thanks for the impressions!

1 Like

I don’t think you need registration to view the Wiki. Sure, if you want to contribute new content to it then you will need registration.

Are you trying on the 5 GHz band or the 2.4 GHz band? The signal will be stronger on the latter and so that may be preferable for an easier life (unless you have a really fast internet connection). Traveling Experiences

Bluetooth worked out of the box for me - although what types of device you can actually pair with is hit-and-miss at the moment i.e. some profiles not supported. Keyboard worked for me but I believe that car or headset are not currently supported.


Yes @irvinewade register to contribute of course as far as the wiki.

The Bluetooth though… well, I don’t have an option on the physical phone for which band. My home network has either 2.4 or 5G and I’ve tried every band and changing channels etc. So as far as my home network that is not the issue. The wifi works fine. The Bluetooth literally does not work. There is option to turn it on -it is grayed out. There are no default controllers while using bluetoothctl. This has to be a hardware issue in the Bluetooth module of the phone. That’s my best guess without having built the thing. Thanks. I’d prefer not to work on this issue for the next few weeks as I am getting frustrated with the price of this phone nadn it not having BASIC functionality out of the box… bluetooth is basic functionality.

I think there’s an outstanding fix that you can try:

edit the file /etc/modprobe.d/librem5-devkit.conf and change both instances of dev_oper_mode to 5, like in this change:

You can do it using the terminal using sudo vim /etc/modprobe.d/librem5-devkit.conf. If you don’t have vim, you can do sudo apt-get install vim, or if you don’t like the editor, go for:

sudo apt-get install nano
sudo nano /etc/modprobe.d/librem5-devkit.conf

Then you need to save the file with your modifications and reboot.

Sorry for the trouble.


This looks promising… however not to start the age old battle but I think I’ll use Emacs thank you very much. No I’m not a dick stallman fan for the record. hehe. moohooohaaahaaahaaa! AHHAAAHHAA! (sinister laugh for those that can’t pick up context…) Thanks @dcz I will return bearing good news I hope.

1 Like

Yea no dice. @dcz The Bluetooth option under settings is unresponsive no matter what. After making those changes to the module conf and rebooting still the same. And I’ve rebooted again and reloaded modules and restarted services. I ran rfkill and had this:

0: mic-hks: microphone
        Soft blocked: no
        Hard blocked: no
1: wlan-hks: Wireless LAN
        Soft blocked: no
        Hard blocked: no
2: wwan-hks: Wireless WAN
        Soft blocked: yes
        Hard blocked: no
3: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

So I unblocked everything just for good measure but still no Bluetooth device. Same with the
When I toggle the kill switch for the wifi and the Bluetooth I notice that the WiFi option goes away from the settings menu however the Bluetooth option is still there unresponsive.

The services are all running except its obviously not finding the That’s dead.

● - Bluetooth
   Loaded: loaded (/lib/systemd/system/; static; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:systemd.special(7)

Either way, thanks for the help. I have no idea… not one… not even a hint of a clue on how this is is dead. But any other ideas I would sure love to try let me know.

Do you have anything in dmesg?

sudo dmesg | grep Bluetooth
[    5.396914] Bluetooth: Core ver 2.22
[    5.397034] Bluetooth: HCI device and connection manager initialized
[    5.397051] Bluetooth: HCI socket layer initialized
[    5.397059] Bluetooth: L2CAP socket layer initialized
[    5.397074] Bluetooth: SCO socket layer initialized
[    8.116647] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    8.116686] Bluetooth: BNEP socket layer initialized

Nothing that looks out of the ordinary I suppose? But here’s any fail or error from

purism@pureos:~$ sudo dmesg | grep -i fail
[    3.870937] systemd[1]: Failed to bump fs.file-max, ignoring: Invalid argument
[    4.943230] imx-sdma 302c0000.sdma: Direct firmware load for imx/sdma/sdma-imx7d.bin failed with error -2
[    4.946034] imx-sdma 30bd0000.sdma: Direct firmware load for imx/sdma/sdma-imx7d.bin failed with error -2
[    5.166630] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[    5.166642] cfg80211: failed to load regulatory.db
[    5.516886] RSI-SDIO WLAN mmc1:fffd:1: Direct firmware load for RS9116_NLINK_WLAN_BT_IMAGE.rps failed with error -2
[    5.516900] redpine_91x: rsi_load_firmware: Failed to open file RS9116_NLINK_WLAN_BT_IMAGE.rps
[   16.865772] redpine_91x: redpine_set_clr_tx_intention,357: Wait event failed
[   16.865809] redpine_91x: rsi_tx_scheduler_thread,623:  Failed to get tx_access
[  759.737388] g_multi gadget: userspace failed to provide iSerialNumber


purism@pureos:~$ sudo dmesg | grep -i error
[    4.288271] EXT4-fs (mmcblk0p2): re-mounted. Opts: errors=remount-ro. Quota mode: none.
[    4.943230] imx-sdma 302c0000.sdma: Direct firmware load for imx/sdma/sdma-imx7d.bin failed with error -2
[    4.946034] imx-sdma 30bd0000.sdma: Direct firmware load for imx/sdma/sdma-imx7d.bin failed with error -2
[    5.166630] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[    5.336867] wm8962 2-001a: ASoC: error at soc_component_read_no_lock on wm8962.2-001a: -16
[    5.347978] wm8962 2-001a: ASoC: error at soc_component_read_no_lock on wm8962.2-001a: -16
[    5.516886] RSI-SDIO WLAN mmc1:fffd:1: Direct firmware load for RS9116_NLINK_WLAN_BT_IMAGE.rps failed with error -2
[  792.932888] edt_ft5x06 2-0038: Unable to fetch data, error: -6


Did you try checking if the antennas are properly seated on the WiFi module?

I did I here’s a pic. I did mention in my correspondance with support via email that they felt really really loose/flimsy. I mean -I barely touched it and it popped off. So I carefully popped it back on and uhh. yea. Here’s a pic:

I’ll check again now though.


purism@pureos:~$ sudo mmcli -m any
  General  |         dbus path: /org/freedesktop/ModemManager1/Modem/0
           |         device id: 2af0ed38a023bf40b592aa26f1b17c60446066c8
  Hardware |      manufacturer: QUALCOMM INCORPORATED
           |             model: 0
           | firmware revision: MPSS.JO.2.0.2.c1.1-00032-9607_GENNS_PACK-1  1  [Feb 25 2019 01:00:00]
           |    carrier config: default
           |      h/w revision: 10000
           |         supported: gsm-umts, lte
           |           current: gsm-umts, lte
           |      equipment id: 863974040054340
  System   |            device: /sys/devices/platform/soc@0/38200000.usb/
           |           drivers: qmi_wwan, option1
           |            plugin: broadmobi
           |      primary port: cdc-wdm0
           |             ports: cdc-wdm0 (qmi), ttyUSB0 (qcdm), ttyUSB1 (at), ttyUSB2 (at),
           |                    ttyUSB3 (at), wwan0 (net)
  Status   |             state: failed
           |     failed reason: sim-missing
           |       power state: on
           |    signal quality: 0% (cached)
  Modes    |         supported: allowed: 2g; preferred: none
           |                    allowed: 3g; preferred: none
           |                    allowed: 4g; preferred: none
           |                    allowed: 2g, 3g; preferred: 3g
           |                    allowed: 2g, 3g; preferred: 2g
           |                    allowed: 2g, 4g; preferred: 4g
           |                    allowed: 2g, 4g; preferred: 2g
           |                    allowed: 3g, 4g; preferred: 4g
           |                    allowed: 3g, 4g; preferred: 3g
           |                    allowed: 2g, 3g, 4g; preferred: 4g
           |                    allowed: 2g, 3g, 4g; preferred: 3g
           |                    allowed: 2g, 3g, 4g; preferred: 2g
           |           current: allowed: any; preferred: none
  Bands    |         supported: pcs, g850, utran-4, utran-5, utran-2, eutran-2, eutran-3,
           |                    eutran-4, eutran-5, eutran-12, eutran-13, eutran-17, eutran-25,
           |                    eutran-26, eutran-41, eutran-66
  IP       |         supported: ipv4, ipv6, ipv4v6

I don’t have a sim it today. Last one I had in there somehow died? Maybe scratched I don’t know. Waiting on new sim.

It definitely does not feel like its seating in there tightly.

That’s the best pic I can get. But yea like I mentioned. I was told to open it up and check them before. I told them that it felt loose and flimsy(the cable connection) And now it looks like the cable on the right is much much more lose than the one on the left. *The cable should almost “snap” into place. And from day one when I took this out of the box a few days ago I was tasked to check the cables and right then I new that cable on the right was going to be an issue.

*lastly, I am confident tearing apart my own computers and pi’s and other IOTs but I do NOT feel good about poking around this device. If it was $100 phone I’ve have this thing apart and replace those cables yesterday. But I do not want to be responsible for this. This should not be fixed by me. I think that is reasonable correct? Software wise? Yes lets do it -tell me what to edit/compile/run etc. But I am not touching this hardware. And to be clear and honest I obviously don’t quite grock the setup on this device yet. So I just want to be clear that I am not a hardware engineer lol. Just trying to make it through the day is all.


My BT worked for several months, but at one point (after an update, I believe), it started misbehaving. I can enable it, and the emblem appears in the notifications area, but it doesn’t seem to scan for devices. Also, sometimes the emblem is not in sync with the Settings app (toggles itself off, but the emblem stays in the notifications for a while). It worked fine for most functionality in my first few months of ownership.

I don’t really have a need for BT on the L5 at present, so I haven’t worked on getting to the cause. I just expect that it will get straightened out with an update at some point.


Thanks. I expect these things to happen as far as the software but I had a feeling this was a hardware issue from day one. * I could be wrong. I’d like to be wrong but these antenna cables are buggin me out man! I’m prob wrong about it being hardware. I don’t know why I keep going there.

I guess that your BlueTooth it fine on hardware it is just that is not working at the moment. My bluetooth it doesn’t work for me either, but worked before. I believe that the BT it going be fixed on some point, Purism developers is busy fixing other bugs. I hope Byzantium will be launched soon and that you enjoy this wonderful L5 machine more.