Librem 5 web browser flaw?

No one expects the L5 to be a Windows-phone :wink:

3 Likes

:rofl: So true!

1 Like

Maybe a little out of topic, but would you mind to explain, step by step, how did you do that? Starting from enabling ssh. Thanks

Ciao @fiacco! Check out this comment [MyL5] Received my Librem 5 (Evergreen) and a few comments further down in the thread. The linked tutorial should help you accomplish it in a couple of minutes. If you need more help, post here. Buon Natale!

1 Like

On your Librem 5, open the terminal and enter the following command:

sudo apt install openssh-server

Then you need to find out your the IP address of your Librem on your local network, one way is to run the ifconfig command.

Then, once you know the IP address, do this on the laptop:

ssh purism@x.x.x.x

where instead of x.x.x.x you put the IP address. It should ask for your password, which is the same as the pin code, it was 123456 when you got the phone.

1 Like

After you get it all set up, your L5 settings will then show this toggle control:

Great! Thank you very much!
Unfortunately I have to solve a problem with my WiFi connection. It doesn’t last enough to let me in (another active post)

That’s frustrating.

scp Secure Copy is another useful command; move a file from one machine to another on your network.

You can always connect to your phone over USB serial console or ssh via Ethernet over USB: https://developer.puri.sm/Librem5/Development_Environment/Phone/Connecting_via_USB.html

Once you have convenient access, check the output of sudo dmesg after you get disconnected.

1 Like

For some reason this is not working for me, and the connecting via USB doesn’t work either.
I have the ssh service running, checked with service --status-all. I checked that the port is 22, with sudo netstat -tulnp | grep 22. (I also checked in the Settings -> Sharing -> Remove Login was On)

Then I’m finding the ip with ifconfig, and use it from my host computer (macbook 16)

jo@99-66248 ~ % ssh -vvv -l pureos 192.168.1.184
OpenSSH_8.1p1, LibreSSL 2.7.3
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 47: Applying options for *
debug2: resolve_canonicalize: hostname 192.168.1.184 is address
debug2: ssh_connect_direct
debug1: Connecting to 192.168.1.184 [192.168.1.184] port 22.
debug1: connect to address 192.168.1.184 port 22: Operation timed out
ssh: connect to host 192.168.1.184 port 22: Operation timed out

Running sudo journalctl -f -k on Librem 5 doesn’t reveal anything when running the ssh command. But there is an old error displayed; “pureos kernel: edt_ft5x06 2-0038; Unable to fetch data, error: -6”. It seems to popup in the logs now and then.

Could be network issue. You have any firewall installed?
Try to ssh from from L5 to itself, first using looback address 127.0.0.1, if that works ssh from L5 again into itself using private IP …1.184
Some routers may introduce client network isolation “feature”. Can devices on your network talk to each other directly?

For something simpler, you could try ping also. In my case ping works both ways, I can ping my Librem 5 from my laptop and I can ping the laptop from the Librem 5. But probably ping will also fail for you, as @AN0N is saying it may be that different devices on your network are not allowed to reach each other.

Another test you could do, if you have another laptop at hand, is to see if the two laptops can reach each other using ping and/or ssh. If that does not work, then you know you have an issue with your network that is not related to the Librem 5, but a more general thing.

You could also try with another WiFi network, like at a friend’s house or something, to see if it works there. I don’t know how common it is for devices to be allowed to talk directly like this on a wireless network, I just know that it happens to work with my WiFi at home. (And I guess it seems to work for several other people who have managed to login to their Librem 5 using ssh.)

Looks like the browser problem is fixed now. I got an update of the libwebkit2gtk package when installing the latest updates today, and now the browser is working again.

2 Likes

Connecting to loopback didn’t work. I haven’t changed the password so it is still 123456 in the lockscreen, but that isn’t the correct one for ssh.
ssh pureos@127.0.0.1

I checked around in the /etc/passwd and shadow files and realized that the user is not pureos, but purism. So running ssh purism@127.0.0.1, with password 123456 works.

1 Like

Now I have the solution :slight_smile: It was two problems. The router I used had some isolation, so I tested another one (my iPhone), which worked. Then the problem was with the user which was purism instead of pureos. Thanks everyone for the help!

1 Like

I’m getting this browser corruption issue currently on what appears to a fully updated Librem 5.

The firefox-esr and iceweasel packages don’t seem to exist. Chromium installs and works fine.

Could be this issue:

If so, then you can fix it by running this command:

sudo apt install libwebkit2gtk-4.0-37/amber-phone

That didn’t work - was already on that version of libwebkit2gtk - but an OS update randomly fixed it when I looked away for a day or two.

1 Like