Librem 5 won't boot

Helping out is not questionable, but if someone cannot rely on currently used BPP-L503 battery I would not recommend re-flashing Librem 5 procedure to be used. I understand your kind recommendation but not sure if by not getting enough power from the used battery, perhaps faulty one, this procedure might reach or get to the successful finish (copy over brand new image, expand /home partition), reach finish line in short.

I have no time now but you are using (without adjusting very useful content of it) wrong link (devkit related). In short, Not expanded /home might be the cause of not booting as well. Therefore @arcenis.rojas please follow this procedure and after extracting purism-librem5.tar.xz file execute on your host computer:
sudo ./

After your Librem 5 partitions auto mounted we can move forward from there.


Yes, I’ve checked this .git link and confirming that it doesn’t serve the purpose (the one that you need) there:

This funtion only work if you updated the bootloader to 2022 version, with newer bootloader you can boot the phone without battery. You just need reinstall pureos intoL5 and everything will work fine,.

While I really appreciate your suggestions, they all seem to require that the phone boots up. Besides, I just got this phone back from Purism because they had to look into fixing my SD card reader and I had only received the phone 2 weeks prior to that initially. Has the boot loader been updated in the last 2 months?

1 Like

I’ll try this again after the red light turns off, but now I’m concerned that it won’t. I’ve had the phone on the charger for more than 11 hours now and the red light has been on the whole time. Is that something I should be concerned about?

Jumpdrive method does not require your Librem 5 to boot up:

As well, having open feedback from your side like this or that would be useful, or I tried this method (already written here and not somewhere else) should help us to help you further.

Just disconnect USB-PD cable (no need to wait further after 11 hours), take Librem 5 battery out and put it back into slot. Is it Librem 5 booting now (do not hold power button or any other, just slide battery back)?

I dont think so that your L5 has upgraded the bootloader already, but any way your gnu device just need reinstall PureOS, to reinstall PureOS not need that the phone turn ON, just need put the device on serial mode.
The problems it is that may be you not much expert on gnu operating systems, and that is causing several issues. You just need a Computer with GNU Operating System turned ON to reinstall PureOS into L5, i am confident that you Librem 5 it on complete perfect condition. Just reinstall PureOS and later upgrade das-uboot.

I’m definitely not an expert on GNU systems, but I’m comfortable on the CLI and have been using a Purism Librem 15 as my primary laptop for over a year. The way Purism is marketing this phone made it seem that someone at my skill level should be able to use a Librem 5 without much problem, but it seems that it also requires a strong background in engineering. I thought the engineering problems were solved. I’m now wondering if it’s too late to get a refund.

Your L15 has PureOS already?

It does, but I don’t know that it would help. I’ve tried connecting my L5 to my L15, but I don’t see the connection anywhere even after taking steps to install uuu.


You should get this output:

When you see above output present, as it should be there, please prepare your next steps based on posts #48 and #74 (as mainly related ones), those you can find within this very same thread.

1 Like

That blog post points to the original location of the librem5-flash-image tool. It has been moved


The phone doesn’t need to boot to put it into serial download mode. The way to guarantee the phone gets to serial download mode.

  1. unplug phone and remove battery
  2. hold vol+ and re-insert battery
  3. while still holding vol+ plug in the USB cable connected to the laptop

run dmesg on the laptop and it should show that an NXP device has been connected.

You can always connect for help with the reflashing procedure


I am having the exact same issue and I own 2 batteries for Librem 5. It won’t boot, so I guess I am going to have to flash an image tog et it to work again? Its a pain in the @$$

1 Like

Not necessarily. It depends on what exactly the problem is.

You might want to put the phone in serial download mode but boot Jumpdrive so that you can view the contents of the phone’s partitions from a host computer.

When I attempt to turn on my Librem 5 I get a green indicator light, but the phone doesn’t actually boot, i.e., nothing shows up on the screen.

This happened to me after OS updates were performed via the PureOS store “Updates” tab. Subsequently I was not able to boot. Instead just got a blank screen and a green light as OP described. My solution, very unfortunately, was to reinstall PureOS.

1 Like

I am trying to reinstall PureOS and the balena etcher is not recognizing any connected device when I plug my phone into the PC. Then I successfully flashed PureOS to a SD card, phone just won’t boot even after the holding up, plug in, then insert battery. Nothing can be easy! lol Any suggestions anyone?

As far as I am aware, at the current time the Librem 5 is not directly capable of booting from uSD card. So that is a non-starter.

What is the operating system on the host computer? (Etcher appears to be available on all of Windows, macOS and Linux.)

When plugging a Librem 5 into a USB port on a Linux computer the behaviour observed on the Linux computer will be different depending on whether the Librem 5 is in serial download mode or not. I suspect that if the Librem 5 is not in serial download mode and is borked then it may be that nothing will show up on the Linux computer e.g. with lsusb

When in serial download mode, lsusb gives the clear indication:

Bus 999 Device 999: ID 1fc9:012b NXP Semiconductors i.MX 8M Dual/8M QuadLite/8M Quad Serial Downloader

(where the 999 values will be different for you).

If you aren’t seeing Serial Downloader then something is not right, regardless of what should happen after that (e.g. reflash using the reflash script or boot Jumpdrive).

1 Like

running Ubuntu (Zorrin), ran dmesg, got some red lines in a bunch of lines saying device not accepting address 9, error -71

also a few other red lines, just not sure what commands will help in this situation or if there is anything I can do to fix this device.