Librem v15, boot issues


#1

Hi there,

I think I’ve run into a problem with my new Librem 15rev3. I’m trying to get into the bios to take a look at a possible issue with boot devices and I can’t seem to get in there. If i’ve got this right (and it is very possible that I don’t) I’m been trying to choose the ‘Payload Coreboot’ option from the boot menu and when I do I get a black screen with green bars running horizontally across the screen. Pic attached.

Hopefully I posted to the right place.

Thanks in advance


#2

There is no BIOS, we have coreboot now.

When you pres ESC upon Purism logo (during boot) you will get a boot menu, from which you can chose which device to boot.

I am not sure what “payload coreboot” is. Do you have your devices listed?


#3

Sorry still using old terminology:

Here is the list of devices I get when I hit escape at the purism logo:

  1. AHCI/0: Samsung SSD 850 EVO 500GB ATA-9 Hard-Disk
  2. USB MSC Drive SanDisk Cruzer
  3. USB MSC Drive Samsung Flash Drive 1100
  4. Payload [memtest]
  5. Payload [coreinfo]

When I hit 5 for 'Payload [coreinfo], that is when I get the green and black screen above. When I try and boot off of 3 the boot hangs at ‘Booting from Hard Disk…’ which is a custom EFI boot drive I built. When I hit 2 it boots normally off a gentoo minimal livecd environment. I was trying to diagnose the issues I was having when hitting option 3 but couldn’t get into any sort of BIOS/UEFI/pre-os environment. I thought that might be what ‘Payload [coreinfo]’ was but unless that is suppose to display green horizontal lines I’m assuming whatever it is isn’t working properly.


#4

Okay well I solved one of my issues by reading that link, I didn’t realize that coreboot doesn’t do UEFI. I would still like to know what ‘Payload [coreinfo]’ is suppose to do if possible.

Thanks


#5

I was curious about this also - coreinfo doesn’t seem to do much other than display green lines.

Is that its intended function?

(edit): It appears that CoreInfo should look like this?

A quick search shows that this may be a known issue.


#6

Thanks for link. I guess I didn’t search enough for the issue.


#7

Yeah, for some reason coreinfo stopped working and I don’t know why, I’m meant to fix it (soon, I promise!).
To answer the question, coreinfo is indeed an “info” payload that is meant to show you information on your hardware (like the PCI devices, the coreboot version, the CPU specs, etc…) I added it because some people wanted to see the PC information like on the older BIOSes, but then by the time we released, it had stopped working and I haven’t had time to look into it yet.
As for your question, yes, SeaBIOS doesn’t support UEFI, that’s why your drive doesn’t boot. You could always have Coreboot+Tianocore (instead of Coreboot+SeaBIOS), which would give you UEFI, but then it won’t boot legacy drives anymore (so your HDD and 2nd usb wouldn’t boot)… either way, we don’t have a coreboot+tianocore build available for people to replace their BIOS with it.


#8

@deadsuperhero @thartman: re-posting here from the other thread :
The coreinfo issue has been fixed, you’ll need to update coreboot. You can either wait until we finalize an easy way to push updates to people (either through a script/deb package with a pre-built image stripped of non-distributable components, or through a similar script distributed through fwupd), or you can simply build coreboot yourself on your machine. I’ve released a script to do that and you can read about it here : Building coreboot from source (official script)


#9

I’m very happy to report that the script worked! Coreinfo now shows up and functions as advertised. Incidentally, building and flashing via the script was super straightforward and took very little input from me to get working.

Amazing job!


#10

hip hip hooray!
Glad you had no issues to report with the script :smiley: