Lock-up only at home

Looking only at differences between work and home, as @ChriChri says, power supply and condition is certainly one, and a good first thing to look at. Another one could be “WiFi” (not that that should be able to cause a complete lock up).

1 Like

I would agree that network connectivity, power supply (including fluctuations thereof, whether fridge-related or not) and connected peripherals are likely culprits. Or, less likely, it could be caused by a difference in temperature, humidity, vibration or electromagnetic interference.

Another thing to consider is whether you are running different application software at home compared to at work, which might cause a lock-up.

1 Like

Not buying any of the possible problems so far for the following reasons. Please let me know if I’m wrong. Since this is a laptop, I have always been under the impression that laptops, due to the structure of the power supply and a battery have basically a built-in power flux suppression (whatever it’s called).

The WiFi — I have no idea why that might be an issue. I’m thinking tonight I’ll use the disable wifi, etc. switch and see if it’s off in the morning.

Finally, the past couple of times it’s locked-up pretty much only Firefox was running. Maybe Nautilus and Tillix as well. But nothing else.

Oh! One other thing. It was locked up when I came home today so I thought, GREAT I’ll look at the logs. But again they only start from the boot despite adding PERSISTENT as I noted early in the conf file. So what am I doing wrong? I really would like to get to the logs and see what happened just before it locked up.

I should perhaps note that as an IT admin for almost 20 years now, I’ve had MANY laptops and never seen this issue before. Also this is one of 4 laptops in our house. Only this one experiences this issue. But mine is the only PureOS laptop. I have an older laptop with SolusOS on it and it runs 24/7 365 and never locks up.

With such an unprecedented issue, I’m sure that logs will be the most important contribution. I had an issue my Purism failing to charge mysteriously off of one of the legs in my house. It did so randomly where it had successfully charged for months. I had overlooked the circuit as an issue until out of desperation, I moved it and charge was restored.

To my knowledge - nothing had changed. No electrical work was done in my house and I had modified nothing in the laptop. I still have no idea why it stopped working. And it was random as hell. And has never happened again. I hope your odd issue is less odd as mine. I look forward to seeing what your logs show.

This reads like the first third of a TED Talk. :ok_hand:

1 Like

Could point in the direction of transfer to the disk… Anyway.

What I wanted to say about the logs is that I ran lately into a problem for which I didn’t have any logs neither.

Along the way of resolving it I were at the point of wanting debug output on serial (which is quiet common e.g. for single board computers). The question would be whether there is a serial line in the Librems which could be used (preferable without opening the case).

Serial line for debugging, @joao.azevedo?

Connect USB device that gives you a serial port?

Getting the logs is obviously a sensible next step. Sorry, I’m too inexperienced to speculate on what, if anything, you might be doing wrong there.

I think the suggestions about possible causes should be taken as starting points for investigations, tests and experiments, rather than complete theories.

It’s probably not. It’s not unheard of for certain combinations of WiFi hardware brands to have subtle incompatibilities that trigger driver bugs, but that probably wouldn’t just happen suddenly, unless you changed something. More likely it would be something that’s different in the local network higher up the network stack (OSI layer 3 or above), so not specific to WiFi.

Don’t underestimate the ability of power supply issues to confound expectations. An ideal laptop should not crash because of a power supply problem, but my impression is that electronics is so messily physical that it’s hard to be certain about that kind of thing. There are too many variables.

An unseen loose connection behind an outlet, perhaps?

It’s possible but since it was limited to my laptop, I hadn’t really bothered to look. Everything continues to work fine including phone charging. It’s an older home for where I live, built in the 50s, so your hypothesis is viable.

By lock once a day, you mean that after the lock screen was enabled, you were not able to unlock it?

No the screen is totally black and nothing happens no matter what I’ve tried. The computer is on though. One thing I haven’t tried is to ssh into it while it’s locked to see if I can get in. I probably won’t try again until next weekend and the logs are not being wiped after each boot, so I should eventually be able to see what’s the problem.

Before that, just ping it.

Well, unfortunately I don’t see anything in the logs that points me to the problem. The same “issues” prior to it hanging existed days before. So that doesn’t seem to be the problem.
BTW the system was down since the last log entry was for morning. I rebooted it this evening since it wasn’t responding after trying to ssh in (forgot about trying to ping, but it wouldn’t have mattered).
Just a strange fluke… would love to figure it out, but probably beyond my pay grade! :stuck_out_tongue_winking_eye:

Maybe beyond ours as well too. Did anything show up in the logs? Would you be willing to share? The game is afoot.

Would if I could. I can’t figure out how to save journalctl entries since the last boot. I can issue the command journalctl -b -1 for them, but the output is like it’s using less. I need it to dump the entire log since the last boot. The goal being to then cat it to a file and then post it on pastebin. If there’s some other way, let me know, but so far the man and internet haven’t been helpful.

Maybe it is not necessary, yet: If you suspect the problem is location related and it is that easy to reproduce I’d try leaving the notebook switched on without a power connection. With no load it should run a good while (if you disable automatic sleep).

If you can’t reproduce the behaviour without a power connection you know where to look at. If you connect ethernet you should try the same with the ethernet connection.

If the lockup still happens when the notebook is not connected to lan or power, the only thing I could think about related to the location would be some sort of radio pulses.

Anyway, if you’d want to debug it from the logfiles you could get back to @kieran idea connecting a usb serial and using it to write out logging.

1 Like

Just run;


without any arguments or flags.

I was certain that journalctl only started from the last boot. I was wrong. Having parsed the logs for the time from one boot to it’s termination I’m stuck with how to post so much text! I was going to use pastebin, but can’t figure it out. So I’ve opted in the end to just put it on Google Drive and share it. Here’s the link:https://drive.google.com/file/d/1_WtO-lT0v7DNtMWY121ho95eEVqjQX89/view?usp=sharing

OK, so just to confirm … the dates and times in that log file are local times for where you are and you booted at 7:41pm on Saturday evening, left it running, and at 3:57pm on Sunday afternoon (or thereabouts) it locked up?

If that’s right, let’s get back to assessing what state the computer is in when it locks up.

  • can you ping it?
  • can you SSH in?

However you might not normally be able to SSH in anyway. So you would need to confirm that you can SSH in when it is running normally and if not then you need to get SSH going first.

Actually it turns out due to my firewall settings, that I would not have been able to ssh into it anyhow. But don’t you think that by virtue of the fact that the system had completely stopped logging anything that it had hung and would respond to a ping either? I will change my firewall settings next weekend and try again, as well as ping.
The times you noted are exact. I should note that the Reboot entry would have to be for several hours later when I had to forcibly reboot the computer.