Mobile Data Usage

Yes I had to install vnstat first. I did find a strange graph one day that vnstati reported 8 gig of usage for the wwan0 port, but my only thought is that it somehow was reading the wlan0 port. I did set up a cron job to run every hour to print a new summary chart so that seems to work well.


This happened to me all the time on Pinephone Mobian. I took to disabling mobile data when I was home to prevent premature and unintended depletion.

When I got my L5, it was not even a thing – no worries… until today.

Last night , I notice it was running was and not charging, eventually with a blinking red light. Shutdown/restart would fix it for a short while. Then I got a notice that I had blown thru 80% of my mobile data. Running speedtest-cli show that packets were going thru the mobile interface even though I had a good wifi connection. All the while, the red light was blinking. Then I turned off HKS-top and two things happened – the cell modem depowered and the damned red light stopped blinking!

When I turned on HKS-top, the cell modem powered up and connected but the red light stayed on. Running speedtest-cli showed data going through wifi, as expected. DOUBLE SUCCESS.

Tentative Conclusion: If HKS-top is not fully-seated in the ON position, it can dork your mobile data as well as the charging controller.

1 Like

I wonder if the switch is causing some of the wierdness with the calls sometimes, maybe when I slide it out of a pocket or something it moves just enough to disrupt the switch and send the modem into spasms?

Maybe so, but I may have the opposite problem. I have a TPU case on the L5, which makjes me have to hook a fingernail to get purchase. I can see how I could easily fail to seat the switch completely.

Either way, the switch (such a great thing) may bring unintended consequences.

1 Like

I think the HKS is still probably an issue for mobile data, but not the charger. Pure coincidence flipping the switch clearing the red light… git it again and the switch had no effect.

What I do have now is an overheating problem. Everything is running about 6C hotter than normal. When in heavy use with the case and back cover on, it is tripping the charger. Not sure why. The only thing different is whatever updates it took the last night and I’ve been bashing Firefox to get it setup. :thinking:

Well I know when I’m on wifi if I load up Tradingview with lots of data hussling through the phone the charger has a hard time keeping up because of the constant writing to the screen etc that charts have. If I navigate away from a busy screen like that the battery icon goes green with the lightning bolt again, so I think in your case it is probably related, probably more so because maybe mobile data generates more heat in your modem card. I don’t have the sparklan card yet but it’s on it’s way I’ll find out after the swap if I don’t have to close down my charts to keep it charging.

My SparkLAN arrived yesterday, I haven’t swapped it yet.

Still seem to be having high data consumption and I think I have isolated it to Brave. I think what happens is it does not smoothly transition from mobile data to wifi for example and it continues to use the wwan0 card when the wlan0 card is available. So what happens is if you happen to have your browser open while on mobile then when you get home and start surfing on your wifi you’re in this fools paradise thinking that you’re not using any mobile data.

In light of that I’m thinking the issue has to be with Brave’s hoggish network data consumption and something isn’t right with their mobile version that I’m using. I think it is technically beta so buyer beware I suppose.

Hello All,

I also experienced my data allotment being maximized and when I went on the provider’s site, it showed the time periods that the high consumption occurred and they corresponded with the same times I was at home with a good wi-fi connection.

Since I had trouble getting my phone to connect to the provider, I made a bit of a mess with the Mobile Access Point list. The phone and messages apps were unreliable in this state - sometime working, other times not, but I could still use use mobile data even though I exceeded my monthly limit.

I re-flashed the phone and it cleaned up the Access points and I no longer have mobile data access when my monthly allotment is exceeded, but phone and messaging work well.

I opened the Advanced Network Connections app and there are settings to prioritize the connection - higher numbers have a greater priority, and to set the Metered Connection type - Yes, No or Automatic. I ser the mobile connections to YES and the wireless connections to No.

I’m not sure what will happen, but I’ll buy a couple more Gigs from the phone company and see if this helped.

1 Like

One can easy check with any browser and a connect to if you are using the IP of your Wifi AP or your data mobile provider:

purism@pureos:~$ lynx -dump

   IP Address (v4 of v6)
   Port 37726
   Browser (User Agent) Lynx/2.9.0dev.6 libwww-FM/2.14 SSL-MM/1.4.1
   Request Time (Unixtime) 1679423522
   Request Time (UTC) 21.03.2023 18:32:02

I use nethogs to see which interface is engaged.

Despite my best efforts this month tethering to my work phone to use it’s mobile data, I still went over my 5 Gig data plan today for no apparent reason. This aspect of the phone really needs some attention in my view as I’m basically going to have to leave mobile data off and do without MMS messages etc…I have also given any Wi-Fi networks higher priority in the advanced networking applet. I just don’t get what is using up all my data, it makes no sense whatsoever.

My workaround for the issue is to use the software switch to turn off the modem for about 30 seconds and then when I kick the modem back on usually the WiFi will persist.

Is that after uninstalling brave?

Didnt uninstall it but haven’t been using it.

Might be worth a shot, maybe some process is hanging out in the background.

You may end up using mobile data even though WiFi is connected when you get an IPv6 address from the mobile network but not from WiFi. Perhaps check whether that’s the case for you.

yeah…but watching it with top and nethogs I don’t see anything suggesting that Brave is running anything in the background because I disabled that function in Brave. This month I rarely if at all opened Brave as I was thinking that it might be the culprit but I’m not so sure anymore. I have been pretty diligent about using my work phone hotspot so essentially my L5 is only connected to wifi and just mms messages would be using data and I’m not sending tons of photos or anything.

I can watch my data usage on my account in near realtime and it ticks up by small amounts almost constantly. There must be something that is not respecting the network settings and just using the wwan0 card without my knowledge. I have nextcloud for my contacts and calendar but I can see it on nethogs using the wlan0 card not the wwan0 card as I know it phones home quite often. It’s quite frustrating…maybe I have to do a wireshark on my phone…lol.

Ok, so I’m midway through day 3 of April and I have already used 252 MB of my data plan and I have my work phone automatically switch on hotspot mode when I’m away from any wifi and my L5 has my Samsung S22 hotspot as a remembered connection and it fairly reliably connects to it when I leave the office and home and I am paranoid about checking it.

Extrapolating my data usage which should be practically nothing. It’s telling me that I will use almost 4 gig’s by the end of the month and I’m not even using mobile data on purpose on my L5 for anything. I have also been shutting down any browsers before I go mobile.

Is it possible there is an application or something in the OS that isn’t respecting the metered network? The apps I have running are the standard ones chatty of course, signal and sometimes I have telegram running but according to nethogs they are all running on the wlan0 card not the wwan0 card. Only other thing I have is Nextcloud, 2 accounts, one for my home network and one for a cloud based server I run for a bunch of other things but I am only using it for calendar and contact sync, so no huge data usage there.

Can someone tell me what other possible things could be running and using mobile data even though I am connected to essentially a wifi network 24x7? This is really concerning and makes me not to want to ever use the L5 on it’s own, I’ll burn through my data like nobodies business.

I know I keep revisiting this but this is going to be a real barrier and eye opener for new people who are used to having more control over data usage on their devices. I think it needs to be a pretty high priority to get more granular control of the data usage.

FYI @dos I asked one of our wireless engineers and we do not issue IPv6 addresses at this time.

Correction I just used whatip and it shows an IPv6 address. How can I disable it @dos?

Here’s one way:
Or, you can go to Settings > Wifi > (cog wheel next to your wifi network(s)) > IPv6 > IPv6 Method > Disable.
You can also use the Advanced Network Settings app.