Move Installation to ThinkPad L15 Gen1

Edit: I didn’t write my real intention down - so I’m updating this post to mirror it to make more understandable why I want to install PureOS on the notebook.

I need to move an installation of PureOS from an old, broken notebook onto the new Thinkpad L15.

My idea has been to install PureOS first and then just overwrite the root partition excluding the boot configuration to get back the old system.

The thing I know now is that I’d need to install firmware-amd-graphics from Debian before moving the installation, but I still do not see the way to get me started and make sure that PureOS works on the Notebook.

original post:

I found out I didn’t know anything about modern notebooks anymore. Since I use a Librem14 and have some old school notebooks I never had problems installing PureOS.

The L15 just shows me after the grub text menu a message

error: no suitable video mode found.
Booting in blind mode

Can someone point me into the right direction to learn

  • how to configure such a modern bios
  • how to install PureOS

I think instead of ThinkPad you mean Librem L15. I wonder if there is a problem with the integrated graphics on your L15?

:wink: No, really, I meant this one.

Ahh ok, was just a little confusing because L15 is used to talk about a Librem 15, especially around these parts.

But in the case of your Thinkpad, it sounds like there are no drivers in the kernel you are loading for the integrated graphics on your Thinkpad.

You can try hitting e when grub shows up and put “-nomodeset” without quotes at the end of the line that starts with “linux”. Then you’ll have to find your driver.

The nomodeset will not persist between boots, BTW.

1 Like

Following approach sounds quite persistent, easy and reliable (with related adjustment): [closed] Error : no suitable video mode found. Might help there if @ChriChri agrees to go ahead with here linked guide and latest PureOS amd64.iso from 2022-10-02.

I tried both, but it didn’t work.

The PureOS USB I made with octobers version boots, but same problem.

supergrubdisk doesn’t find anything bootable on the PureOS usb, but detects the drive itself.

Update: I updated my original post to reflect what I really want to do (move installation from an older, broken notebook) to maybe find some other, easier way to achieve this.

Solved the problem:

  • connected new to lan using a known to work usb-c ethernet adapter
  • old: installed the amd firmware from the debian repos
  • new: used a knoppix rescue disk to partition the drive and format a boot partition
  • used rsync to copy the boot partition from old to new over network
  • copied the root partition (encrypted) using dd and netcat from old to new


  • mounted the luks root partition
  • edited fstab for the new harddrive
  • installed the grub efi package, uninstalled grub-pc packages
  • installed grub from chroot
  • reboot
  • had to install a kernel newer than 5.14 and misc firmware from debian to get the wifi working
  • installed realtek firmware from debian to get the expected speed on the built-in ethernet