No more WiFi after today OS update

I do not think there is a problem with the warranty, but better to wait @dos answer. If it never worked then maybe the correct is to write to support of purism. But how did you get to kernel 5.11 if you did not have a working wifi? I guess that it came like that (with 5.11 pre-installed). Right? You did not upgrade, correct?

Connected via usb to my linux laptop, flashed the phone from there, got the 5.11 kernel. My gsm-SIM internet works sometimes, can also run an apt update && apt upgrade from there, thought after flashing it claims all packets are up to date.

Didn’t check which one was coming installed with in the first place, but followed some other comment in the forum to downgrade to 5.9, which didn’t change anything in regards of BT+WIFI. Now reflashed back to 5.11. Will wait for @dos answer on opening the back and reseating the wifi module :slight_smile:

I’m sure @dos or someone in support will be able to identify the problem for you and find a fix. Hang in there!

1 Like

This thread is dealing with a number of different wifi issues.

  1. No Wifi on boot with the 5.11 kernel please add your info to this issue
  2. poor wifi performance, please go here and add information
  3. Scrambled wifi firmware please go here

@amarok how does it go? Does it work as expected or not?

Yes, my WiFi is totally normal now, even through multiple reboots and the latest kernel upgrade. No degradation in performance, either.

However, the bluetooth is weird right now. The GUI settings toggle turns it on and off as expected, but it never seems to scan for available devices. I hardly ever use bluetooth for anything, so I’m just waiting until a future update makes it act right.

1 Like

Thanks. Because I read the issue 264 above and I still hesitate to upgrade. Because it seems they have not yet found the source of the problem. But probably I should do it if I need to connect to wifi on routers that I do not control (at work) because of the 20/40 MHz issue at 2.4GHz.

I’m now on 5.11.0-1-librem5 #1 SMP PREEMPT Wed Mar 17 02:15:51 PDT 2021 aarch64 GNU/Linux and no WiFi issues.

Edit: I just switched over to 5GHz to test and it seems fine, too…connected right away, downloaded some updates, rebooted, still connected. My router’s ranges for 2.4 and 5GHz are both set to automatic.

Bluetooth attempted to use with what kind of device?

I have the same kernel version and my Bluetooth keyboard is still working. Obviously that was paired months ago using a previous software version (and Bluetooth audio output didn’t work previously for me).

Not trying to use any device. Just that when I toggle the GUI button to “on,” the panel area below, that would normally start to list devices within range, doesn’t do anything. (And I know there are devices within range.)

1 Like

As a data point, not even toggling anything, just going into Settings / Bluetooth lists two devices (both Disconnected, as it happens) and it appears to be scanning for more devices. However both of those have previously been paired and I don’t think I have any other new Bluetooth gadgets lying around to try.

I, too, tested with some previously paired devices, but the lower panel in the GUI still doesn’t appear to be scanning. No biggie for now. I haven’t really been using bluetooth with the L5. I’m sure it’ll come back to life at some point.

And actually, just did another check and my Android doesn’t see my L5, although the tray icon for BT is present (on the L5), and the GUI button is on.

1 Like

Nice you got a way for wifi @amarok ! I was in touch with support about my non-wifi+bt situation and seems there has been a couple of faulty cards already, they directly asked to send me a different one to test. Still asked about whether the reseating of the wifi+bt module voids the warranty and they told me to go ahead. Was fairly simple, even reconnecting the antennas. Unfortunately still doesn’t work after reseating, seems I’ll have to wait until they send the replacement.

I didn’t have the right screwdriver yesterday, so I went for one and I also got a USB-c dock with ethernet, which for now allows me to at least connect the phone to internet at home.


I hope they find out what’s wrong with it. Mine was apparently the firmware issue, but you apparently already have the right firmware.

1 Like

@dos something strange to report. I do not know if it makes sense. As long as I was using Ethernet through laptop it could not see existing updates. Today I decided to update and I thought it would be better to have all kill switches on so the updates see all the available hardware. When I turned on the wifi in 3-4 seconds there was a message that important updates are available !!

So I followed the GUI update and restart procedure. The system came up with no wifi adapter found. Terrifying. I flipped the switch off and on and the wifi came back. Rebooted several times, the wifi comes up normally. Shutdown. Start again. wifi does NOT come up. Flipping the switch corrects so far the problem. Here are some details:

uname -r reports

sudo dmesg | grep redpine, starting from shutdown with wifi not found and found after flipping the switch off and on reports:

purism@pureos:~$ sudo dmesg | grep redpine
[ 5.860653] redpine_91x: rsi_probe: ***** 9116 Module *****
[ 5.861913] redpine_91x: redpine_hal_device_init: oper_mode = 13, coex_mode 2
[ 5.869010] redpine_91x: ***** Loaded Firmware *****
[ 9.165975] redpine_91x: ================================================
[ 9.166003] redpine_91x: ================ RSI Version Info ==============
[ 9.166006] redpine_91x: ================================================
[ 9.166010] redpine_91x: FW Version :
[ 9.166018] redpine_91x: RSI FW Version : 0000.
[ 9.166024] redpine_91x: Driver Version : RS9116.NB0.NL.GNU.LNX.OSD.2.04
[ 9.166029] redpine_91x: Operating mode : 13 [Wi-Fi STA + BT DUAL]
[ 9.166033] redpine_91x: Firmware file : (null)
[ 9.166037] redpine_91x: ================================================
[ 79.836706] redpine_91x: redpine_set_clr_tx_intention,357: Wait event failed
[ 79.836732] redpine_91x: rsi_disconnect,1371: Failed to get tx_access
[ 79.836881] redpine_91x: rsi_reset_chip: Failed to Write SDIO WAKEUP REG
[ 79.900169] redpine_91x: rsi_reset_card: CMD0 failed : -123
[ 79.900180] redpine_91x: rsi_reset_card: CMD5 failed : -123
[ 79.900188] redpine_91x: rsi_reset_card: CMD5 failed : -123
[ 79.900194] redpine_91x: rsi_reset_card: card in not ready : 0 -123
[ 85.984180] redpine_91x: redpine_set_clr_tx_intention,357: Wait event failed
[ 85.984215] redpine_91x: rsi_tx_scheduler_thread,623: Failed to get tx_acces
[ 92.124712] redpine_91x: redpine_set_clr_tx_intention,357: Wait event failed
[ 92.124745] redpine_91x: rsi_coex_scheduler_thread,112: Failed to get tx_acs
[ 92.125304] redpine_91x: ##### RSI SDIO device disconnected #####
[ 112.921896] redpine_91x: rsi_probe: ***** 9116 Module *****
[ 112.922348] redpine_91x: redpine_hal_device_init: oper_mode = 13, coex_mode 2
[ 112.926983] redpine_91x: ***** Loaded Firmware *****
[ 115.996813] redpine_91x: ================================================
[ 115.996830] redpine_91x: ================ RSI Version Info ==============
[ 115.996834] redpine_91x: ================================================
[ 115.996837] redpine_91x: FW Version :
[ 115.996843] redpine_91x: RSI FW Version : 0000.
[ 115.996849] redpine_91x: Driver Version : RS9116.NB0.NL.GNU.LNX.OSD.2.04
[ 115.996852] redpine_91x: Operating mode : 13 [Wi-Fi STA + BT DUAL]
[ 115.996857] redpine_91x: Firmware file : (null)
[ 115.996861] redpine_91x: ================================================
[ 116.000316] redpine_91x: rsi_send_bt_reg_params: Sending BT reg frame
[ 116.000710] redpine_91x: HCI module init done…
[ 116.002268] redpine_91x: RSI HCI DEVICE “hci0” open
[ 116.098848] redpine_91x: <==== Interface UP ====>
[ 116.098910] redpine_91x: rsi_mac80211_bss_info_changed: Change of ERP INFO: 0
[ 116.098918] redpine_91x: rsi_mac80211_bss_info_changed: Sending vap updates…
[ 116.101143] redpine_91x: <==== Interface DOWN ====>
[ 116.105976] redpine_91x: <==== Interface UP ====>
[ 116.106027] redpine_91x: rsi_mac80211_bss_info_changed: Change of ERP INFO: 0
[ 116.106037] redpine_91x: rsi_mac80211_bss_info_changed: Sending vap updates…
[ 116.107822] redpine_91x: RSI hci0' flush [ 116.107856] redpine_91x: RSI HCI DEVICE "hci0" closed [ 116.107861] redpine_91x: rsi_hci_close: device hci0’ not running
[ 119.951740] redpine_91x: <==== Interface DOWN ====>
[ 119.956401] redpine_91x: <==== Interface UP ====>
[ 119.956463] redpine_91x: rsi_mac80211_bss_info_changed: Change of ERP INFO: 0
[ 119.956473] redpine_91x: rsi_mac80211_bss_info_changed: Sending vap updates…

So does this dmesg help? It seems something is wrong.

Wait… Booted again after shutdown. wifi came up normally.

So the exists some instability? Anyway I hope the above helps.

1 Like

After update WiFi does not come up but after Power Down and Power Up it comes up normally.

Yes, that’s It’s not a deterministic problem (although it seems to happen much more often for some than for others).

Ah wait, looking closer at that dmesg is actually suggest some kind of communication failure between the SoC and the card. Have you tried reseating the card in its M.2 slot?

No I did not try to re-seat it because I had no failures with kernel 5.9.
If you think that would be useful (to re-seat it) then I will try it. If this happens again in the next days then I will try to re-seat it for sure.

By the way the above link now gives 500 Error (“Something went wrong on our end”).