Offline for a few years... update needed!

Good move! Therefore reminding here to:

Temporary workaround: Librem 5 will not update with wifi

The following is approximately the documentation for the features supported by the forum software in the subcategory of Markdown.

Look at the last two features (those involving the backquote character).

The forum software is complicated though because it allows you to mix and match features from Markdown, features from BBCode and features from HTML (and with generally incomplete documentation).

More comprehensive discussion:

1 Like

Yes. If you open your external drive in the file browser and then press Ctrl+L (location) it should show you the exact path in the address bar.

Oh, and of course I assumed all your important data is in your home directory. That’s usually the case.

1 Like

Thanks, @Quarnero!

I’ve read through that post a few times, but am not quite sure if I understand how it pertains to my situation. Isn’t the issue in my case an expired certificate and not a missing gpg or apt-key error?

I checked /etc/apt/trusted.gpg.d and a file named pureos-archive-keyring.gpg is definitely in there.
When I ran apt list pureos-archive-keyring, it said
Listing... Done pureos-archive-keyring/now 2016.09 all [installed,local]

So, is 2016.09 the date of its creation? I.e., is it old and in need of replacement by following your instructions to sudo apt reinstall pureos-archive-keyring, etc?

Or should I instead try the temporarily “switch https to http” workaround that @irvinewade and @Dwaff both suggested?

Or simply jump to a clean install of Byzantium as per the advising of @Dwaff, @Gavaudan and @Caliga?

1 Like

Yes, you need replacement for sure (sorry for not making this clear, the one from 2016 is just some obsolete key, not useful any more):

Grateful for the clarification, @Quarnero! I really appreciate you taking the time and effort to walk me through this. :smiley:

I just tried this…
sudo dpkg --install pureos-archive-keyring_2021.11.0_all.deb

but got this…
dpkg: error: cannot access archive 'pureos-archive-keyring_2021.11.0_all.deb': No such file or directory

Was I supposed to run all of the additional commands? I.e., downloading the related package, and:
cd Downloads
sudo dpkg --install pureos-archive-keyring_2021.11.0_all.deb
sudo apt update
sudo apt upgrade


1 Like

Yes. dpkg works on a deb file you already have.

1 Like

Thanks! But now please read (study) carefully:

Ok, I downloaded pureos-archive-keyring_2021.11.0_all.deb.
Then, proceeded with cd Downloads and…
~/Downloads$ sudo dpkg --install pureos-archive-keyring_2021.11.0_all.deb (Reading database ... 265712 files and directories currently installed.) Preparing to unpack pureos-archive-keyring_2021.11.0_all.deb ... Unpacking pureos-archive-keyring (2021.11.0) over (2021.11.0) ... Setting up pureos-archive-keyring (2021.11.0) ...

Is that correct? It seems stuck at “Setting up…” ???

And, when I run sudo apt-key list, the new key isn’t listed and the old one is still there. I also tried installing it via Software & Updates, but got this popup…

Should I try removing the old key via Software & Updates?

1 Like

Might help:
sudo apt purge pureos-archive-keyring

And afterwards:

Ok, done… but not certain that it worked!

~$ sudo apt purge pureos-archive-keyring
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
pureos-archive-keyring* pureos-desktop* pureos-gnome* pureos-minimal* pureos-standard*
0 upgraded, 0 newly installed, 5 to remove and 0 not upgraded.
After this operation, 57.3 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 265711 files and directories currently installed.)
Removing pureos-desktop (0.9.4) ...
Removing pureos-gnome (0.9.4) ...
Removing pureos-standard (0.9.4) ...
Removing pureos-minimal (0.9.4) ...
Removing pureos-archive-keyring (2021.11.0) ...

Odd. Doesn’t that last line indicate that the new key had been installed correctly after all?
However, when I check `apt-key list’ as well as Software & Updates again, they both still list keys that have been removed or purged and not the freshly installed one. :confused:

Ploughing ahead in case the new key did actually replace the old one, I tried sudo apt update, but got the same errors as before. I.e., Certificate verification failed.... does not have a Release file.... Updating from such a repository can't be done securely, and is therefore disabled by default.

Should I just try the temporarily “switch https to http” workaround in Post#16 now?

1 Like

I’d like to know what is output of: apt list pureos-archive-keyring?

And please install removed packages back:
sudo apt install pureos-desktop pureos-gnome pureos-standard pureos-minimal

I’m not sure if you are using https, you should use https.

Yes, please. Take the PureOS GNOME image from yesterday.

EDIT: @rootapoottoot, I also see that you are having a lot of packages installed over there (probably including local ones) Please follow this post and put packages.list file aside (including all other backups as @Caliga kindly recommended here) right away, and certainly before you reformat your current drive (if not replacing it with the brand new one), as described here: New Post: App Showcase: Backups. Also, please do not expect that all (especially obsolete) packages will get back and expect that you’ll need to remove “few” packages, by editing this file within gedit, saving it as new one, and retrying to restore what possible, in order to restore packages that are still available within byzantium repo.

1 Like

Thanks for the tip!

I just tried to backup my home directory and got an avalanche of these:
Operation not permitted
cp: cannot create hard link
Operation not permitted
cp: cannot create symbolic link
Invalid argument
cp: cannot create regular file

So, I’m assuming it failed… quite a few times. :frowning:

~$ apt list pureos-archive-keyring
Listing... Done
pureos-archive-keyring/now 2021.11.0 all [installed,local]

~$ sudo apt install pureos-desktop pureos-gnome pureos-standard pureos-minimal
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package pureos-desktop
E: Unable to locate package pureos-gnome
E: Unable to locate package pureos-standard
E: Unable to locate package pureos-minimal

Yes, as far as I know, I am using https.

Is it sudo apt update working there now? sudo apt update needs to go through without any errors.

This post should help some further: Been awhile - looking for help updating distro.

Alas, no, I’m still getting the same errors as before… Certificate verification failed… does not have a Release file… Updating from such a repository can’t be done securely, and is
therefore disabled by default.

That’s why I thought maybe switching temporarily to http (as per Dwaff and irvinewade’s advice) might work.

Or should I change my sources.list file from amber to byzantium now?

I still think that the brand new install of PureOS Byzantium is the way to go with (no doubt for several reasons). You are trying to bridge two generations (versions) of PureOS through some simple way and at the same time using it on top of quite unsafe distro (it is not safe any more, old Linux Kernel, etc.).

1 Like

sudo apt full-upgrade