Pcie ssd install failed

Ive bought a pcie ssd to speed up my pc, i can only install to it under UEFI, attempting to install under BIOS-CSM returns an installation error, so atm all i can install is Win 10 which i hate. Are there any plans to allow PureOS to be installed on an UEFI system?

Should be able to get it to work… Either grub2 EFI, or directly booting the linux kernel (which can act as an bootable EFI program). PureOS may be lacking some firmware for UEFI on your hardware, but you can grab the upstream linux-firmware package and probably get it working.

1 Like

I tried making a bootable thumb drive with Rufus but using the iso left me with the only option to boot to a bios or csm-uefi. Windows 10/8 allow me to create a full on uefi boot able thumb drive. I tried using etcher but that didn’t work either.

“Capable of creating exact bit-level copies of USB”, even though I never used this utility. You might try this anyway, please follow the instructions (all of them) before you proceed. Probably not necessary to mention, but when you get your USB flash drive ready you need to change to CSM before you boot this PureOS thumb drive and continue with install “things” on mentioned PCIe SSD. I hope you’ll let others know if this utility (with your steps/method) worked (as I didn’t have time to test it) for you.

1 Like

For getting into Linux UEFI, I recommend super grub disk. You can get the ISO here:


DD that onto the head of a USB stick (which will destroy any data on the stick). You can then add a linux ISO as a .iso file to the SGD second partition, and loop-boot it. Or you can access an existing install or whatever you need for system rescuing.

Once you are booted into UEFI linux, you can install grub properly, and you’re off to the races. Note that if you want UEFI linux, you probably need to be using a GPT partition table, and the boot partition needs to be fat16 or fat32 formatted. You can use a hybrid MBR/GPT table, but those are a bit unreliable. Very recent grub versions look like they can handle loading a kernel from a GPT partition in bios mode, or an MBR partition in EFI mode, but there grub itself must still be installed on a fat32 GPT partition for EFI and at the head of a block device for MBR.


yes you need to have a SEPARATE /efi partition on the internal/external HDD/SSD that you have connected to your motherboard for a gnu/linux distro compatible with UEFI enabled hardware. Debian 10.2 Buster(stable) worked for me last time i tried in november this year ! (internal m2 nvme pcie 4x ssd) will report back after i try with external bootable …

1 Like

I’ve just released (as I’m not having such UEFI-only thing) that I made my reply out of subject, on “full on uefi boot able thumb drive” with some kind of turbo engine. Why this new thread anyway … it has already been discussed here:

But if pureos will run in an Intel chipset that has MINIX embedded isn’t running pureos defeating the object. Ergo if we should only run pureos on specific hardware why are we allowed to run it on anything else? Its a real shame pureos won’t allow installation onto nvme drives.

maybe it’s just SOME nvme drives … ShangSungs seem to work fine …

There are multiple considerations here.

As far as I can tell … PureOS does allow installation onto NVMe drives and works.

I wasn’t exactly clear what hardware you are using. What PC?

I believe that there are limitations as far as UEFI goes. PureOS intends to work with BIOS, not UEFI - and the reason has apparently been given (UEFI requires blobs and PureOS intentionally avoids blobs). Are you motivated enough to work around that? It is for you to decide how much effort you want to expend in order to compromise your privacy.

The question is the wrong way round … why should it stop you from attempting to do whatever you want? Linux tries to let you do anything you want and sometimes it will work and sometimes it will not work.

Which chipset are you referring to?

If you are referring to the Intel ME (aka the Homunculus CPU), Librem laptops running PureOS disable as much of that as is possible.

We don’t live in an ideal world.

My PC is:
Asrock Fatal1ty Z77 Professional with nvme support. (Can boot into windows 10 via Windows Boot manager).
Intel i7 3770k
16gb ddr3
480gb corsair force510 nvme ssd (gen 3).

It almost installs PureOS but near the end it gives me an error message. My mobo wasn’t able to boot to nvme originally but after asking them how to do it the sent me a new bios which allowed win10 to create a Windows Boot Manager folder the ability to create a bootable folder in the bios. Prior to this windows would not install. So I assume because pureos doesn’t create a folder in the uefi is the reason it can’t complete the install. I would love to be able to get a work around to achieve it.

That is possible. BIOS or UEFI can only boot from types of disk device that it is coded to support. To boot from the ‘latest’ types of disk device requires the ‘latest’ BIOS or UEFI. This of course is completely independent of the operating system.

The Linux kernel has had NVMe support for some years - but that is not much good for the root file system if the BIOS or UEFI can’t boot from NVMe.

Who can say? But PureOS does not claim or intend to work with UEFI.

One thing that may be interesting to you is: Support UEFI in PureOS

from which

The only thing I can say at the moment that we will have this done for the next release of PureOS. I know this is kind of vague, but at the moment I can’t make a more definitive statement about it, sorry.

(dated Jan 3 this year)

so I guess UEFI support is coming.

1 Like

and if the manufacturer doesn’t add that in the latest BIOS/UEFI update and it isn’t being worked on at-the-moment then tough shit … next

True but in this case the manufacturer has issued an update that seemingly adds support for booting from NVMe.

I don’t recall whether you said that this particular UEFI has a “legacy BIOS boot” option. For those distros of Linux that don’t support UEFI (some do, some don’t) that can be an option that is worth trying.

Then of course there is the question as to whether that option supports booting from NVMe.

1 Like

Yeah it has the CSM option with OpROM feature and also full UEFI if I disable the CSM.

Have Purism been able to get this working yet? I can’t wait for it to work.

If your motherboard with updated BIOS and Phison PS5012-E12 controller are not making any problems than perhaps you might need to be a bit aggressive, do yourself some homework/workaround with your NVMe drive, if you want to resolve this on/with Linux (without blaming or expecting from PureOS maintainers to solve this), but as first please understand your standing point if you will, as already kindly described here:

Therefore, as you didn’t want to avoid proprietary or closed H/W, in your case probably key sentence is: “SSDs with overprovisioning space typically have used 7% of the total SSD storage capacity.” It is, for example, proofed that 960GB SSDs from manufacturer you are using occupy around 24GB with Pseudo-SLC-Cache. You might try to remove this space that Phison controller uses and look if able to boot PureOS from such/upgraded to 512GB NVMe drive (after new format). I’m not providing guaranty that this advice will help on Linux, instead it should be your homework (probably by using dd command within CLI, after backup). Again, my main point here is that you need to be active and not others. If you need any other, here related, help or direction just ask.

I haven’t read through the above post just yet as I’m shattered.
My new nvme drive arrived this morning. I downloaded pureos 9 (turns out my previous version on dvd was 3.0). I managed to get it to install all the way to it saying it was done. When I restart it won’t boot. I had a similar thing with windows but the bios added a new option for booting ‘windows boot manager’ after I updated the bios. Doesn’t seem to work for Linux. With pureos 3.0 it failed to complete the install so I feel hopeful it can be done. Should a put the boot loader on the windows drive where the windows boot manager is? And if I do that would a windows update wipe it out in the future?