Phone stays in windowed mode

I’ve connected the librem 5 with my TV and now after undocking it seems that it does not find back to phone (staged) mode again.

Even after a reboot it will open all apps as windows, the on screen keyboard is not available, and the symbol bottom right in the header shows “undocked” and is inactive (e.g. does not allow mode changes).

Does anyone know if it is possible to change the mode via command line ?

Or alternatively by editing a file ?

On ubuntu touch there is a command to switch between “windowed” and “staged” for example, but I don’t know it for phosh.

The used software is byzantium.

Thank you in advance!

What I already tried is connecting to the monitor / TV again: This works and instead of just plugging the USB C cable I’ve changed the setting to “single monitor” from the system settings. But the phone still stayed in this mode. Even while connected to the TV, the symbol in the header always shows “undocked” and remains not enabled (grayed out)

ok I think by looking at https://source.puri.sm/Librem5/phosh/-/merge_requests/631/diffs#4266c98a25ddaa3037594b0bdd3a1174a25790cc I found the commands:

#window size
gsettings set sm.puri.phoc auto-maximize true
#keyboard
gsettings set org.gnome.desktop.a11y.applications screen-keyboard-enabled true

I think some crash that occured while connected to the external screen caused the values to be not reset correctly.

You can also simply dock the phone again and undock it, which will reset these values.

Indeed, this happens when the phone shuts down while docked and is undocked before turning it back on. https://gitlab.gnome.org/World/Phosh/phosh/-/merge_requests/945 should fix it.