Post Re-Flash Blues Restoring apps

Having flashed sort of successfully, I thought it best to start a new topic as follow up on post flashing L5.

Things that don’t work right:

  1. Firefox gave me grief as it wouldn’t load, but was in background.
  • Clicked “Restart” and it went to the black screen with “Librem 5” in centre of screen - and stayed there. No Restart.
    Pushed the Start button in until it shut down.

I rebooted

  1. The tools to logon to modem after boot (I want it that way) has disappeared and I can’t find it in System, or Mobile. Use to be at very w/ top-right

  2. Shutdown goes directly to the micro-screen - text is way too small. But I recognized the screen with a white line across the middle which on closer inspection with a good magnifying glass is the font! The bottom right has the min-logo - it’s the hard way of entering the password.

  3. Opened “Contacts”:

  • Set up a contact.
  • Opened Chats & Sent plain text - was received.
  • Sent text with 100k. image.
  • Don’t know if it was sent, or waiting but it has not been received.
  • Sent another text to same contact - received.
  • Checked SMS/MMS(c?) in Chats - oddly enough, it was the same as it was before flashing - - - the phone!
  • Rebooted. Nothing changed.
  • Opened Chats again, and only one text message is there, just one of 3 I sent. 2 texts, one text w/ pic.
    Only text stored in Chats is the my text w/ pic (no idea if pic is with it) This was one w/ pic I sent to receiver after getting first 1st text received confirmation.
  • Cannot send pic with texts.
  1. ← S/B 5!
    PureOS Store only loads the 6 boxes. Click on any, i.e. Create brings up a list of boxes the first being “Editor’s Choice” each box with 3 dots (…) and after about 2-minutes, boxes disappear, Editor’s Choice disappears. leaving the page title “Create” at the top.
    It’s been doing that before flashing.

  2. <— S/B 6!
    I’d love to get the fonts size back to readable and ditch the magnifying glass.


1 Like

Using Settings and then Displays, what do you have for Resolution and what do you have for Scale?

That happens for me too. So this is a) not a problem with your phone and b) not anything that you have done. I expect that it is just a bug. I just don’t use PureOS Store. (I install from the command line.) I think Purism is aware that PureOS needs work.


PS You don’t make it clear whether you are operating in docked mode or not. I would recommend that you avoid docking until things are working satisfactorily undocked.


720 x 1440
Scale 200%

I’ts crystal clear that "PureOS needs work. The “app” bank of 'wares needs it too.

To be clear, when I say PureOS Store I mean the site, or wanna-be site, that has software to click and install. Not the 2 or 3 sites promoting these devices. And they want to cell phones?!

If I found a PureOS cheat sheet with all the commands, like PHP, CSS have etc., and had the time, and interest in going back to the early days of DOS (NOT Denial Of Services - well, sometimes ):smirk:

There should be a place where we can register to be advised by email when the store (represented by the shopping bag icon) is open and tested from outside the peer network.

Yeah. I dock sometimes, sometimes I use magnifying glasses hen un-docked.

To anyone thinking I’m old and can’t handle a digital devcies, be it known that I picked up a Galaxy S23 and have no problems navigating, tapping out a text etcetera. Same on Galaxy A8. Fortunately, I had to hand it back to my friend Juz say’n s’all.

The device when clicking Camera has fonts, 3rd row down from the top bar (time etcetera), I think they are settings. The line across when camera is switched off, if memory is good today, is a warning that the switch might be off.

I’d take a screenshot of it, but the site that is supposed to support this with wares has no support to keep the site up. If they can’t do that, they should at least provide a list of programs complete with description of the ‘‘app’’ and the command line to install it.
They could quickly get all that right off their database - - MySql perhaps? :rofl:

And here I thought I was almost there. Twilight Zoned.

1 Like

sudo apt install gnome-screenshot


Repositories are currently expired for all distributions.

Thanks. This reply (after I read it through) isn’t meant to elicit help, triage, or bandages. It just shows what it’s like with Murphy hanging out instead of Yhprum and his laws.

Today, the L5 takes 20 seconds to load anything. Things like Network Connections now with no WiFi connection, installing Warp which I used a lot pre-re^flashing now has:

The following packages have unmet dependencies.
Unable to install (filename)

and after more than 10 minutes, loads the dysfunctional “PureOS Store”. I gather the entire stores dependencies are the “unmet” dependencies.

After many minutes, poof!, the store opened with the departments and @ top, the slideshow showed Metadata Cleaner (MC) and other categories. (I only clicked on store icon once).
So I clicked MC - nothing - not for about 15 minutes, and in very tiny print is the paragraph that explains what the cleaner does. 15 minutes!!!
There are 4 black circles with a white dash (-) through each one. What a piece of work that site is.

For the H of it, I clicked “Install” and now it’s “Pending installation”
Then the screen changes and at top bar says “Loading…” and in mid-screen, kewl spiral froze, and then top left said “Autoupdate paused”. Then update note vanished.

Now at top error says
Unable to install “Metadata Cleaner”:

No such ref 'aapp/fr.romainvigier.MetadataCleaner/aarch64/stable' in remote flathub

Same similar message when trying to install Warp.

Now it says “Failed to install file: not supported.”
No store.
No use.
No files supported
No more installs (not /w a road map).
No way to log in to network any more.

Yeah, reflashing fixed it alright.
I blame today’s crazy events on that solar eclipse that was supposed to bring doom and gloom according to :crazy_face:'s and :face_with_spiral_eyes:'s on Youtube.
Maybe we’ll get lucky next time.

There use to be a means of login into the WiFi, but was fixed I guess and is no longer available post flash. I’m sure there’s a command line for it but…

:face_with_symbols_over_mouth: eclipse!


1 Like

Duh - I just tested it on my tower. It works. But not for the L5. Not before or after flashing.

If I want to get Warp - a file transfer program, and using tower (with PureOS updated) I found and downloaded Warp.
I’m have a lot of problems installing it. I tried

sudo apt install warp

and variety of the same line to no avail.
I gather I need to be in root someplace - correct?

and if I may bug you a little more, is there a PureOS cheat sheet i.e. command line usage. I spent considerable time looking but clearly, not in the right place.


1 Like

Use this command:

flatpak install flathub app.drey.Warp

Usually a command has a --help or man argument you can pass to provide helpful context or a manual.

apt --help
1 Like

But bear in mind that you might have to install the flatpak command itself and potentially configure a flat repo.

1 Like

@Sharon already did that.

1 Like

It said it was getting Flatpak stuff and reached 100% then I waited. 10 minutes later it still showed 100%.
Remembering just how slow this is, waited another 5 and was about to look for a sewer for this thing when the original PureOS store site finally showed up. Of course, still nothing shows under any category - least not after a 15 minute wait for “Work”.

If the phone is so smart as the ad states, why isn’t there a search for apps at the store. Never mind.

1 Like

Explain what “It” is, preferably using GNOME Screenshot:

sudo apt install gnome-screenshot

There is a magnification glass icon at the top left of the PureOS Store:

Tapping it reveals a text field directly below it:

Typing a query within it searches through all configured repositories:

1 Like

The “it” is in reference to the instructions you gave.
I followed the instructions and during installation and watching the L5 screen, I could see the words.

As for the other concern, with reference to Irvine suggesting, "

and your reply to Irvine that:

If my counts are correct, 9 flashings of the L5 have been done. Somewhere, I "already did that ", in between flashings. But it didn’t work. “it” being the flatpak setup.

1 Like

If you successfully installed any flatpaks (e.g. Warp), then you have a successful flathub install.

Verify with the command:
flatpak list
to see all the flatpaks you have currently.