Problems after updates of 30th of September 2019 / can't start kernel 4.19.0-5-amd64 (anymore...)

With my last update on 30th of September a lot of problems started, while directly after the update everything looked good - as far as I remember.

Update installed kernel 4.19.0-5-amd64 which - as I believe I started after signing the new /boot in heads.

On following boots problems with hanging systemd units started and while debugging at some time I couldn’t start the newer kernel anymore.

The boot process just stops right after starting the new kernel:

(gotta take a better picture if it would help solving this)

The former kernel started and I used apt-get to purge the newer kernel (thinking the file might have gotten broken) and re-installed it.

But still couldn’t start it. I could swear I had it running directly after signing it after initial install…

Yep, found it in syslog - started a few times that far that it logged to syslog.

1 Like

O.k. went through some trouble after the updates of 30th September.

First things first: After again (tried before already) installing the actual kernel and header-files by apt-get install linux-image-amd64 linux-headers-amd64 I still can’t boot the new kernel. Now I’ve got a better screenshot:

(stitched together from two pictures)

Beside this and the fact I can’t make my old kernel 4.19.0-2-amd64 default boot in heads I had another problem:

Could not build my displaylink evdi kernel module anymore

The build was successful, but the module could not be loaded and failed with modprobe: ERROR: could not insert 'evdi': Exec format error. In dmesg I found the error kernel: [ 1788.737481] module: x86/modules: Skipping invalid relocation target, existing value is nonzero for type 1, loc 0000000095252834, val ffffffffc12e056f.

This is what my update contained:

Start-Date: 2019-09-30  08:54:02
Commandline: packagekit role='update-packages'
Upgrade: libreoffice-style-breeze:amd64 (1:6.1.5-3+deb10u3, 1:6.1.5-3+deb10u4), libreoffice-math:amd64 (1:6.1.5-3+deb10u3, 1:6.1.5-3+deb10u4), libcomerr2:amd64 (1.44.5-1, 1.44.5-1+deb10u2), libnghttp2-14:amd64 (1.36.0-2, 1.36.0-2+deb10u1), libcom-err2:amd64 (1.44.5-1, 1.44.5-1+deb10u2), python-samba:amd64 (2:4.9.5+dfsg-5, 2:4.9.5+dfsg-5+deb10u1), linux-libc-dev:amd64 (4.19.37-5+deb10u2, 4.19.67-2+deb10u1), libreoffice-gtk3:amd64 (1:6.1.5-3+deb10u3, 1:6.1.5-3+deb10u4), libwbclient0:amd64 (2:4.9.5+dfsg-5, 2:4.9.5+dfsg-5+deb10u1), libgs9:amd64 (9.27~dfsg-2+deb10u1, 9.27~dfsg-2+deb10u2), libreoffice-core:amd64 (1:6.1.5-3+deb10u3, 1:6.1.5-3+deb10u4), samba-dsdb-modules:amd64 (2:4.9.5+dfsg-5, 2:4.9.5+dfsg-5+deb10u1), e2fsprogs:amd64 (1.44.5-1, 1.44.5-1+deb10u2), pureos-theme-gnome:amd64 (1.6, 1.7), plymouth-theme-pureos:amd64 (1.6, 1.7), python-apt-common:amd64 (1.8.4pureos2, 1.8.4pureos3), linux-compiler-gcc-8-x86:amd64 (4.19.37-5+deb10u2, 4.19.67-2+deb10u1), e2fslibs:amd64 (1.44.5-1, 1.44.5-1+deb10u2), python3-uno:amd64 (1:6.1.5-3+deb10u3, 1:6.1.5-3+deb10u4), libexpat1:amd64 (2.2.6-2, 2.2.6-2+deb10u1), ibus-gtk:amd64 (1.5.19-4, 1.5.19-4+deb10u1), ibus-gtk3:amd64 (1.5.19-4, 1.5.19-4+deb10u1), libss2:amd64 (1.44.5-1, 1.44.5-1+deb10u2), libreoffice-base-core:amd64 (1:6.1.5-3+deb10u3, 1:6.1.5-3+deb10u4), samba-libs:amd64 (2:4.9.5+dfsg-5, 2:4.9.5+dfsg-5+deb10u1), libext2fs2:amd64 (1.44.5-1, 1.44.5-1+deb10u2), libreoffice-impress:amd64 (1:6.1.5-3+deb10u3, 1:6.1.5-3+deb10u4), libreoffice-style-elementary:amd64 (1:6.1.5-3+deb10u3, 1:6.1.5-3+deb10u4), samba-common:amd64 (2:4.9.5+dfsg-5, 2:4.9.5+dfsg-5+deb10u1), libreoffice-style-colibre:amd64 (1:6.1.5-3+deb10u3, 1:6.1.5-3+deb10u4), ure:amd64 (6.1.5-3+deb10u3, 6.1.5-3+deb10u4), libreoffice-writer:amd64 (1:6.1.5-3+deb10u3, 1:6.1.5-3+deb10u4), python-apt:amd64 (1.8.4pureos2, 1.8.4pureos3), libreoffice-common:amd64 (1:6.1.5-3+deb10u3, 1:6.1.5-3+deb10u4), ghostscript:amd64 (9.27~dfsg-2+deb10u1, 9.27~dfsg-2+deb10u2), libwebkit2gtk-4.0-37:amd64 (2.24.2-1, 2.24.4-1~deb10u1), wpasupplicant:amd64 (2:2.7+git20190128+0c1e29f-6, 2:2.7+git20190128+0c1e29f-6+deb10u1), lightning:amd64 (1:60.8.0-1~deb10u1, 1:60.9.0-1~deb10u1), ghostscript-x:amd64 (9.27~dfsg-2+deb10u1, 9.27~dfsg-2+deb10u2), libsmbclient:amd64 (2:4.9.5+dfsg-5, 2:4.9.5+dfsg-5+deb10u1), samba-common-bin:amd64 (2:4.9.5+dfsg-5, 2:4.9.5+dfsg-5+deb10u1), libgs9-common:amd64 (9.27~dfsg-2+deb10u1, 9.27~dfsg-2+deb10u2), thunderbird:amd64 (1:60.8.0-1~deb10u1, 1:60.9.0-1~deb10u1), ibus:amd64 (1.5.19-4, 1.5.19-4+deb10u1), fonts-opensymbol:amd64 (2:102.10+LibO6.1.5-3+deb10u3, 2:102.10+LibO6.1.5-3+deb10u4), gir1.2-webkit2-4.0:amd64 (2.24.2-1, 2.24.4-1~deb10u1), libibus-1.0-5:amd64 (1.5.19-4, 1.5.19-4+deb10u1), gir1.2-ibus-1.0:amd64 (1.5.19-4, 1.5.19-4+deb10u1), libreoffice-pdfimport:amd64 (1:6.1.5-3+deb10u3, 1:6.1.5-3+deb10u4), uno-libs3:amd64 (6.1.5-3+deb10u3, 6.1.5-3+deb10u4), linux-kbuild-4.19:amd64 (4.19.37-5+deb10u2, 4.19.67-2+deb10u1), libreoffice-style-tango:amd64 (1:6.1.5-3+deb10u3, 1:6.1.5-3+deb10u4), pureos-artwork-base:amd64 (1.6, 1.7), libreoffice-gnome:amd64 (1:6.1.5-3+deb10u3, 1:6.1.5-3+deb10u4), linux-config-4.19:amd64 (4.19.37-5+deb10u2, 4.19.67-2+deb10u1), libreoffice-calc:amd64 (1:6.1.5-3+deb10u3, 1:6.1.5-3+deb10u4), libjavascriptcoregtk-4.0-18:amd64 (2.24.2-1, 2.24.4-1~deb10u1), grub-theme-pureos:amd64 (1.6, 1.7), linux-source-4.19:amd64 (4.19.37-5+deb10u2, 4.19.67-2+deb10u1), libreoffice-draw:amd64 (1:6.1.5-3+deb10u3, 1:6.1.5-3+deb10u4), python3-apt:amd64 (1.8.4pureos2, 1.8.4pureos3), gir1.2-javascriptcoregtk-4.0:amd64 (2.24.2-1, 2.24.4-1~deb10u1), libreoffice-avmedia-backend-gstreamer:amd64 (1:6.1.5-3+deb10u3, 1:6.1.5-3+deb10u4)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2019-09-30  08:54:44

I had to download the old version (as before the update) of linux-libc-dev, linux-compiler-gcc-8-x86, linux-kbuild-4.19 and linux-config-4.19 and install them to be able to compile the module again.

Another effect of the update was that PureBrowser didn’t work with FoxyProxy anymore and left a process running after closing the window.

I have to add that I didn’t find linux-kbuild-4.19_4.19.37-5+deb10u2_amd64.deb, but only linux-kbuild-4.19_4.19.37-5_amd64.deb .

/var/log/apt/history.log shows that there had been a version installed for which the packet file (now?) is missing in the repos…

Even though I can now compile the kernel module I still have a broken dependency:

root@system:~# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 linux-headers-4.19.0-5-amd64 : Depends: linux-kbuild-4.19 (>= 4.19.37-5+deb10u2) but 4.19.37-5 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Did I overlook the missing package in the repo, misinterpret the history log or has the file gone missing for some reason?

Let’s try eating the elephant one piece at a time. How about trying apt --fix-broken install?

Nice saying…

I already tried apt-get -f install - result:

root@system:~# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
Use 'apt autoremove' to remove it.
The following packages will be REMOVED:
  linux-headers-4.19.0-5-amd64 linux-headers-amd64
0 upgraded, 0 newly installed, 2 to remove and 5 not upgraded.
After this operation, 4989 kB disk space will be freed.
Do you want to continue? [Y/n] n

Furthermore I put the packages I had to roll back to the versions before the update on hold:

user@system:~# dpkg-query -l | grep ^h
hi  linux-compiler-gcc-8-x86              4.19.37-5                            amd64        Compiler for Linux on x86 (meta-package)
hi  linux-config-4.19:amd64               4.19.37-5                            amd64        Debian kernel configurations for Linux 4.19
hi  linux-headers-4.19.0-2-amd64          4.19.16-1                            amd64        Header files for Linux 4.19.0-2-amd64
hi  linux-headers-4.19.0-2-common         4.19.16-1                            all          Common header files for Linux 4.19.0-2
hi  linux-image-4.19.0-2-amd64            4.19.16-1                            amd64        Linux 4.19 for 64-bit PCs (signed)
hi  linux-kbuild-4.19                     4.19.37-5                            amd64        Kbuild infrastructure for Linux 4.19
hi  linux-libc-dev:amd64                  4.19.37-5                            amd64        Linux support headers for userspace development
hi  purebrowser                           68.0.2esr-1pureos3                   amd64        web browser based on Mozilla technology

I could deinstall like proposed linux-headers-4.19.0-5-amd64 and linux-headers-amd64 which wouldn’t be to bad since I can’t start linux-image-4.19.0-5-amd64 anyway and I’ll be noticed about new kernels and headers by the linux-image-amd64 meta package.

But that doesn’t solve the problem that - at least I - can’t compile the evdi module (or maybe any module?) with the latest software from the repo. Could you try to reproduce?

If compiling any module works for you, could you point me to the source? I tried to compile evdi-5.2.14 from inside this download.

What is the benefit of “holding” those packages?

Here’s the output of my uname -a on my Librem 13 v4;

Linux sigmund 4.19.0-5-amd64 #1 SMP Debian 4.19.37-5+deb10u2 (2019-08-08) x86_64 GNU/Linux

I believe you will want that kernel since it’s received some important updates.

As I described above the kernel you’re using didn’t start (screenshot above) after I installed it on my Librem13v4. I tried a few times to reinstall, but it stayed the same.

Also, with the updates of the other packages I couldn’t compile a kernel module (see above) I’m using and had to downgrade.

I want to keep this state, because I need the old kernel to be able to boot and the old other packages to be able to compile the kernel module. The problems with PureBrowsers “up-down-grade” are discussed also and I need it working. I’m not happy with it and therefore looking for a solution.

I absolutely agree and I’m short of trying kernel from the Debian repositories, because I don’t know how to get the newer kernel working.

I’m wondering why the kernel starts on your Librem and not on mine. Could you give me your command line? I changed things in my /etc/grub/default/grub and that is the only reason I could imagine making a difference beside problems with the hardware. Well, one more reason I could think about: too old version of coreboot?

BTW: Debian Buster is using a newer kernel that fixes ~20 CVEs. Debian Package version is 4.19.67-2+deb10u1 (version fits also better the versions of the other development packages for the kernel).

Did you try to compile a kernel module and try to load it successfully afterwards with the actual versions of the linux-* packages as provided from the PureOs repo?

This part is solved here. Don’t deinstall plymouth even if you don’t want any graphical output during boot.

Still open: Compiling a kernel module using the current combination of linux-image and linux-kbuild from the repo does not work.

Here’s my kernel command line from /proc/cmdline;
BOOT_IMAGE=/vmlinuz-4.19.0-5-amd64 root=UUID=5a9f3aaf-00be-4b81-bf31-e7f4024e85f4 ro i915.enable_rc6=0 quiet cryptdevice=UUID=f77bd093-9df3-409e-a3ffdf434a8c:luks-f77bd093-9df3-409e-a3ffdf434a8c root=/dev/mapper/luks-f77bd093-9df3-409e-ae24-a3ffdf434a8c resume=/dev/mapper/luks-f77bd093-9df3-409e-ae24-a3ffdf434a8c splash

What steps did you use to compile the module?

After resolving the issue that new installed kernels didn’t start because plymouth had been deinstalled on my notebook I set all packages to unhold.

For whatever reason apt-get upgrade downgraded some packages I had on hold (maybe somehow my pinning got mixed up) and with my actual packages dkms were able to compile the module.

I didn’t have the time, yet, to further look into it and find out, what might have caused all this, but for the moment everything seems to work (again).

Looking back I still don’t understand why the update pushed me e.g. linux-kbuild-4.19:amd64 4.19.67-2+deb10u1 while I was using linux-image-4.19.0-5-amd64 4.19.37-5. This seemed to have been the reason for my problems compiling modules.

Anyway, the elephant so far had two pieces and those are eaten ;-).

The problem with the downgrade of PureBrowser can’t be helped - I hope there’ll be a way to upgrade back to 68.0.2esr or newer, soon.

1 Like